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Introduction 
This document describes the BRAHMS plant uses module. In summary, the module allows you to: 

 Develop a plant uses dictionary with major and minor use categories. A default uses list can be 

imported. 

 Develop custom lookup lists for plant parts (bark, stems, etc.) and other relevant data types. 

 Link uses and common names to taxa at the species or infra-specific level, assigning literature 

source links as available and adding further details such as the plant part used, a description of the 

use, its link to a geographic region and/or links to specimen vouchers if available. Note that 

common names can also be assigned to families as in ‘The Olive family’. 

 Import species, uses and literature references from RDE files.  

 Add and edit plant uses and common names using the main species file form or directly in the main 

uses and common names dictionary. 

 Add common names (not uses) via the main botanical records form. 

 Text summaries of plant uses can be added to species and botanical records. 

 Extract (query) taxa using any available method including some that directly related to what uses 

taxa have. 

 In taxa extract files, format species uses into text fields that can subsequently be included in text 

reports which can be opened in word processors or other text editors.  

 Add literature reference lists to such reports, embedded in the report or added as a numbered 

appendix. 

 Calculate a range of statistics on species uses, for example, the number of different families, genera 

or species that have a particular use. 

 

Excel transfers  
For projects that have gathered significant data into Excel files, these data can also be processed into RDE 

format and thus transferred to BRAHMS. Note that wherever possible, it is preferable to enter the data 

direct to RDE, thus avoiding all the Excel to DBF steps. 

Excel to DBF transfers are a general function in BRAHMS used where data have been provided in Excel.  The 

function is found under File > Get external data > Import Wizard. Note that Excel files must first be saved 

as type Microsoft Excel 5.0/95.  

Excel column headings should, as far as is possible, be the same as those used in RDE. This simplifies 

transfers and avoids heavy column renaming in RDE. In Excel, column headings should be 10 characters or 

less in width (the permitted max in DBFs). 



 

 

 

 

Ideally, Excel file column headings should be the same as those used in RDE allowing simpler transfers to 

DBF, thus RDE and thus BRAHMS. 

In relation to the plant uses module, Excel file worksheets can be transferred to RDE files of three different 

types. 

 Taxa RDE file for species names 

 Taxa RDE file with special fields for uses 

 Biblio RDE file for literature 

This process is not further discussed in this document. 

 

RDE to BRAHMS 
Species and references are added to BRAHMS using standard RDE import functions. Any non-standard 

fields are added to the BRAHMS species and Biblio link files.  

Species uses do not have their own dedicated RDE file. Rather, they can be imported into an RDE type file 

with the following fields: 

 country 
 food 
 animalfood 
 medicines 
 poisons 
 materials 
 fuels 
 socialuse 
 environuse 
 weeds 
 genesource 



 plantpart 
 extrainfo 
 product 
 animal 

 

The uses data are transferred via a purpose transfer tool (in opened uses RDE file registered in Taxa RDE 

manager, choose Tools > Import species uses data.  

 

 

Non- standard fields are added to the species link file and can be used to query taxa and/or include in 

reports. 

Note that link fields can be used to tag and selected species for reporting. Thus, one could easily tag, query 

and report on all species with seed banked at the MSB. 

 

Plant uses dictionary 
The plant uses list is opened using Taxa > Plant use dictionary.  The default list of uses can be imported 

from setup file using the Tools option provided. If the file is empty, you are prompted to import the default 

list. 

The use dictionary stress uses at 2 main levels (uselevel1 and uselevel2). This is a simple hierarchical 

arrangement where uselevel1 is parent to level2.  

 

Summary of level 1 uses. 

Use Tools > Update calc fields to update calculated stats on how uses are linked in the database. Options 

are provided for: 

 Total number of links per use (CALCTOTAL). 

 Number of different families, genera, taxa, plant parts and countries per use (CALCFAM, etc.) 



 

The species uses dictionary can be imported from the Kew standard list or developed independently. Tools 

are provided to update species use totals, for example, how many different families a use is found across. 

This example is sorted on the field CALCTOTAL. Digestive System Disorders seem to be well treated or 

reported… 

When compiling formatted plant use reports in the taxa extract file, it is also possible to restrict to tagged 

uses. This offers flexibility with creating different types of report. 

 

Species form uses tab 
The species main data entry/edit form now separates common names and uses and has been further tidied 

up. Uses and common names can be linked textually to a geotext entry (in your case country) or optionally 

linked via a voucher. Voucher links are no longer obligatory. 

 

The main species form Uses/Common names tab provides options to add and remove uses and/or common 

names, linking these to literature references as available. 



 

Main uses and common names file 
All use and common name links are stored and can be viewed/edited directly in the main species – 

uses+common names file opened with Taxa > Uses and common names. 

 

The main uses and common names file provides direct editing access and also provides some additional 

Tools options, for example to tag all species based on tagged uses. 

Uses in this dictionary can be selectively tagged and these tags copied to the main species file. This is useful 

to build reports on particular uses or groups of uses. 

 

Literature 
References of different categories are stored in the main references file opened using Biblio > View/edit 

references in database. References categories are stored and can be edited using Biblio > Resource files > 

Publication categories. 

 

Snapshot view of main references file. 



Each reference is numbered and when citing literature in reports, these numbers can be used to replace 

the title. The INCLUDE field in the publication category file can be used to include/exclude references by 

category from reports. For example, you may wish to exclude less formal sources such as ‘Traditional 

knowledge’. 

 

 

The literature types file has an INCLUDE field which allows you to selectively include/exclude categories of 

literature from reports. 

When formatting uses (see below) and you select the option to use reference number, all relevant 

references are listed to the file ‘referencelist.txt’ - the location of the file is reported after formatting. 

 

Extracting/querying taxa 
Reports that include formatted uses, as with other types of species based reports (checklists, taxonomic 

revision outputs and similar) are prepared from the taxa extract file. Taxa are extracted using Taxa > 

Extract/query data. The choice of extract method will depend on which names you wish to report on. 

If your database includes synonyms, you may want to restrict the query to accepted names only. You can 

do this using the Name status option on the query form if your accepted names are marked ‘acc’ in the 

TAXSTAT field. Bear in mind that in any case, synonyms can be formatted under your list of accepted 

names. 

Extracting by tagged species is very flexible as you can first tag records in your main species file using a 

multitude of options. There are also Tools options in the main uses and common names file to transfer tags 

to the main species file. Thus by combining filters and tag options, you could easily tag species with a 

special set of known uses and then query on these. 

In the taxa extract file, you can use Tools options to format in various features including, as discussed 

below, species uses. For further details of formatting and text reporting, refer to the documents: 

http://herbaria.plants.ox.ac.uk/bol/Content/Groups/brahms/Resources/Taxonomic_accounts.pdf 

http://herbaria.plants.ox.ac.uk/bol/Content/Groups/brahms/Resources/Textreporting.pdf 

 

Bear in mind that, as with any other file, you can define field views in taxa extract files to show a 

convenient selection of fields. Use the  toolbar. 

http://herbaria.plants.ox.ac.uk/bol/Content/Groups/brahms/Resources/Taxonomic_accounts.pdf
http://herbaria.plants.ox.ac.uk/bol/Content/Groups/brahms/Resources/Textreporting.pdf


 

 

A field view showing a selection of taxa extract file fields. 

 

Formatting uses for reports 
All use formatting is carried out in the taxa extract file. Thus, the typical steps to create a report are: 

 Extract the taxa to report on using one of several methods.  

 Use the plant uses formatting tools provided to populate the taxa extract file CALCUSES memo. 

 Use text reporting to generate the formatted text report. 

In the opened taxa extract file, the formatting tools for uses is opening using Tools > Formatting for text 

reports > Species uses to CALCUSES. 

Note that CALCUSES is a temporary field only found in taxa extract files. You can store a permanent 

summary of uses in the species file memo field USES. The formatted content of CALCUSES can be used to 

help prepare the USES text. 

Text report components are all highly ‘formattable’ – the examples given here are simply examples of a 

potentially limitless range of reporting styles. 

It is possible to exclude uses and/or their references that are not tagged in the reference category file 

INCLUDE field – see Biblio > Resource files > Publication categories. Uses can also be restricted to those in 

a selected country or geo-zone. Uses can also be restricted to species uses that are tagged in the main 

species use dictionary. 

Uses can be groups by geography or my major use category. When formatting reports, you can define 

which elements to include (geography, use name, plant part, notes, etc.) 

 

 



 

Uses are formatted in the taxa extract file using the species uses formatting tools. The resulting USES memo 

can then be added to a BRAHMS text report. 

 

Formatted uses examples 
 

Example 1. Uses grouped by major use type. 

FOOD: Food additives (Unspecified parts), condimentos, Mexico [12]; Other food type (Unspecified parts), 

botanas, Mexico [12]; Unspecified Food (Unspecified parts), alimento, Mexico [12]. 

MATERIALS: Alcohols (Unspecified parts), Brebajes alcoholicos, Mexico [12]. 

MEDICINES: Abnormalities (Aerial parts), medicina fiebre, Mexico [12]; Circulatory System Disorders (Aerial 

parts), Medicina baños de asiento, Mexico [12]; Digestive System Disorders (Aerial parts), medicina Tos, 

Mexico [12]; Infections/Infestations (Aerial parts), medicina problemas intestinales, Mexico [11]; 

Inflammation (Unspecified parts), medicina inflamacion, Mexico [11]; Injuries (Aerial parts), medicina 

heridas, Mexico [12]; Muscular-Skeletal System Disorders (Unspecified parts), medicina espasmos, Mexico 

[12]; Pain (Unspecified parts), medicnina dolor, Mexico [12]; Pregnancy/Birth/Puerpuerium Disorders 

(Unspecified parts), Probocar aborto, Mexico [12]; Respiratory System Disorders (Aerial parts), medicina 

problemas respiratorios, Mexico [12]; Skin/Subcutaneous Cellular Tissue Disorders (Aerial parts), medicina 

granos, Mexico [12]. 

 

Example 2. Uses grouped by major use type but restricted to uses that include the word ‘disorder’. 

MEDICINES: Circulatory System Disorders (Aerial parts), Medicina baños de asiento [12]; Digestive System 

Disorders (Aerial parts), medicina Tos [12]; Muscular-Skeletal System Disorders (Unspecified parts), 

medicina espasmos [12]; Pregnancy/Birth/Puerpuerium Disorders (Unspecified parts), Probocar aborto 

[12]; Respiratory System Disorders (Aerial parts), medicina problemas respiratorios [12]; 

Skin/Subcutaneous Cellular Tissue Disorders (Aerial parts), medicina granos [12]. 



 

  



Example 3. A text report with a few more fields added 

LEGUMINOSAE-MIM  

 

Acacia senegal var. rostrata  

Description:-3m tall tree with smooth grey bark peeling out to reveal yellow/ straw papery bark, 3 prickles at each node, 2 pointed and 1 

hooked. Distribution:-N.W.C. of the country, in a mopane woodland mixed with Acacias and grassland, white limestone soils. GPS: 21 17' 

5.00" S; 25 11' 0.17" E. Alt: 955. Abundance: Uncommon. Uses:-ANIMAL FOOD: Herbage (Leaves), Black Rhino, Botswana [1]; FOOD: 

Gums/Mucilages/Resins (Exudates), Botswana [5]; MATERIALS: Gums/Resins (Exudates), Botswana [12].  

 

 

MALVACEAE  

 

Azanza garckeana (F.Hoffm.) Exell & Hillc.  

Description:-A shrub of about 4m with hairy leaves which are feint green in colour underneath, Entire margins, Bark greyish and smooth, 

Leaves are large,3-5 lobed, broad and veined from the base.  Distribution:-Found in many parts of Botswana, grows on loam soils. Open 

woodland, clay-loamy soils exposed to full sun, Spread throughout the country, except for the deep sand areas as kgalagadi. Uses:-ANIMAL 

FOOD: Flowers (Flowers), Botswana, ; Herbage (Leaves), Game and livestock, Botswana, ; ENVIRONMENT USE: Agroforestry (Entire plant), 

Botswana [13]; Ornamentals (Entire plant), Botswana, ; Shade/Shelter (Entire plant), Botswana [21]; Soil improvers (Leaves), Botswana, ; 

FOOD: Food additives (Fruits), Makes jelly, Botswana [1]; Gums/Mucilages/Resins (Fruits), Botswana [12]; Vegetables (Leaves), Botswana 

[5]; FUEL: Charcoal (Stems), Botswana [12]; Fuelwood (Stems), Botswana [1]; MATERIALS: Fibres (Bark), Botswana [21]; Wood (Stems), 

Botswana [12].  

 

 

1. Van Wyk, B.; Van Wyk, P. (1997). FIELD GUIDE TO TREES OF SOUTHERN AFRICA. Not given [Book] 5. Heath, A.; Heath R.; Goyder D. (eds.) 

(2009). FIELD GUIDE TO THE PLANTS OF NORTHERN BOTSWANA INCLUDING THE OKAVANGO DELTA. Not given: 1-588 [Book] 12. Roodt, B. 

(1998). THE SHELL FIELD GUIDE SERIES: PART I: TREES AND SHRUBS OF THE OKAVANGO DELTA. MEDICINAL USES AND NUTRITIONAL 

VALUE.. Not given: 1-224 [Book] 13. Motlhanka, D M T; Nthoiwa, G. .P. (2013). ETHNOBOTANICAL SURVEY OF MEDICINAL PLANTS OF 

TSWAPONG NORTH, IN EASTERN BOTSWANA: A CASE OF PLANTS FROM MOSWUE AND SEOLWANE VILLAGES. Not given [Scientific paper] 

21. Mojeremane, W.; Legwaila, G. .M.; Mogotsi. K. K.; Tshwenyane, S. .O. (2005). MONEPENEPE (CASSIA ABBRIVIATA): A MEDICINAL PLANT 

IN BOTSWANA. International Journal of Botswana 1(2): 108-110 [Scientific paper] 

 

 

Reference appendix example 

 

References can be formatted in different ways using further format control options. A simple example: 

 

1. Van Wyk, B.; Van Wyk, P. (1997).  FIELD GUIDE TO TREES OF SOUTHERN AFRICA.  Not given [Book]  

2. Behr, K. (6).  PLANTZ AFRICA DATABASE.  Not given [Online database]  

3. Lecheng village elder INTERVIEW OF  ELDERS WHO CAME FOR  A DAY ESCORT AT THE EXPEDITION- LECHENG VILLAGE.  Not given 

[Traditional knowledge]  

4. Anonymous villager INTERVIEW FROM A VILLAGER, -TOROMOJA, BOTETI, CENTRAL, AND EXPEDITION GUIDE (ELDER) IN 

LECHENG, TSWAPONG, CENTRAL.  Not given [Traditional knowledge]  

5. Heath, A.; Heath R.; Goyder D. (eds.) (2009).  FIELD GUIDE TO THE PLANTS OF NORTHERN BOTSWANA INCLUDING THE 

OKAVANGO DELTA.  Not given: 1-588 [Book]  

6. Maunatala Village elders INTERVIEW FROM VILLAGE ELDERS WHO ACCOMPANIED UPP DURING EXPEDITION, - MAUNATALA 

VILLAGE.  Not given [Traditional knowledge]  



7. Tsetseng village elders INFO FROM VILLAGE ELDERS-TSETSENG VILLAGE KWENENG.  Not given [Traditional knowledge]  

8. Village locals VILLAGE LOCALS, QANGWA VILLAGE, NORTH WEST, NATA VILLAGES.  Not given [Traditional knowledge]  

9. Pilikwe Trust committee members (2013).  PILIKWE TRUST WORKSHOP.  Not given [Traditional knowledge]  

10. Van Wyk, B.; Van Oudtshoorn, B.; Gericke, N. (2000).  MEDICINAL PLANTS OF SOUTH AFRICA.  Not given: 1-304 [Book]  

 


