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ABOUT THIS GUIDE 
 

 
 
This guide is a training guide, not a manual. More comprehensive documentation is available on 
http://dps.plants.ox.ac.uk/bol/BRAHMS/Documentation/Index. 
 
 
The guide is suitable for beginner and intermediate levels, addressing collection management and research topics.  
On formal courses, the guide provides course structure.  
 
 

 

 

Syntax used: 

 
The text Admin > Users and access permissions means:  

 
Select the menu option Admin followed by the menu option Users and access permissions. 

 
 

Using the function key template: 

You can cut out the function key template from the guide, fold the page appropriately and keep it near your 
keyboard. Using function keys speeds things up. 

 
 
The correct way to quote this guide is óFiler, D.L. (2010). Botanical Research And Herbarium Management 
System training guide. Department of Plant Sciences, University of Oxford.ô 

http://dps.plants.ox.ac.uk/bol/BRAHMS/Documentation/Index
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FUNCTION KEY TEMPLATE 
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INSTALLATION 

Training course folder ï do you have it? 

Course instructors may have and distribute a zip file which will open to create the training course folder (illustrated 
below). The training course folder provides a useful folder structure and it includes all the resources you need.  
 
If you do not have this folder - no problem. You can separately download  as follows: 

 
BRAHMS: http://dps.plants.ox.ac.uk/bol/BRAHMS/Software/Index     
Conifer database: http://dps.plants.ox.ac.uk/bol/BRAHMS/Sample/Conifers 
DIVA GIS: http://www.diva-gis.org/ 
Sample base maps data:  http://dps.plants.ox.ac.uk/bol/BRAHMS/GroupResources/Index 

BRAHMS is already installed on your PC? 

If you previously installed BRAHMS for testing, delete your BRAHMS6 folder. Also, delete all \tempfiles-brahms 
folders. Then proceed to install the new system. 
 
If you have one or more active BRAHMS databases, follow the link for installation help on 
http://dps.plants.ox.ac.uk/bol/BRAHMS/Software/Index 

System installation 

¶ Locate the brahms6.zip file in the folder as shown below OR your software download file. 
 

 
 

¶ Extract the software zip file to the top level of your C: drive (usually referred to as óLocal Disk (C:)ô or 

óDRIVE_C (C:)ô. This will create a folder called BRAHMS6 ï in this case, C:\BRAHMS6.  
 

 You can safely extract the software zip elsewhere. The software folder will always be created relative to the 
folder you choose. 

Activation key 

¶ If you do not have a key in your BRAHMS training course \ Activation key folder, login to the BRAHMS 
website and download your key from http://dps.plants.ox.ac.uk/bol/BRAHMS/Members. If you cannot 
login, please register using the menu option provided on the home page. 

¶ Copy the file BRAHMSKEY.MEM to the BRAHMS6 folder. 

Creating a desktop shortcut to BRAHMS 

¶ Locate the file BRAHMS.EXE (represented by a blue drum) in the BRAHMS6 folder. The ó.exeô file 

extension may be hidden. 

¶ Right-click on this file and choose Send to > Desktop (create shortcut). 

 

 
 

¶ Right-click on the new shortcut, choose the Rename option and type in ñB R A H M Sò.  

 

http://dps.plants.ox.ac.uk/bol/BRAHMS/Software/Index
http://dps.plants.ox.ac.uk/bol/BRAHMS/Sample/Conifers
http://www.diva-gis.org/
http://dps.plants.ox.ac.uk/bol/BRAHMS/GroupResources/Index
http://dps.plants.ox.ac.uk/bol/content/Documentation/HTMLHELP/brahms/BRAHMS.htm?%7B5AEFF6B2-B0A2-4126-8E2B-8F35F0A0A21C%7D.htm
http://dps.plants.ox.ac.uk/bol/BRAHMS/Members
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INSTALLING THE CONIFER DATABASE 

About the Conifer database 

 

 

The conifer database has been provided by Aljos 
Farjon, RBG Kew - a taxonomist of 
Gymnosperms and chair of the IUCN Conifer 
Specialist Group.  
 
If you wish to use the data for a research 
publication or any other purpose beyond training, 
kindly consult first with A.Farjon@kew.org. 
 

 
 
The conifer database includes all published conifer names with nomenclatural details, IUCN conservation codes, 
TDWG geographic distribution codes, species descriptions and more. It also includes specimen data across the 
group, almost all referenced for mapping. Descriptions have been truncated to a maximum of 500 characters.  
 
The conifer database has been used to help publish four publications:   
 

¶ A taxonomic monograph on Pinus for Latin America (Farjon, A. & Styles, B. T., 1997. Flora Neotropica 
Monograph 75, The New York Botanical Garden  

¶ A World Checklist And Bibliography of Conifers, Aljos Farjon, 1998, Kew Publishing  

¶ A Monograph of Cupressaceae and Sciadopitys, Aljos Farjon, 2005. Kew Publishing 
 

¶ A Handbook of the World's Conifers. Publication: April 2010 by E. J. Brill (www.brill.nl) 

  

       

Download database from BRAHMS website 

If you do have it, the database can be downloaded from http://dps.plants.ox.ac.uk/bol/BRAHMS/Sample/Conifers.  

Installing the Conifer database 

¶ Locate the coniferdatabase.zip file in the folder as shown below OR your sample database download file. 
 

 
 

¶ Extract the zip file to the top level of your C: drive (usually referred to as óLocal Disk (C:)ô or óDRIVE_C 

(C:)ô. This will create C:\ BRAHMSDATA-CONIFERS.  
 

 If you have installed to another folder,  you will have problems later on with this guide. In this case, move the 
folder to C: to create c:\brahmsdata-conifers. 

 

https://nexus.ox.ac.uk/owa/redir.aspx?C=dd350b765cad498c984b8c63ba13be6f&URL=http%3a%2f%2fwww.brill.nl
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The installed database folder includes several subfolders. Of these the most important is DATABASE. The 
myrdefiles, myreports and mysavedfiles folders are empty suggested locations for files of those types. Other 

folders may be provided. 

Register the Conifer database in BRAHMS 

¶ Log into the TEMPLATE database using user name Administrator and password A. 

¶ Select File > Database manager. 

Assuming the conifer database is not yet registered, click the  toolbar. Add an entry for the Conifer database 
as shown in the following screen. 
 

 Note that the Database folder is pointing to the DATABASE subfolder within BRAHMSDATA-CONIFERS. 

 

 
 

 
 
Note that the database folder is pointing to the DATABASE subfolder.  
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PREPARE FOR MAPPING 
 
This step may be done now or later on. 

Installation steps 

If you do not have a special training course folder and wish to install DIVA, you can visit: 
 
DIVA GIS: http://www.diva-gis.org/ 
Sample base maps data:  http://dps.plants.ox.ac.uk/bol/BRAHMS/GroupResources/Index 
 

 

¶ Locate the folder óC:\ BRAHMS training course \ Mappingô. 

 

  
 

¶ Extract themapping. zip file to the top level of your C: drive (usually referred to as óLocal Disk (C:)ô or 

óDRIVE_C (C:)ô. This will create C:\ MAPPING.  

Installation of DIVA GIS 

If you wish to install DIVA (you may already have ArcView or another GIS): 
 

¶ Locate the file SETUP.EXE in the folder Mapping \ Diva software OR from your download 

¶ Run this setup. This will install DIVA GIS on your PC. 

Mapping folder explained  

 

 
 
 

  It is very convenient to keep all your mapping resources and files under one main folder (here \MAPPING). In 
particular, it is useful to have the óbasemapsô folder adjacent to the folder ómapping points from BRAHMSô folder 
 
 

Basemaps Country and internal admin boundary .SHP for use with DIVA and/or 
ArcView. 
 

CAT out 
 

A folder for Conservation Assessment results generated by the CATS 
tool (ArcView users only). 

Diva software 
 

Diva setup files ï ready to install. Just run the SETUP.EXE file.  

ESRI extensions 
 

CATS.AVX file and PDF file documenting the Conservation 
Assessment Tools. 
 

Mapping points from BRAHMS 
 

Empty folder for your BRAHMS generated map files. 

Projects 
 

Empty folder for you to save APR and DIV projects to. 

 
 
 

http://www.diva-gis.org/
http://dps.plants.ox.ac.uk/bol/BRAHMS/GroupResources/Index
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THE BRAHMS HELP FILE 

Move or copy the help file to your desktop 

If you do not have a special training course folder, the help file is available on 
http://dps.plants.ox.ac.uk/bol/BRAHMS/Documentation/Download/ 
 

¶ Locate the folder óC:\ BRAHMS training course \ Help fileô. 

 

 
 

¶ Drag the file BRAHMS.CHM onto your desktop. 

 

 The CHM help file will not work correctly if stored on a network drive. Locate it on your local drive. 

Opening the help file and reading a topic 

¶ Using your file manager (e.g. Windows Explorer), locate and dbl-click the help file icon to open. Note 
there are Contents, Search and Favorites tabs.  

¶ Click on the Contents tab.  

¶ To open a section (purple book icon),click on the left hand side +.  

¶ To display a topic, click on the page you want to open. 
 

 
 
A screen shot of the help file with the Contents tab selected and a topic selected. 

Contents tab 

Using the help file Contents tab, locate the following topics: 
 

¶ System fundamentals  > Logging in and out 

¶ Mapping > Producing maps > Google Earth mapping 

¶ Rapid Data Entry (RDE) > RDE file manager > Creating and registering files 

¶ Troubleshooting > Index problems 

Search tab 

Using the help file Search tab, search for the following topics. Remember to Dbl-click a page to goto/open a 

search result. 
 

¶ óActivation keyô 

¶ óFunction keysô 

¶ óNavigationô 

¶ óAdd synonymô 

¶ óBacking upô 

http://dps.plants.ox.ac.uk/bol/BRAHMS/Documentation/Download/
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LOG IN/OUT AND EDIT THE USER FILE 

Logging in  

Initially, the project to open is the Template project stored in the template\database folder.  This is an empty 

database provided with BRAHMS. 
 

¶ To log into a newly installed system, enter password óAô followed by <Enter>.  

¶ Choose Advanced mode, and Single user  (defaults). 

 

 

A typical login screen with a user entering in single-user mode. 

Adding your username  

¶ On the main menu, select Admin > Users and access permissions.  

 

 
 
Selecting an option on the main menu 

 
 

¶ Click  on the main toolbar to add a new record.  

¶ Add your first and last name (maximum of 2 names) and a password.  

¶ All the other fields in this file can be left with their default values.  

¶ Note that the field ACCESS GROUPS defaults to óALLô. This means that the user has full administrative 
access to the database. 

 

 On networks, system administrators can set access permissions for each user. 
 
 

 
 

The user file opened with the main toolbar selectively enabled 

Logging out 

¶ Log out of BRAHMS using File > Exit BRAHMS. This closes down open database files. 



 19 

Logging in with your own user name 

¶ Now log in again but this time choose your own user name. A new folder will be created for temp files ï these 
files are explained in the next section. 

 

 You should always log into BRAHMS using your personal log in name rather than Administrator. On networks, 
system administrators can set access permissions for each user. 

Add your username to your desktop shortcut 

¶ Right-click on your BRAHMS desktop shortcut, select Properties and add your name as shown below. 

This speeds up login, especially when the user file has many entries. 
 

 
 

 A maximum of 2 words (first and last name) is permitted when editing this option. 
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TEMPFILES-BRAHMS WORK FOLDERS 

What are tempfiles folders? 

Tempfiles-brahms folders are user by BRAHMS for various temporary files. Also, when you make a query, the 
results are sent to this folder. 

Folder creation 

When you log into BRAHMS, the system checks if you have a tempfiles folder. If not, one will be created 
automatically and called '\tempfiles-brahms'. The exact name and location of this folder depends on your 
username and project code settings. A typical example is 'C:\tempfiles-brahmsA'.  
 
Each user on a given workstation has a separate work folder. If a user has more than one project, several sub-
folders will be created, one per project.  
 

 
 

A typical tempfiles folder 

Folder deletion 

Normally, you do not need to delete these folders ï unless there is a specific problem. If you delete work folders, 
BRAHMS re-creates these when you next log in. No data are lost. To delete your tempfiles folders(s): 
 

¶ Log out of BRAHMS 

¶ Locate the folder(s) c:\tempfiles-brahmsa (the name may vary slightly). 

¶ Delete the folder(s). 

¶ Log in again and note that the work folder is re-created. 
 
 

 
 
Work folder paths are auto added to the user file LOCALPATH field. Where necessary (on some network or 
Terminal Server systems), path drives and names can be edited. The default is always local disk C:. 
 

When to delete tempfiles folders 

When you upgrade BRAHMS, you will be asked to delete your tempfiles folders. 
 
If you experience a system crash or see any messages about bad index files, it is recommended that you delete 
your temporary work folder(s).  
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PERSONAL AND SYSTEM-WIDE CONFIGURATION  
 
Some configuration settings are system-wide and apply to all users of the current database. Others are personal 

and are associated with individual users. If using BRAHMS as a single user system, these categories can be 
treated equally. Personal settings are stored in the user file and preferences added here will apply to that user in 
any database he or she opens. System-wide settings are stored as part of a given database and apply only to that 
database. 

Personal settings examples 

If running BRAHMS on a network with multiple users, normally, only the system administrator will have access to 
the Admin menu and thus system-wide settings. In this case, you can edit your personal settings by selecting 
Utilities > My setup/profile. There are many configuration options ï here are a few examples: 
 
Active modules 
 

¶ Select Utilities > My setup/Profile > Active modules. Here, you can include/exclude main menu 

options. 
 
Data grid options 
 

¶ Select Utilities > My setup/Profile > Data grids. Here, you can experiment with different data grid 

settings, for example, whether to select text on entry to a field.  
 

 
 
Many useful features can be found under the Data grids tab. Settings are remembered for each user. 

 
 
Highlight colours 
Select Select Utilities > My setup/Profile > Highlight colours. Here, you can set colour preferences for tags, 

column clicks, the zoom window and a few other things. 
 
Home herbarium 
Select Select Utilities > My setup/Profile > Home Herbarium to add your own herbarium code (if relevant). 

BRAHMS uses this to give preference to your herbarium when displaying barcodes and/or accession numbers ï 
and also for certain functions linked to loans management, 

System-wide setting examples 

 
Mapping configuration options 
 

¶ Select Admin > Project configuration > Maps. Choose the software you are likely to use the most.  

¶ On the same tab, choose the map units you use most commonly. The choices are 
Degrees/Minutes/Seconds (DMS), Decimal degrees (DD) and Degrees and decimal minutes (DM).  

 
Date format 

¶ Select Admin > Project configuration > Dates and choose your date language/format. Note that month 
names for the 5 styles can be edited using Admin > Month names. 
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DATABASES AND DATA FILES 

Databases 

When you log into BRAHMS, you need to select a database/project to open. The BRAHMS system is delivered 
with one empty database called Template. This can be copied to make entirely new database projects. 

 

 
 
 
 
 

Data files 

Many of the BRAHMS menu options open up data files as shown here with botanical records. Data files consists 
of records and columns.  
 

 
 
BRAHMS is a relational database. Several of the columns you see in the above screen, for example the family 
name, are held in separate tables but are displayed together with botanical record data. 
 
When you open any file, the menu options change to the data editing menu. This is very different to the main 
system menu. 
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OPENING AND CLOSING FILES 
 
The purpose of this exercise section is mostly to provide orientation with where some of the more commonly used 
options are on the menu system. 

Log into the Conifer database 

 

 
 
When you log in, select the Conifer database, not the Template database. 

Locate, open and close a selection of database files  

After opening each file, you can simply close the file again using Alt+X or click on the top right close window X.  
 
Missing menu options? 
If you do not see a menu option, for example Maps,  select Utilities > My setup/Profile > Active modules é to 

switch the missing menu option on. 
 

 
 
Opening the main species file 
 

 

¶ Main species file:  Taxa > View/edit SPECIES in database 

¶ Main genus file:  Taxa > View/edit GENERA in database 

¶ Main family file:  Taxa > View/edit FAMILIES in database 

¶ Taxonomic status categories: Taxa > Resource files > Taxonomic status  

¶ Main botanical records file: BotanicalRecords > View/edit botanical records in database 

¶ Main specimen file:  BotanicalRecords > View/edit specimens in database 

¶ Herbarium list:  BotanicalRecords > Herbarium list 

¶ Type categories:  BotanicalRecords > Resources files > Type categories 

¶ Specimen categories  BotanicalRecords > Resources files > Specimen categories 

¶ Country list:   Geo > View/edit countries in database 

¶ Main gazetteer:  Geo > View/edit gazetteer in database 

¶ People:   People > View/edit people in database 

¶ Map projects:  Maps > Saved ArcView (APR) and DIVA (DIV)  projects 

¶ Map colours:   Maps > Colours and opacity 

¶ Image library:  Images > View/edit images registered in database  

¶ Month names  Admin > Month names 

¶ Custom lookup values  Admin > Custom lookups 

¶ Database manager  File > Database manager 
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THE MAIN SYSTEM TOOLBAR  
 

 

 Tag toggle. Adds or removes * to the TAG field. Tagging used throughout BRAHMS. 

 Delete toggle. Adds or removes * to the DEL field. To remove records marked in this 
way, select Edit > Delete options > Remove records marked for deletion. Deletion 

throughout BRAHMS is a two-stage process.  

 Add a record. In selected modules including RDE, the add function can be configured 

using the  toolbar. 

 Copy settings. Configure what happens when a new record is added.   

 Access custom designed forms, if available.  

 Opens a data file.  

 Open/close a linked data file.   

 Define and/or select a field view.   

 Find a record using custom find form.  

 
Open Zoom pane - display fields for the current record in the right window pane.  
Right-click the zoom window for more options.  

 Reduces field widths by a %. Right-click to increase field widths.  

 
Auto fit data columns. 

 Open the sort form to carry out compound sorts. For simple field sorts, right-click the 
column header name. A list of convenient sorts usually available on the Fastsort 

menu option.  

 Set a filter on current field or another field as selected. Multiple filters can be set. To 
clear all filters, right-click filter button or use the Clear filters option on the Filter form.  

 Analyse data in selected column. 

 Display taxa in tree view with options to navigate/filter on taxa. 

 
Open the FoxPro command library.  

 Link the current record to any reference stored in your reference lists. 

 Open image viewer + image toolbar 

 Link documents such as PDFs, Excel, Videos, whatever to any record. 

 Copy/Save as options. 

 Check and transfer the contents on an RDE file to BRAHMS. 

 Design and generate reports from any BRAHMS module.  

 Create maps using your preferred GIS. 

 Open current file in Excel.  Respects current filters, sort order and field selection.  

 Edit comments for records. Activate if the COMMENTS field is available in the current 
file. Right-click to restrict the view to records with comments.  

  Field level documentation and local data rules for current file. 
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DATABASE FUNDAMENTALS  

Basic record and field navigation  

¶ Select Taxa > View/edit species in database to open the main species file. 

 

¶ Press ENTER (or TAB) several times to move forwards to the next fields.  

¶ Press <SHIFT>+ENTER to move backwards to the previous fields. 

¶ Use arrows or the scrollbar to move up and down records. 

¶ Press the F12 key to go to column 1 

¶ When in the first column, you can press the left arrow to go to the last column. 
 

 The Navigation toolbar on the top right side of the screen can be used for record navigation. 

Locating records using  

¶ In the main species file, use the  toolbar to locate the species name Pinus devoniana. Entering ópin 
devô in the search for box should be enough. Note that Pinus devoniana is an accepted name and has 

óaccô in the TAXSTAT field. 
 

 
The species search form with Goto accepted option selected. If you choose a synonym, the system will direct 
you to the accepted name 

 

 Selected options such as óGoto accepted nameô on the above form are saved as a personal preference. 

Locating records using  

The tree view control is used to display your taxa in a searchable tree. 
 

¶ In the main species file, select the  toolbar to build a tree view. 

¶ Click on a family name to go to and filter on that family. 

¶ Click ó+ô to list genera in that family and click on a genus name to go to and filter on that genus. 

¶ Click ó+ô again to list species in the selected genus and click on a species name to go to that species. 
 

¶ Using the  tree view option, navigate to the species Fitzroya cupressoides in the Cupressaceae. 
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Tag options introduced 

Record tagging is used throughout BRAHMS for marking/selecting records. When you tag a record, ó*ô is added 

to the TAG field.  

 
Most files have a TAG field at the start of the record 

 
 
Some example uses of tags: a) to create groups of records (a tag profile); b) to copy selected records to a new 
file; c) to extract/query data; d) to restrict an analysis to tagged records; e) to restrict a map to include tagged 

records. 
 

¶ Select Taxa > View/edit species in database to open the main species file. 

¶ Select Tag > Tag all with * to tag all records. 

¶ Select Tag > Clear all * tags to clear all tags. 

¶ Click   or press F6 several times to tag some records. If a record is already tagged, the tag will be 

removed. 
                                                 

 
 

Screen shot of the Tag menu options 
 

¶ Select Calculate > Count tagged with *  

¶ Select Calculate > Count untagged. 

 

 To quickly set a filter on tagged records (restrict to tagged records), use Tag > Show tagged. 

Tag custom commands 

You can use custom commands to tag records. For example, the main species file includes the field YEAR (=year 
of publication). We want to tag all records published before 1900 
 

¶ Select Taxa > View/edit species in database to open the main species file.  

¶ Select Tag > Clear all tags. 

¶ Select Tag > Tag for é and enter the command as prompted:  YEAR < 1900 

¶ Click OK to tag these records. 
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Try a more complex example: 
 

¶ Select Tag > Tag for é and enter the command as prompted:  

 
TAXSTAT = 'acc' and YEAR > 1850 and YEAR <= 1880 

 

 The operator <= means: less than or equal to. Note that acc is surrounded by quotes as it is text. Numbers 

such as 1850 are not. 

Learning to use more function keys 

Many tasks are faster using function keys rather than your mouse. For example, F6 can be used instead of  to 

tag records. 
 

 
 
The BRAHMS Function Key template is available in the folder BRAHMS6\template\function key template.  

 

¶ Select BotanicalRecords > View/edit botanical records in database. 

¶ Enter Alt+A several times to add blank records.  

¶ In the BOTRECCAT field, press F9 to lookup the available options for that field. 

¶ Use F6 to tag the new records.  

¶ Use F7 to mark all these new records for deletion. Although note a useful option is Edit > Delete 
options > TAG->DEL. 

¶ Select Edit > Delete options > Remove records marked for deletion.  

¶ Enter Alt+X to close the screen. 

 

 The template form can be opened in a separate window using SHIFT+F1.  

Setting simple filters  

Filters restrict your view of the data to a selected group of records.  
 

¶ In the main species file, locate and click once on the text óaccô in the field TAXSTAT (choose any record). 

¶ Now right-click on the TAXSTAT column header and choose Filter by selection. This will set a filter to 

show only óaccô names i.e. accepted names. 
 

 
 

Filter by selection is one way to quickly filter/restrict records on the selected text in any field 
 
 

¶ Then choose Tag > Tag all with *.  This will tag all the accepted names. 

¶ To remove the filter, right-click on the  toolbar.  

¶ Try setting filters on some other fields. 
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 To quickly set a filter on tagged records, use Tag > Show tagged. 

Setting compound filters 

You can add multiple filters at the same time using the  toolbar. 
 

¶ Select Taxa > View/edit species in database to open the main species file. 

¶ Use the  toolbar to open the main filter form. 

¶ Edit the form so that the option reads field=family, operator=includes; value=cupr. 

¶ Click the  button to apply the filter. 

¶ Re-open the filter form and add a second command: field=taxstat, operator=includes; value=acc.  

¶ Apply the filter. This will set the filter to accepted names in the Cupressaceae. 

¶  

 
 

Donôt panic! The syntax on the left is added automatically 

Simple record sorting 

 

¶ Still in the main species file using the menu options: 

¶ Select FastSort > Family + species to sort the file A-Z by species within family.  

¶ Now select FastSort > Species name to sort this file by the species name only.  

¶ Right-click on the column header for the field SP1 and choose Sort Ascending. 

¶ Right-click on the column header for the field FAMILY and choose Sort Unique to show one record per 

different family. 

¶ To remove the current file sort, right-click on the  toolbar. 

 

 Compound sorts using multiple fields and the  toolbar are discussed later. 

Calculate menu and toolbar options 

Calculate options provide counts and summaries of your data. Aside from using count tagged and untagged as 
above, the most commonly used option is Calculate > Analyze data in selected column, also activated using 

the  toolbar. 
 

¶ Open the main species file. 

¶ Right-click the toolbar to ensure no filters are set. 

¶ Click anywhere in the TAXSTAT field (data or header). 

¶ Click on the   toolbar. 
 

 
 



 29 

 
 
The record counts here refer to the number of species records for each TAXSTAT value. 

 
Try the following:  
 

¶ Use   in the FAMILY field to calculate the  total number of taxa per family. 

¶ Use   in the GENUS field to calculate the  total number of taxa per genus. 

¶ Use   in the YEAR field to calculate the  total number of taxa per publication year. 
 
 

¶ Apply a simple filter on the FAMILY field to filter on the family Podocarpaceae. 

¶ With this filter set, click once in the AUTHOR1 field and then use   to display the total number of taxa 
in this family published per different author. 

¶ To clear all filters, right-click on the  toolbar. 
 

¶ Apply a simple filter on the TAXSTAT field to show only acc names (as described earlier). Locate the 

field IUCN in the main species file. Click in this column and then use   to display the total number of 

taxa per IUCN category. Also open the analysis result in Excel using the option provided on the  form. 
 

 
 
 

¶ Open the main genus file (option on the Taxa menu). Using the  toolbar option, produce a summary 

table of the total numbers of genera per family. Which family has the most genera? 
 
 

 Results generated by the  toolbar can be open in Excel and used to prepare charts and graphs. 
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The Zoom window 

The   toolbar displays all non-empty fields in a mouse-sensitive window to the right of the main window. 
Clicking on the Z o o m button a second time closes the Zoom window.  

 

¶ Select Taxa > View/edit species in database to open the main species file. 

¶ Click on the  toolbar to open the zoom pane. 

¶ Double click on a field name in the Zoom pane to go to and highlight that column. 

 

 
 

When you move to a new record in the main file, the Zoom window is updated 
 

¶ Click on the  toolbar to close the zoom window. 

¶ Using the simple filter method learnt above, apply a filter to show only those names with TAXSTAT = acc. 

¶ Now Click now on the  toolbar to open the linked data file (bottom of screen). Linked data are 
explained more in a subsequent section. 

¶ With the link file open, click on the  toolbar to open the zoom pane. Data from link file fields will be 
included in the zoom pane. 

 

 If you right-click in the Zoom window, you can adjust window properties. One of the options is to include 

blank fields (these are excluded by default). 

Using the  toolbar to get field level help 

¶ Select BotanicalRecords > View/edit botanical records in database. Click in the PREFIX field and 

then on the  toolbar to read about this field.  

¶ Open one of the taxon files (family, genus or species) and, using  toolbar, read about the SYNOF field. 
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Physical and translated field names 

The field headings you see on the screen are sometimes different to the real field names in the data file. This 
makes them more readable. However, with some functions (e.g. creating reports and using Foxpro commands), 
you must know and use the real field names. 
 

¶ Select BotanicalRecords > View/edit botanical records in database and locate the field name with 

the name MAJOR COUNTRY AREA. 

¶ Hover your mouse over the column header and note that the physical field name here is GAZ.MAJOR. 
This means that the field is in a related file with short name GAZ and in that file, the true field name is 
MAJOR. 

 

 

Memo fields 

Memo fields hold text of any length. They are used for notes and descriptions. You can copy and paste text into 
memo fields or drag selected text from your word processor files. 
 

¶ Select BotanicalRecords > View/edit botanical records in database.  

¶ Locate the field PLANT DESCRIPTION. 

¶ Double-click on a memo to open it or use Ctrl+M.  

¶ Enter Ctrl+W to close and save - or Esc to close a memo and abandon edits. 

 

 Memo fields with óMemoô rather than ómemoô have data.  You can open and edit several memo fields at the 
same time in a file. 

Field Views 

Field views are used to restrict the fields you see when viewing data grids. You can create and save multiple 
views for each type of data (species, collections, extract files, RDE files, etc.). They are useful for different editing 
tasks or simply viewing your data. 
 

¶ Select BotanicalRecords > View/edit botanical records in the database.  

¶ Select the  toolbar to define/select field views.  

¶ Initially, select Exclude all to remove all fields then choose fields by numbering in the POS column. 

¶ Create a field view to show the fields TAG, DEL, COLLECTOR(S), NUMBER, YEAR, FAMILY and 
FULLNAME. 

 

 
 
The field selection form with the option Show selected fields ticked. 

 

¶ Select Save as new to save and select this view, choosing an appropriate name for this field selection 

as prompted. 



 32 

 
You can add and save many field views per file. The required view is selected using the dropdown field view list 
on the main toolbar.  All field views are registered centrally under Admin > Field views and settings. You can 

remove views here. 

Edit data in form mode 

Experienced BRAHMS users usually find working in data grids faster and more flexible than working with forms. 
However, with some files, especially those with many fields, data can also be edited using tabbed dialogue screen 
forms. 
 

 
 

¶ In the main species file, locate the name Taiwania cryptomerioides using the  toolbar. 

¶ Select the   toolbar to open the data form. 

¶ Click on the Nomenclature tab to view/edit synonyms of this species. 

Calculated fields 

Calculated fields are summaries of data, often handy for reporting and data checking. These fields are not auto-
updated ï they must be updated periodically using the Calculate menu options provided. Calculated field options 

are available in most of the main files. 
 

¶ Open the main country list by selecting Geo > View/edit countries in database. 

¶ Select Calculate > Update calculated fieldsé.  

¶ Select Select all then Process.  

 
Calculated totals are added to fields such as COLLECTION TOTAL, SEED TOTAL, SPECIES TOTAL, etc.  
 

¶ Locate the column COLLECTION TOTAL, right-click the column header name and choose Sort 
Ascending. Go to the bottom of the file to see the highest values. 

¶ Close the country file. 
 

 
 

The country file with a field view set to show calculated fields. 
 

¶ Now open the main people file by selecting People > View/edit people in database. 

¶ Select Calculate > Update calculated fields and select the option óCollection totalsô and then Process. 

Locate and then and sort on that column. 



 33 

ADDING AND DELETING RECORDS 

Adding records 

¶ Open the main species file using Taxa > View/edit SPECIES in database, click the  toolbar several 

times to add some blank records.  You donôt need to add any data at this stage. Close this file. 
 

¶ Open the main country file using Geo > View/edit countries in database, click the  toolbar several 

times to add several  blank records.  Close this file 
 

¶ Now add blank records to the botanical records, family and genus files. 
 

Deleting records 

 

¶ Delete all the new records added to the various files edited above. To delete a record, go to that record 

and then either click on the   toolbar or press the F7 key.  This adds * to the DEL field for each record 

that you want to delete. 
 

¶ To finally remove these marked records, select Edit > Delete options > Remove records marked for 
deletion. 

 

 Record deletion is always a two-stage process as described here. 

 
 

 

Pressing F7 of using the  toolbar adds * to the DEL field but at this stage, records are only marked for 
deletion. In the above example, the records are also tagged. 
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USING LINK FILES TO EXTEND DATABASE STRUCTURE  

Link files introduced 

BRAHMS database files are provided with default standard fields. If BRAHMS lacks fields that you require, you 
can add your own fields using linked data files. Link files extend the structure of your database and are available 
in most of the main database files including species and botanical records. 
 
For example, if you want to indicate whether a species has spines or not, you could add a new field to the species 
link file called óSPINESô and add ó*ô to all species that have spines. In this case, the field would only need  be 1 
character in width. 

Viewing link file fields from a main file 

¶ Select Taxa > View/edit species in database to open the main species file. 

¶ Click on the  toolbar. This opens the link data file at the bottom of your data grid.  

¶ Set a simple filter in the main species file to restrict the view to TAXSTAT = óaccô. Accepted names will 
tend to have linked data such as descriptions stored. 

¶ Open the zoom window using the   toolbar.  

¶ Link file data are included in the Zoom window and all the data in the Zoom window are updated as you 
move to a different record. 

¶ Close the main species file.  
 
 

 
 

The link file opened using the  toolbar at the bottom of the main species file. Link file fields are displayed in the 
Zoom window. 

 

 Link files are available for species, gazetteer, botanical records, seed collections, living collections, images 
and references. 

Opening and editing link files directly 

You can also open link files directly from the main menu. 
 

¶ Select Taxa > Default linked data file (SPLINK). This opens the species link file. If you are doing a lot 

of editing of link file fields, it may be quicker to open it like this rather than at the bottom of the main 
species file. 
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Modify link file structure 

 

¶ Select Taxa > Default linked data file (SPLINK) to re-open the link file. 

¶ Select File > Modify file structureé  

¶ In the open square at the bottom of the field list, type in mynotes and change the field type to Memo. 

¶ Click on Insert to add another new field 

¶ In the open square at the bottom of the field list, type in spines and change the field type to Character 

width 1 
 
 

 
 
 

¶ Click OK to save this edit  and respond Yes to the prompt óMake structure change permanent?ô.  

¶ Close the link file. 

¶ Select Taxa > View/edit species in database to open the main species file. 

¶ Click on the  toolbar again to open the link file and note that these new fields are now available and 
can be edited. 

  




























































































