BRAHMS 7 UPGRADE NOTES
July 2012

A POWERFUL AND FLEXIBLE ONLINE SERVICE ........................................................................................................................ 2
BRAHMS WEBCONNECT ............................................................................................................................................... 3
ONLINE HERBARIUM TRANSACTIONS: IMAGE BASED LOANS ..................................................................................................... 4
WEBSITE STYLE AND CSS FILE EDITING ................................................................................................................................. 4
HERBARIUM OPTIONS – A NEW MENU ................................................................................................................................ 5
HERBARIUM BOXES AND FOLDERS...................................................................................................................................... 5
RAPID SPECIMEN SCANNING ............................................................................................................................................. 5
BOTANIC GARDENS ........................................................................................................................................................ 6
SEED MANAGEMENT ....................................................................................................................................................... 7
PLOT SAMPLE MODULE.................................................................................................................................................... 8
TURBOVEG DATA IMPORTER ............................................................................................................................................ 9
SAVED FILE MANAGER .................................................................................................................................................. 11
XML EXPORTING ......................................................................................................................................................... 12
DATA CORRECTION FILES................................................................................................................................................ 13
SPECIES FORM ............................................................................................................................................................. 14
CONSERVATION ASSESSMENT MODULE (CAM) BETA ......................................................................................................... 15
TAXONOMIC NAME RESOLUTION SERVICE ........................................................................................................................ 16
A NEW FORM FOR RDE AND BOTANICAL RECORDS .............................................................................................................. 17
RDE BOTANICAL RECORDS SPECIES NAME CHECKER ............................................................................................................. 18
PHENOLOGY AND PHENOPHASE ANALYSIS ......................................................................................................................... 18
IMPROVED ERROR CHECKING ON RE-INDEXING ................................................................................................................... 19
SHORT CUT MENUS EXTENDED ........................................................................................................................................ 20
ADVANCED SORT AND SAVED FASTSORT ........................................................................................................................... 20
TAG FOR COMMANDS ................................................................................................................................................... 21
ZOOM WINDOW ENHANCEMENTS ................................................................................................................................... 22
TAXA EXTRACT COLLECTION ANALYSIS ............................................................................................................................... 22

A powerful and flexible online service
BRAHMS online (BOL) has been heavily upgraded to a new system with flexible analysis and reporting
features for family, genus, species, botanical record, specimen, seed, living collection, map and image
data.
BRAHMS online is programmed using the latest Microsoft .net framework in C#. The web components
use the MVC framework.
As well as using the BOL service on the secure BRAHMS server, BRAHMS online can be installed on your
own server or indeed, any computer running windows. The largest online system (June 2012) is the
National Herbarium Netherlands database with some 2 million specimens. Amongst its many features,
the new BOL version includes:









Stats overview of data linked to a website.
Zoomify for online image viewing.
Image based online loans management and determination returns.
Support for e-floras and online monographs.
Map clustering and a map data browser with Zoom tools.
Support to publish seed banks and botanic gardens online.
Substantial search speed increase for large (> 1m specimens) databases.
BOL now operates on 32 and 64 bit servers.

Many of the new features are described in the Millennium Seed Bank Data Warehouse guide on
http://herbaria.plants.ox.ac.uk/bol/content/documentation/MSBP_Data_Warehouse_help_document.p
df . Most of the examples in this document refer to seed data but apply equally to other BOL data
categories.

Some sample screens grabbed from various BRAHMS online sites.

BRAHMS WebConnect
An updated WebConnect system in BRAHMS provides a seamless link to BRAHMS online for website
design and data uploading. Some features of the revised WebConnect component:










A new PublishOnline menu in BRAHMS.
Improved web page design HTML controls for HTML dummies (i.e. most of us…).
Taxonomic data uploading implemented, for example descriptions and synonymy.
Botanical records, specimens and determinations uploaded together.
All data are now transferred using XML files.
A great number of upload restrictions may be applied.
A system of batch queuing data to the server, ideal for larger data uploads.
Monitor your uploads history.
A new flexible system for implementing image slide shows http://nivo.dev7studios.com/.

For full details, refer to the revised WebConnect guide on
http://herbaria.plants.ox.ac.uk/bol/content/documentation/BRAHMSWebConnect.pdf

The WebConnect data uploads screen

A sample WebConnect uploads history screen

Online herbarium transactions: image based loans
BRAHMS and BRAHMS online (BOL) provide facilities to generate and manage online, image based
loans. For full details, refer to:
http://herbaria.plants.ox.ac.uk/bol/content/documentation/onlineloans.pdf

Website style and css file editing
Amongst the changes with WebConnect, more control over website layout is provided through editing
access to your css (Cascading Style Sheet) file. Those interested can create/upload a custom css to help
standardise fonts, colors, background, borders, text formatting and link effects on your BOL websites.

Herbarium options – a new menu
A reorganisation of herbarium related functions under a new principal 'Herbaria' menu as shown below.
If needed, ensure the menu option is enabled from Utilities > My setup > Active modules.

Herbarium boxes and folders
Curation features have been added to manage herbarium boxes and specimen folders. Items are
identified by barcodes. Herbarium specimens can now be linked to individual boxes and folders and the
number of herbarium sheets per folder and folders per box auto-calculated. Folders are linked into
boxes and can be assigned a taxa group (down to species level) and a geographic text, often a ‘region’.
These features have been added in part to support high volume, high resolution herbarium scanning
initiatives such as that currently being implemented by Naturalis in the Netherlands.

Rapid specimen scanning
High volume, high resolution rapid specimen imaging tools developed in collaboration with Naturalis,
Netherlands. For each
herbarium box, images are
scanned for the box
(barcode), each folder cover
within a box and each sheet
within each folder.
Barcodes (matrix) are
included in the data
returned from the scanner
and all data are saved to a
.csv file using post scan

software developed by Naturalis.
The CSV file is imported to RDE using a new Tools import option. Data and image file names are added,
based on the correctly sorted, scanned images for each box, folder (taxa + region) and auto-propagated
to all sheets within the folder, these having the same taxa and geo-region coding. Data from specimen
images can then be added on a limited basis depending on resources (e.g. collector name, number,
date, country). This process is currently being further developed and tested at the Naturalis herbaria in
Wageningen and Leiden. The image shows the new scanning process underway at Wageningen.

Botanic Gardens
The Living Collections module for botanic gardens has been extended and refined after a year of use at
the Oxford Botanic Garden.

See short 2012 Oxford Plant Systematics article on:
http://herbaria.plants.ox.ac.uk/bol/content/documentation/OPS2012_OBG.pdf
Further details are provided in:
http://herbaria.plants.ox.ac.uk/bol/content/documentation/BRAHMSLivingCollections.pdf
A number of new fields provided to record propagation details. These now include propagation type,
date, done by who, propagation result, seed treatment, parent/crossing details where relevant and
general notes.

Seed management
The BRAHMS Seed Management module has been developed collaboratively with the Millennium Seed
Bank (MSB) Partnership at RBG Kew. Our focus has been on the development of the RDE template for
seed collections allowing users to compile field, processing, germination, seed weight and tetrazolium
test data in one simple data entry form. Partners duplicating material to the MSB for conservation
storage are able to generate xml files directly from RDE, the resulting files being importable into the
data management system at MSB. This transfer can also work in the reverse direction enabling data
repatriation to Partners across the global MSB Partnership. The template also maps across to the online
MSB Data Warehouse (http://herbaria.plants.ox.ac.uk/bol/msbp). Plans are being developed to extend
functionality of the BOL online seed bank pages to facilitate seed exchange and purchase direct from the
website; a service required by the many Tree Seed Centres within the MSBP.

The Seed Manager data capture form in use for germination tests in an RDE file.

Generating an XML transfer file from the seed RDE file.

Plot sample module
A heavily revised sample plot module with a new menu interface has been implemented, in
collaboration with William Hawthorne and very much geared towards Rapid Botanical Survey work as
described in the Hawthorne guide now linked on the BRAHMS home page.

Aside from re-structuring the plot-sample menus, new tools have been added for plot header and data
files. A new system to store plot vouchers added and integrated with the plot data file. Plot vouchering
is a vital part of botanical survey.

Vouchers from a plot survey in Liberia, often sterile, are identified and the data added to the plot voucher file.
Each voucher is assigned a voucher code and this is also added to the plot sample record. Photo credits William
Hawthorne.

Plot and voucher data can be viewed together to facilitate det updates. Data can be copied from voucher to plot
file, vice versa. Further tools are provided on the form when browsing a sample data file.

TurboVeg data importer
Plot data stored in standard TurboVeg files (habitat + abundance + species + various popup lists) can be
imported to the BRAHMS plot sample module using the Tools option provided in an opened plot header
file.

This option asks the user to locate the various folders where the TV habitat and abundance file are
stored; some smaller dictionaries (popups) and the species reference list. Data for each plot is added to
a BRAHMS plot header file and the data are added to a data file. Species names are added to the data
file. The species names can subsequently be coded against an existing BRAHMS species list, and this
process exposes new and potentially incorrect species names.

Saved File Manager

The ‘Copy/Save as’ function has been upgraded together with a new saved file manager.





All saved files are named with date and time, thus not overwriting earlier saved files.
Saved files can be registered in the manager which is now accessed from the main File menu.
Any file category (DBF,CSV, XML, XLS, MDB, etc.) can be opened directly from the file manager
using the relevant software by dbl-clicking on the file name.
The saved files manager is more easily accessible on the main File menu.

The Saved File Manager provides a central mechanism to open files of different types. Here shown open a saved
.csv file.

XML exporting
The XML exporter (Admin > XML/Darwin export options) uses the same function as WebConnect. XML
provides the most comprehensive way to export data from BRAHMS.

All XML files generated are saved to and can be opened from the saved file manager.

XML files can be created for the following data
categories

An example XML output

Data correction files
This function helps to clean up data in a selected field which includes misspellings and other errors. The
contents of any non-read only field (e.g. any RDE field) can be uniquely copied to a ‘correction file’,
edited, and then returned to the relevant data field in the donor file to update the data. Correction files
can usefully be shared between projects.

Step 1: Choose a field that contains data to be edited. Typical examples are the fields such as
COLLECTOR, ADDCOLL and DETBY in RDE files. But it could be any non-read only field in any BRAHMS
file.
Step 2: Select Edit > Data correction and parsing options > Create a corrections file for the selected
field. This will create a data file with one record for each different entry on the selected field. The file
will be auto-registered in your saved file manager. It includes the fields INPUT (the list of names from
the donor file) and CORRECTED (the field you can edit). By default INOUT fields are copied to
CORRECTED as a) many entries will be correct and b) wrong entries are usually quite similar to the input
field. may be similar.
Step 3: Edit the data in the field CORRECTED. After editing, entries that were already correct will have
the same value as the original INPUT field.

The above correct file was created from a large RDE file with plenty of problem spellings with collector names
(mostly missing initials and accent problems). The INPUT field contains a unique list of entries generated from
the RDE file and these have been edited and corrected where necessary. The COUNT field indicates the number
of records with the entry.

Step 4: Once the file has been edited, it can be fed back into the relevant file using Select Edit > Data
correction and parsing options > Restore data from corrections file. In the above example, any field
with the entry W. Giess would be corrected to Giess, J.W.H.

Species form
The main species file has an entirely new form providing improved editing controls, access to botanical
record data and various useful stats. The form can be used together with the data grid and can be
dragged over to a separate monitor.

Here showing botanical records for the current species and the stats screen with a summary of the botanical
records including a summary of the herbaria the specimen data are derived from.

The species form Text page includes an assembled summary of all HABITATTXT and PLANTDESC memos for all
botanical records of the current species. Dbl-clicking on any memo text area opens the text in a larger editing
area on the right pane. The summaries are useful when preparing species descriptions.

Conservation Assessment Module (CAM) beta
A new module (currently beta) to store data for conservation assessments has been added in
collaboration with the Red Listing and conservation assessment projects at RBG Kew. Data are entered
via Taxa RDE files using the CAM form, opened in taxa RDE files. Lookup values for all options can be
pre-loaded into your custom lookup dictionary using Admin > Custom lookups > Tools. The custom look
file is currently in development but a first draft is in the setupdata/cam folder.

Assessment data are stored in a single RDE file. Botanical records stored in your database are used to
help calculate country occurrence, altitude range and AOO /EOO, the latter through a direct link to
GeoCAT. Selected botanical records (e.g. cultivated or inaccurate records) can be excluded from
calculations. The CAM module is currently being extended to generate XML that can be uploaded to
IUCN.

Taxonomic Name Resolution Service
Links to the Taxonomic Name Resolution online service
(http://tnrs.iplantcollaborative.org/TNRSapp.html) have been implemented with a new internet toolbar
option. The toolbar option assembled tagged taxa names in the current file onto a clipboard – allowing
to copy/paste the names to the TNRS ‘submit’ text area.

Up to 5000 names can be submitted at once. Each name is checked against the sources you select on the TNRS
setup option.

A new form for RDE and botanical records

The data capture form for RDE and the main botanical records file has been heavily revised. The form
can be used at the same time as the data grid on the same or a separate monitor.

The Find tab provides handy search options for RDE
records. The Stats pane provides a general summary
about the data in an open RDE file. Erroneous ranges are
highlighted in bold.

RDE botanical records species name checker
This handy new tool helps you check through any botanical records RDE file – looking for names that are
not already registered in your main species list. This is not always an easy task as determinations and
names used for types are often ‘hidden’ in the RDESPEC memo. Problems in larger and older RDE files
build up especially when the main species list has been extensively edited - leaving redundant names in
the RDE file. And these names can be difficult to locate. When such RDE files are transferred to
BRAHMS, this may result in many new names being inappropriately added to your taxa files. The
function is found in botanical record RDE files using Tools > Data checks >Taxa > Check all dets
including names in RDESPEC memo.
Optionally, any new names encountered can be used to create a Taxa RDE file. Also, any many new
names are often due to simple family name re-designations, you can auto-update the family names in
the RDE file based on your database family – genus arrangements.
For a full description: http://herbaria.plants.ox.ac.uk/bol/content/documentation/RDEdetchecking.pdf

RDE name checking form

Phenology and phenophase analysis
Results from the PPI tool allow you to analyse and estimate phenophases for selected taxa based on a
minimum set of phenology data recorded by month. PPI produces three taxon-specific results:
Maximum probability period (currently month) for the phenophase;
A predictability index, varying between ~0 (= 0.02) and 1;
Chart of the predictability indexes for the periods (currently 12 months of the year).

Phenological Predictability Index in BRAHMS: a tool for herbarium-based phenological studies.
Ecography Volume 35, Issue 4, pages 289-293, April 2012.
(http://onlinelibrary.wiley.com/doi/10.1111/j.1600-0587.2011.07329.x/abstract).
For implementation within BRAHMS, see
http://herbaria.plants.ox.ac.uk/bol/content/documentation/BRAHMS-PPI.pdf

The Phenological Predictability Index (PPI) processing screen in a taxa extract.

Improved error checking on re-indexing
Re-indexing now checks for obvious errors in altitude, collection date, detby date and lat/long fields.

Short cut menus extended
New shortcut menus on data grid header right-clicks include find/replace, split data, an alltrim function
for character/memo fields and a field duplication option for column duplication to a ‘_b’ field.

Advanced sort and saved FastSort
New Advanced Sort module with improved control over sort commands. A favourite command can be
marked for addition to the FastSort menu.

Advanced sort commands are easier to add, edit and select. You can add a common used advanced sort to your
FastSort menu.

Tag for commands
New 'Tag for' commands module with improved control over commands. Commands are saved in a
project file and thus can be reused.

The Tag for menu option

The Tag for command screen

Zoom window enhancements
The Zoom window has a new option to open Zoom content as a Word document. Handy for spell
checking.

Taxa extract collection analysis
Some additional calculations added to the taxa extract under Tools > Collection data analysis

New calculations per taxa include total number of mappable records and the total number of different
herbaria for specimens.

