A single database can be used to create many products

Query the database


Araucariaceae diversity in New Caledonia. Plotted from conifer database on Google Earth

Acacia diversity in Africa plotted from Acacia database plotted using DIVA GIS

Shorea collections on Malay peninsula (Data from FRIM) plotted on Google Earth

ArcView map calculating area of occupancy (AOO) and extent of occurrence (EOO) in Tropical East Africa. Calculation uses RBG Kew’s CAT

Palm diversity in Borneo plotted on Google Earth

BRAHMS data are used to map diversity in different ways. Species totals are less interesting than bio-quality which takes rarity into account
# CONTENTS

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>ABOUT THIS GUIDE</td>
<td>5</td>
</tr>
<tr>
<td>SYNTAX USED:</td>
<td>9</td>
</tr>
<tr>
<td>USING THE FUNCTION KEY TEMPLATE:</td>
<td>9</td>
</tr>
<tr>
<td>FUNCTION KEY TEMPLATE</td>
<td>11</td>
</tr>
<tr>
<td>INSTALLATION</td>
<td>13</td>
</tr>
<tr>
<td>TRAINING COURSE FOLDER – DO YOU HAVE IT?</td>
<td>13</td>
</tr>
<tr>
<td>BRAHMS IS ALREADY INSTALLED ON YOUR PC?</td>
<td>13</td>
</tr>
<tr>
<td>SYSTEM INSTALLATION</td>
<td>13</td>
</tr>
<tr>
<td>ACTIVATION KEY</td>
<td>13</td>
</tr>
<tr>
<td>CREATING A DESKTOP SHORTCUT TO BRAHMS</td>
<td>13</td>
</tr>
<tr>
<td>INSTALLING THE CONIFER DATABASE</td>
<td>14</td>
</tr>
<tr>
<td>ABOUT THE CONIFER DATABASE</td>
<td>14</td>
</tr>
<tr>
<td>DOWNLOAD DATABASE FROM BRAHMS WEBSITE</td>
<td>14</td>
</tr>
<tr>
<td>INSTALLING THE CONIFER DATABASE IN BRAHMS</td>
<td>15</td>
</tr>
<tr>
<td>PREPARE FOR MAPPING</td>
<td>16</td>
</tr>
<tr>
<td>INSTALLATION STEPS</td>
<td>16</td>
</tr>
<tr>
<td>INSTALLATION OF DIVA GIS</td>
<td>16</td>
</tr>
<tr>
<td>MAPPING FOLDER EXPLAINED</td>
<td>16</td>
</tr>
<tr>
<td>THE BRAHMS HELP FILE</td>
<td>17</td>
</tr>
<tr>
<td>MOVE OR COPY THE HELP FILE TO YOUR DESKTOP</td>
<td>17</td>
</tr>
<tr>
<td>OPENING THE HELP FILE AND READING A TOPIC</td>
<td>17</td>
</tr>
<tr>
<td>CONTENTS TAB</td>
<td>17</td>
</tr>
<tr>
<td>SEARCH TAB</td>
<td>17</td>
</tr>
<tr>
<td>LOG IN/OUT AND EDIT THE USER FILE</td>
<td>18</td>
</tr>
<tr>
<td>LOGGING IN</td>
<td>18</td>
</tr>
<tr>
<td>ADDING YOUR USERNAME</td>
<td>18</td>
</tr>
<tr>
<td>LOGGING OUT</td>
<td>18</td>
</tr>
<tr>
<td>LOGGING IN WITH YOUR OWN USER NAME</td>
<td>19</td>
</tr>
<tr>
<td>ADD YOUR USERNAME TO YOUR DESKTOP SHORTCUT</td>
<td>19</td>
</tr>
<tr>
<td>TEMPFILES-BRAHMS WORK FOLDERS</td>
<td>20</td>
</tr>
<tr>
<td>WHAT ARE TEMPFILES FOLDERS?</td>
<td>20</td>
</tr>
<tr>
<td>FOLDER CREATION</td>
<td>20</td>
</tr>
<tr>
<td>FOLDER DELETION</td>
<td>20</td>
</tr>
<tr>
<td>WHEN TO DELETE TEMPFILES FOLDERS</td>
<td>20</td>
</tr>
<tr>
<td>PERSONAL AND SYSTEM-WIDE CONFIGURATION</td>
<td>21</td>
</tr>
<tr>
<td>PERSONAL SETTINGS EXAMPLES</td>
<td>21</td>
</tr>
<tr>
<td>SYSTEM-WIDE SETTING EXAMPLES</td>
<td>21</td>
</tr>
<tr>
<td>DATABASES AND DATA FILES</td>
<td>22</td>
</tr>
<tr>
<td>DATABASES</td>
<td>22</td>
</tr>
<tr>
<td>DATA FILES</td>
<td>22</td>
</tr>
<tr>
<td>OPENING AND CLOSING FILES</td>
<td>23</td>
</tr>
<tr>
<td>LOG INTO THE CONIFER DATABASE</td>
<td>23</td>
</tr>
<tr>
<td>LOCATE, OPEN AND CLOSE A SELECTION OF DATABASE FILES</td>
<td>23</td>
</tr>
</tbody>
</table>
THE MAIN SYSTEM TOOLBAR ................................................................. 24

DATABASE FUNDAMENTALS .................................................................. 25
  Basic record and field navigation ...................................................... 25
  Locating records using ................................................................. 25
  Locating records using ................................................................. 25
  Tag options introduced ............................................................... 26
  Tag custom commands ............................................................... 26
  Learning to use more function keys .............................................. 27
  Setting simple filters ................................................................... 27
  Setting compound filters ............................................................. 28
  Simple record sorting ................................................................... 28
  Calculate menu and toolbar options ............................................. 28
  The zoom window ...................................................................... 30
  Using the TOOLBAR to get field level help ................................. 30
  Physical and translated field names ............................................. 31
  Memo fields .............................................................................. 31
  Field views .............................................................................. 31
  Edit data in form mode .............................................................. 32
  Calculated fields ...................................................................... 32

ADDING AND DELETING RECORDS ............................................. 33
  Adding records .......................................................................... 33
  Deleting records ...................................................................... 33

USING LINK FILES TO EXTEND DATABASE STRUCTURE .................. 34
  Link files introduced .................................................................. 34
  Viewing link file fields from a main file ...................................... 34
  Opening and editing link files directly ........................................ 34
  Modify link file structure ............................................................ 35

EXTRACTING (QUERYING) DATA ...................................................... 36
  About extract – query files ........................................................ 36
  Extract collections by genus – use calculate options .................. 36
  Mapping extracted collections to Google Earth ......................... 37
  Extract collections by country ..................................................... 37
  Extracting data using a tag profile ............................................. 38
  Create a species list from extracted botanical records ............... 38
  Extract accepted names of Juniperus ......................................... 38

MORE EXTRACTS AND A START WITH REPORTS .............................. 40
  Preparing a sample text report for Juniperus ............................... 40
  Tagging species to prepare a checklist of conifers for Madagascar 41
  Preparing a sample text report for Madagascar conifers .......... 41
  Extract botanical records by collector name ............................... 42
  View extracted collections using a visual report list template .... 42
  View extracted collections using a visual report label template ... 42
  Adding a title to the visual report ............................................... 42
  Livening up a visual report template with images ..................... 43
  Creating an index of collections ............................................... 44

USING RAPID DATA ENTRY (RDE) .................................................. 45
  Relationship between RDE and BRAHMS ................................. 45
  Create a new RDE file for botanical records .............................. 45
  Adding botanical records to RDE .............................................. 45
  Field and record copying using F4 and Ctrl+F4 ......................... 46
  Selective field copying using the TOOLBAR ............................ 46
  Using F9 lookup options ........................................................... 46
  AutoComplete ...................................................................... 46
VISUAL REPORTS: DESI .................................................. 46
OPENING THE SPECIMEN LEVEL FORM ........................................ 47
CUSTOM LOOKUPS, AutoComplete and Verify data .......................... 47
AutoMatching ............................................................................. 47
USING THE RDEIMAGES MEMO .................................................. 48
TRANSFER THE RDE FILE TO BRAHMS ................................. 48
CHECK YOUR DATABASE FILES ................................................ 48
RDE IMPORT PROBLEMS .......................................................... 48

REPORTING INTRODUCED ...................................................... 49
TEXT VS VISUAL REPORTS ...................................................... 49
LEARNING CURVE ....................................................................... 49
TEMPLATES? .............................................................................. 49
MANAGING YOUR REPORT TEMPLATE FILES ............................... 49
INHERITING REPORTS FROM ANOTHER PROJECT ......................... 49
IMPORTING REPORT TEMPLATE SAMPLES .................................. 49

TEXT REPORTS: A SAMPLE CHECKLIST .................................... 50
THE OBJECTIVE OF THIS EXERCISE ......................................... 50
EXTRACTING AND SORTING THE DATA ...................................... 50
A QUICK CHECKLIST AT THIS STAGE ......................................... 50
FORMATTING NAMES AND TYPES ............................................ 51
ADDING AND FORMATTING SPECIMENS FOR EACH SPECIES ............ 52
DESIGNING THE FINAL TEXT REPORT ........................................ 52

VISUAL REPORTS: DESIGNING A SPECIMEN LABEL ....................... 54
DESIGNING LABELS ................................................................... 54
GETTING READY WITH YOUR RDE FILE .................................... 54
CREATING A NEW VISUAL REPORT TEMPLATE .............................. 54
REPORT BANDS AND COLUMNS ............................................... 55
THE REPORT CONTROLS TOOLBAR AND EDITING GRID ............... 55
SETTING A DEFAULT FONT ........................................................ 55
ADDING A BOX SURROUND FOR THE LABELS .............................. 55
ADDING A TEXT LABEL ............................................................. 56
LABEL PREVIEWING .................................................................. 56
ADDING THE FAMILY NAME ...................................................... 56
ADDING THE SPECIES NAME ..................................................... 57
ADDING LOCALITY DATA ........................................................... 57
ADDING OTHER FIELD NOTES .................................................. 57
ADDING THE COLLECTOR NAME AND DATE ............................... 57
ADDING IMAGES TO YOUR LABEL ............................................. 58
ALIGNING FIELDS .................................................................... 59
LABELS FOR RDE OR EXTRACT FILES ........................................ 59
PRINTING TO A PDF FILE .......................................................... 59

DEVELOPING THE SPECIES LIST ............................................... 60
FAMILIES, GENERA AND SPECIES ............................................. 60
MANUALLY ADDING FAMILY, GENUS AND SPECIES RECORDS ........ 60
EDITING AUTHOR NAMES .......................................................... 60
EDITING SYNONYM LINKS IN THE SPECIES FILE ......................... 61
ADDING LINK FILE FIELDS ....................................................... 61
IMPORT NAMES FROM IPNI ........................................................ 61

BOTANICAL RECORDS ............................................................. 62
BOTANICAL RECORDS AND SPECIMENS .................................... 62
MANUALLY ADDING A BOTANICAL RECORD WITH 3 SPECIMENS .... 62

THE MAPPING REVOLUTION ..................................................... 64
RECENT ADVANCES .................................................................... 64
MAP STYLE AND Google Earth ..................................................... 64
ABOUT THIS GUIDE

This guide is a training guide, not a manual. More comprehensive documentation is available on http://dps.plants.ox.ac.uk/bol/BRAHMS/Documentation/Index.

The guide is suitable for beginner and intermediate levels, addressing collection management and research topics. On formal courses, the guide provides course structure.

Unless carefully managed, courses can bewilder the first time user. This guide helps to introduce the system in gradual steps.

Syntax used:

The text Admin > Users and access permissions means:

Select the menu option Admin followed by the menu option Users and access permissions.

Using the function key template:

You can cut out the function key template from the guide, fold the page appropriately and keep it near your keyboard. Using function keys speeds things up.

<table>
<thead>
<tr>
<th>Key</th>
<th>F1</th>
<th>F2</th>
<th>F3</th>
<th>F4</th>
<th>F5</th>
<th>F6</th>
<th>F7</th>
<th>F8</th>
<th>F9</th>
<th>F10</th>
<th>F11</th>
<th>F12</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Help</td>
<td>Open form</td>
<td>Open file</td>
<td>Copy field</td>
<td>Sort form</td>
<td>Tag toggle</td>
<td>Delete mark toggle</td>
<td>Field view</td>
<td>Lookup</td>
<td>Filter form</td>
<td>Go to first column</td>
<td></td>
</tr>
<tr>
<td>Shift</td>
<td>Open shortcut help template</td>
<td>Increment last field value</td>
<td>Sort ascending</td>
<td>Tag all</td>
<td>Add</td>
<td>External file lookup</td>
<td>Filter on selection</td>
<td>Go to last column</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Ctrl</td>
<td>Find</td>
<td>PostPro commands</td>
<td>Copy record</td>
<td>Count tagged</td>
<td>Reduce column width</td>
<td>Zoom toggle or Ctrl+Z</td>
<td>Filter includes selection</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Alt</td>
<td>Add record or Alt+A</td>
<td>Close screen or Alt+X</td>
<td>Clear sort</td>
<td>Clear tags</td>
<td>Increase column width</td>
<td>Clear filters</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Enter/Tab = next field  
Shift+Enter/Tab = last field  
Ctrl+M = open memo  
Ctrl+W = save memo  
Ctrl+Z = zoom toggle  
Ctrl+I = image toggle
INSTALLATION

Training course folder – do you have it?
Course instructors may have and distribute a zip file which will open to create the training course folder (illustrated below). The training course folder provides a useful folder structure and it includes all the resources you need.

If you do not have this folder - no problem. You can separately download as follows:

BRAHMS: http://dps.plants.ox.ac.uk/bol/BRAHMS/Software/Index
Conifer database: http://dps.plants.ox.ac.uk/bol/BRAHMS/Sample/Conifers
DIVA GIS: http://www.diva-gis.org/
Sample base maps data: http://dps.plants.ox.ac.uk/bol/BRAHMS/GroupResources/Index

BRAHMS is already installed on your PC?
If you previously installed BRAHMS for testing, delete your BRAHMS6 folder. Also, delete all \\tempfiles-brahms folders. Then proceed to install the new system.

If you have one or more active BRAHMS databases, follow the link for installation help on http://dps.plants.ox.ac.uk/bol/BRAHMS/Software/Index

System installation

- Locate the brahms6.zip file in the folder as shown below OR your software download file.

  - BRAHMS training course
  - Activation key
  - BRAHMS6 folder
  - Help file
  - Mapping
  - Sample databases

- Extract the software zip file to the top level of your C: drive (usually referred to as ‘Local Disk (C:)’ or ‘DRIVE_C (C:)’). This will create a folder called BRAHMS6 – in this case, C:\BRAHMS6.

  You can safely extract the software zip elsewhere. The software folder will always be created relative to the folder you choose.

Activation key

- If you do not have a key in your BRAHMS training course \ Activation key folder, login to the BRAHMS website and download your key from http://dps.plants.ox.ac.uk/bol/BRAHMS/Members. If you cannot login, please register using the menu option provided on the home page.
- Copy the file BRAHMSKEY.MEM to the BRAHMS6 folder.

Creating a desktop shortcut to BRAHMS

- Locate the file BRAHMS.EXE (represented by a blue drum) in the BRAHMS6 folder. The ‘.exe’ file extension may be hidden.
- Right-click on this file and choose Send to > Desktop (create shortcut).

- Right-click on the new shortcut, choose the Rename option and type in “B R A H M S”.

13
INSTALLING THE CONIFER DATABASE

About the Conifer database

The conifer database has been provided by Aljos Farjon, RBG Kew - a taxonomist of Gymnosperms and chair of the IUCN Conifer Specialist Group.

If you wish to use the data for a research publication or any other purpose beyond training, kindly consult first with A.Farjon@kew.org.

The conifer database includes all published conifer names with nomenclatural details, IUCN conservation codes, TDWG geographic distribution codes, species descriptions and more. It also includes specimen data across the group, almost all referenced for mapping. Descriptions have been truncated to a maximum of 500 characters.

The conifer database has been used to help publish four publications:

- A World Checklist And Bibliography of Conifers, Aljos Farjon, 1998, Kew Publishing

Download database from BRAHMS website

If you do have it, the database can be downloaded from http://dps.plants.ox.ac.uk/bol/BRAHMS/Sample/Conifers.

Installing the Conifer database

- Locate the coniferdatabase.zip file in the folder as shown below OR your sample database download file.

  - Extract the zip file to the top level of your C: drive (usually referred to as 'Local Disk (C:)') or 'DRIVE_C (C:)'. This will create C:\BRAHMSDATA-CONIFERS.

  ![Conifer database](image)

  If you have installed to another folder, you will have problems later on with this guide. In this case, move the folder to C: to create c:\brahmsdata-conifers.
The installed database folder includes several subfolders. Of these the most important is DATABASE. The myrdefiles, myreports and mysavedfiles folders are empty suggested locations for files of those types. Other folders may be provided.

Register the Conifer database in BRAHMS

- Log into the TEMPLATE database using user name Administrator and password A.
- Select File > Database manager.

Assuming the conifer database is not yet registered, click the toolbar. Add an entry for the Conifer database as shown in the following screen.

Note that the Database folder is pointing to the DATABASE subfolder within BRAHMSDATA-CONIFERS.

Note that the database folder is pointing to the DATABASE subfolder.
PREPARE FOR MAPPING

This step may be done now or later on.

Installation steps

If you do not have a special training course folder and wish to install DIVA, you can visit:

DIVA GIS: http://www.diva-gis.org/
Sample base maps data: http://dps.plants.ox.ac.uk/bol/BRAHMS/GroupResources/Index

- Locate the folder ‘C:\ BRAHMS training course \ Mapping’.
- Extract the mapping.zip file to the top level of your C: drive (usually referred to as ‘Local Disk (C:)’ or ‘DRIVE_C (C:)’). This will create C:\ MAPPING.

Installation of DIVA GIS

If you wish to install DIVA (you may already have ArcView or another GIS):

- Locate the file SETUP.EXE in the folder Mapping \ Diva software OR from your download
- Run this setup. This will install DIVA GIS on your PC.

Mapping folder explained

```
<table>
<thead>
<tr>
<th>Folder</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basemaps</td>
<td>Country and internal admin boundary .SHP for use with DIVA and/or ArcView.</td>
</tr>
<tr>
<td>CAT out</td>
<td>A folder for Conservation Assessment results generated by the CATS tool (ArcView users only).</td>
</tr>
<tr>
<td>Diva software</td>
<td>Diva setup files – ready to install. Just run the SETUP.EXE file.</td>
</tr>
<tr>
<td>ESRI extensions</td>
<td>CATS.AVX file and PDF file documenting the Conservation Assessment Tools.</td>
</tr>
<tr>
<td>Mapping points from BRAHMS</td>
<td>Empty folder for your BRAHMS generated map files.</td>
</tr>
<tr>
<td>Projects</td>
<td>Empty folder for you to save APR and DIV projects to.</td>
</tr>
</tbody>
</table>
```
THE BRAHMS HELP FILE

Move or copy the help file to your desktop
If you do not have a special training course folder, the help file is available on http://dps.plants.ox.ac.uk/bol/BRAHMS/Documentation/Download/

- **Locate** the folder ‘C:\ BRAHMS training course \ Help file’.

  - ![Image of file structure]

  - **Drag** the file BRAHMS.CHM onto your desktop.

  > The CHM help file will not work correctly if stored on a network drive. Locate it on your local drive.

Opening the help file and reading a topic

- Using your file manager (e.g. Windows Explorer), locate and **dbl-click** the help file icon to open. Note there are **Contents**, **Search** and **Favorites** tabs.
- **Click on the Contents tab**.
- To open a section (purple book icon), click on the left hand side +.
- To display a topic, click on the page you want to open.

![Image of help file open with contents tab selected]

A screen shot of the help file with the Contents tab selected and a topic selected.

Contents tab
Using the help file **Contents tab**, locate the following topics:

- System fundamentals > Logging in and out
- Mapping > Producing maps > Google Earth mapping
- Rapid Data Entry (RDE) > RDE file manager > Creating and registering files
- Troubleshooting > Index problems

Search tab
Using the help file **Search tab**, search for the following topics. Remember to **Dbl-click** a page to goto/open a search result.

- ‘Activation key’
- ‘Function keys’
- ‘Navigation’
- ‘Add synonym’
- ‘Backing up’
LOG IN/OUT AND EDIT THE USER FILE

Logging in
Initially, the project to open is the Template project stored in the template/database folder. This is an empty database provided with BRAHMS.

- To log into a newly installed system, enter password ‘A’ followed by <Enter>.
- Choose Advanced mode, and Single user (defaults).

![A typical login screen with a user entering in single-user mode.]

Adding your username
- On the main menu, select Admin > Users and access permissions.

![Selecting an option on the main menu]

- Click on the main toolbar to add a new record.
- Add your first and last name (maximum of 2 names) and a password.
- All the other fields in this file can be left with their default values.
- Note that the field ACCESS GROUPS defaults to ‘ALL’. This means that the user has full administrative access to the database.

![The user file opened with the main toolbar selectively enabled]

On networks, system administrators can set access permissions for each user.

Logging out
- Log out of BRAHMS using File > Exit BRAHMS. This closes down open database files.
Logging in with your own user name

- Now log in again but this time choose your own user name. A new folder will be created for temp files – these files are explained in the next section.

You should always log into BRAHMS using your personal log in name rather than Administrator. On networks, system administrators can set access permissions for each user.

Add your username to your desktop shortcut

- **Right-click** on your BRAHMS desktop shortcut, select **Properties** and add your name as shown below. This speeds up login, especially when the user file has many entries.

A maximum of 2 words (first and last name) is permitted when editing this option.
TEMPFILES-BRAHMS WORK FOLDERS

What are tempfiles folders?
Tempfiles-brahms folders are user by BRAHMS for various temporary files. Also, when you make a query, the results are sent to this folder.

Folder creation
When you log into BRAHMS, the system checks if you have a tempfiles folder. If not, one will be created automatically and called ‘tempfiles-brahms’. The exact name and location of this folder depends on your username and project code settings. A typical example is ‘C:\tempfiles-brahmsA’.

Each user on a given workstation has a separate work folder. If a user has more than one project, several sub-folders will be created, one per project.

Folder deletion
Normally, you do not need to delete these folders – unless there is a specific problem. If you delete work folders, BRAHMS re-creates these when you next log in. No data are lost. To delete your tempfiles folders(s):

• Log out of BRAHMS
• Locate the folder(s) c:\tempfiles-brahms (the name may vary slightly).
• Delete the folder(s).
• Log in again and note that the work folder is re-created.

Work folder paths are auto added to the user file LOCALPATH field. Where necessary (on some network or Terminal Server systems), path drives and names can be edited. The default is always local disk C:.

When to delete tempfiles folders
When you upgrade BRAHMS, you will be asked to delete your tempfiles folders.

If you experience a system crash or see any messages about bad index files, it is recommended that you delete your temporary work folder(s).
PERSONAL AND SYSTEM-WIDE CONFIGURATION

Some configuration settings are system-wide and apply to all users of the current database. Others are personal and are associated with individual users. If using BRAHMS as a single user system, these categories can be treated equally. Personal settings are stored in the user file and preferences added here will apply to that user in any database he or she opens. System-wide settings are stored as part of a given database and apply only to that database.

Personal settings examples

If running BRAHMS on a network with multiple users, normally, only the system administrator will have access to the Admin menu and thus system-wide settings. In this case, you can edit your personal settings by selecting Utilities > My setup/profile. There are many configuration options – here are a few examples:

Active modules

- Select Utilities > My setup/Profile > Active modules. Here, you can include/exclude main menu options.

Data grid options

- Select Utilities > My setup/Profile > Data grids. Here, you can experiment with different data grid settings, for example, whether to select text on entry to a field.

Highlights colours

Select Utilities > My setup/Profile > Highlight colours. Here, you can set colour preferences for tags, column clicks, the zoom window and a few other things.

Home herbarium

Select Utilities > My setup/Profile > Home Herbarium to add your own herbarium code (if relevant). BRAHMS uses this to give preference to your herbarium when displaying barcodes and/or accession numbers – and also for certain functions linked to loan management.

System-wide setting examples

Mapping configuration options

- Select Admin > Project configuration > Maps. Choose the software you are likely to use the most.
- On the same tab, choose the map units you use most commonly. The choices are Degrees/Minutes/Seconds (DMS), Decimal degrees (DD) and Degrees and decimal minutes (DM).

Date format

- Select Admin > Project configuration > Dates and choose your date language/format. Note that month names for the 5 styles can be edited using Admin > Month names.
Databases

When you log into BRAHMS, you need to select a database/project to open. The BRAHMS system is delivered with one empty database called **Template**. This can be copied to make entirely new database projects.

![Database icons](image)

A database is a collection of related data files stored in a single database folder together with system configuration settings.

![Database manager screen](image)

When logged into the Template database, you can create new database projects and link these to your BRAHMS software.

Data files

Many of the BRAHMS menu options open up data files as shown here with botanical records. Data files consists of records and columns.

![Data file screenshot](image)

BRAHMS is a relational database. Several of the columns you see in the above screen, for example the family name, are held in separate tables but are displayed together with botanical record data.

When you open any file, the menu options change to the data editing menu. This is very different to the main system menu.
OPENING AND CLOSING FILES

The purpose of this exercise section is mostly to provide orientation with where some of the more commonly used options are on the menu system.

Log into the Conifer database

When you log in, select the Conifer database, not the Template database.

Locate, open and close a selection of database files

After opening each file, you can simply close the file again using Alt+X or click on the top right close window X.

Missing menu options?
If you do not see a menu option, for example Maps, select Utilities > My setup/Profile > Active modules ... to switch the missing menu option on.

Opening the main species file

- Main species file: Taxa > View/edit SPECIES in database
- Main genus file: Taxa > View/edit GENERA in database
- Main family file: Taxa > View/edit FAMILIES in database
- Taxonomic status categories: Taxa > Resource files > Taxonomic status
- Main botanical records file: BotanicalRecords > View/edit botanical records in database
- Main specimen file: BotanicalRecords > View/edit specimens in database
- Herbarium list: BotanicalRecords > Herbarium list
- Type categories: BotanicalRecords > Resources files > Type categories
- Specimen categories: BotanicalRecords > Resources files > Specimen categories
- Country list: Geo > View/edit countries in database
- Main gazetteer: Geo > View/edit gazetteer in database
- People: People > View/edit people in database
- Map projects: Maps > Saved ArcView (APR) and DIVA (DIV) projects
- Map colours: Maps > Colours and opacity
- Image library: Images > View/edit images registered in database
- Month names: Admin > Month names
- Custom lookup values: Admin > Custom lookups
- Database manager: File > Database manager
THE MAIN SYSTEM TOOLBAR

Tag toggle. Adds or removes * to the TAG field. Tagging used throughout BRAHMS.

Delete toggle. Adds or removes * to the DEL field. To remove records marked in this way, select Edit > Delete options > Remove records marked for deletion. Deletion throughout BRAHMS is a two-stage process.

Add a record. In selected modules including RDE, the add function can be configured using the toolbar.

Copy settings. Configure what happens when a new record is added.

Access custom designed forms, if available.

Opens a data file.

Open/close a linked data file.

Define and/or select a field view.

Find a record using custom find form.

Open Zoom pane - display fields for the current record in the right window pane. Right-click the zoom window for more options.

Reduces field widths by a %. Right-click to increase field widths.

Auto fit data columns.

Open the sort form to carry out compound sorts. For simple field sorts, right-click the column header name. A list of convenient sorts usually available on the Fastsort menu option.

Set a filter on current field or another field as selected. Multiple filters can be set. To clear all filters, right-click filter button or use the Clear filters option on the Filter form.

Analyse data in selected column.

Display taxa in tree view with options to navigate/filter on taxa.

Open the FoxPro command library.

Link the current record to any reference stored in your reference lists.

Open image viewer + image toolbar

Link documents such as PDFs, Excel, Videos, whatever to any record.

Copy/Save as options.

Check and transfer the contents on an RDE file to BRAHMS.

Design and generate reports from any BRAHMS module.

Create maps using your preferred GIS.

Open current file in Excel. Respects current filters, sort order and field selection.

Edit comments for records. Activate if the COMMENTS field is available in the current file. Right-click to restrict the view to records with comments.

Field level documentation and local data rules for current file.
DATABASE FUNDAMENTALS

Basic record and field navigation

- Select Taxa > View/edit species in database to open the main species file.
- Press ENTER (or TAB) several times to move forwards to the next fields.
- Press <SHIFT>+ENTER to move backwards to the previous fields.
- Use arrows or the scrollbar to move up and down records.
- Press the F12 key to go to column 1
- When in the first column, you can press the left arrow to go to the last column.

The Navigation toolbar on the top right side of the screen can be used for record navigation.

Locating records using

- In the main species file, use the toolbar to locate the species name Pinus devoniana. Entering ‘pin dev’ in the search for box should be enough. Note that Pinus devoniana is an accepted name and has ‘acc’ in the TAXSTAT field.

![Search for species in database](image)

The species search form with Goto accepted option selected. If you choose a synonym, the system will direct you to the accepted name.

Selected options such as ‘Goto accepted name’ on the above form are saved as a personal preference.

Locating records using

The tree view control is used to display your taxa in a searchable tree.

- In the main species file, select the toolbar to build a tree view.
- Click on a family name to go to and filter on that family.
- Click ‘+’ to list genera in that family and click on a genus name to go to and filter on that genus.
- Click ‘+’ again to list species in the selected genus and click on a species name to go to that species.
- Using the tree view option, navigate to the species Fitzroya cupressoides in the Cupressaceae.
Tag options introduced

Record tagging is used throughout BRAHMS for marking/selecting records. When you tag a record, ‘*’ is added to the TAG field.

Most files have a TAG field at the start of the record

Some example uses of tags: a) to create groups of records (a tag profile); b) to copy selected records to a new file; c) to extract/query data; d) to restrict an analysis to tagged records; e) to restrict a map to include tagged records.

- Select Taxa > View/edit species in database to open the main species file.
- Select Tag > Tag all with * to tag all records.
- Select Tag > Clear all * tags to clear all tags.
- Click ✔️ or press F6 several times to tag some records. If a record is already tagged, the tag will be removed.

Screen shot of the Tag menu options

- Select Calculate > Count tagged with *
- Select Calculate > Count untagged.

To quickly set a filter on tagged records (restrict to tagged records), use Tag > Show tagged.

Tag custom commands

You can use custom commands to tag records. For example, the main species file includes the field YEAR (=year of publication). We want to tag all records published before 1900

- Select Taxa > View/edit species in database to open the main species file.
- Select Tag > Clear all tags.
- Select Tag > Tag for ... and enter the command as prompted: YEAR < 1900
- Click OK to tag these records.
Try a more complex example:

- Select **Tag > Tag for** ... and enter the command as prompted:

  \[ \text{TAXSTAT} = \text{’acc’ and YEAR > 1850 and YEAR <= 1880} \]

*The operator \( \leq \) means: less than or equal to. Note that acc is surrounded by quotes as it is text. Numbers such as 1850 are not.*

### Learning to use more function keys

Many tasks are faster using function keys rather than your mouse. For example, **F6** can be used instead of ☑ to tag records.

<table>
<thead>
<tr>
<th>Key</th>
<th>F1</th>
<th>F2</th>
<th>F3</th>
<th>F4</th>
<th>F5</th>
<th>F6</th>
<th>F7</th>
<th>F8</th>
<th>F9</th>
<th>F10</th>
<th>F11</th>
<th>F12</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shift</td>
<td>Help</td>
<td>Open form</td>
<td>Open file</td>
<td>Copy field</td>
<td>Sort form</td>
<td>Tag toggle</td>
<td>Delete mark</td>
<td>Toggle</td>
<td>Field view</td>
<td>Lookup</td>
<td>Filter form</td>
<td>Go to first column</td>
</tr>
<tr>
<td>Ctrl</td>
<td>F6</td>
<td>Filter commands</td>
<td>Document text field value</td>
<td>Sort ascending</td>
<td>Tag all</td>
<td>Add</td>
<td>Edit</td>
<td>External</td>
<td>lookup</td>
<td>Filter by selection</td>
<td>Go to last column</td>
<td></td>
</tr>
<tr>
<td>Alt</td>
<td>Add record or Alt+A</td>
<td>Close screen or Alt+X</td>
<td>Clear record</td>
<td>Clear sort</td>
<td>Clear tag</td>
<td>Reduce column width</td>
<td>Increase column width</td>
<td>Zone toggle on Alt+Z</td>
<td>Filter includes selection</td>
<td>Clear Filter</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The BRAHMS Function Key template is available in the folder BRAHMS6\template\function key template.

- Select **BotanicalRecords > View/edit botanical records in database.**
- Enter **Alt+A** several times to add blank records.
- In the BOTRECCAT field, press **F9** to look up the available options for that field.
- Use **F6** to tag the new records.
- Use **F7** to mark all these new records for deletion. Although note a useful option is **Edit > Delete options > TAG->DEL.**
- Select **Edit > Delete options > Remove records marked for deletion.**
- Enter **Alt+X** to close the screen.

*The template form can be opened in a separate window using SHIFT+F1.*

### Setting simple filters

Filters restrict your view of the data to a selected group of records.

- In the main species file, locate and click once on the text ‘acc’ in the field TAXSTAT (choose any record).
- Now **right-click** on the **TAXSTAT column header** and choose **Filter by selection.** This will set a filter to show only ‘acc’ names *i.e.* accepted names.

*Filter by selection is one way to quickly filter/restrict records on the selected text in any field*

- Then choose **Tag > Tag all with** *. This will tag all the accepted names.
- To remove the filter, **right-click** on the ☑ toolbar.
- Try setting filters on some other fields.
To quickly set a filter on tagged records, use **Tag > Show tagged**.

### Setting compound filters

You can add multiple filters at the same time using the toolbar.

- Select **Taxa > View/edit species in database** to open the main species file.
- Use the toolbar to open the main filter form.
- Edit the form so that the option reads **field=**family, **operator=includes; value=cupr**.
- Click the button to apply the filter.
- Re-open the filter form and add a second command: **field=taxstat, operator=includes; value=acc**.
- Apply the filter. This will set the filter to accepted names in the Cupressaceae.

### Simple record sorting

- Still in the main species file using the menu options:
- Select **FastSort > Family + species** to sort the file A-Z by species within family.
- Now select **FastSort > Species name** to sort this file by the species name only.
- **Right-click** on the column header for the field SP1 and choose **Sort Ascending**.
- **Right-click** on the column header for the field FAMILY and choose **Sort Unique** to show one record per different family.
- To remove the current file sort, **right-click** on the toolbar.

Compound sorts using multiple fields and the toolbar are discussed later.

### Calculate menu and toolbar options

Calculate options provide counts and summaries of your data. Aside from using count tagged and untagged as above, the most commonly used option is **Calculate > Analyze data in selected column**, also activated using the toolbar.

- Open the main species file.
- **Right-click** the toolbar to ensure no filters are set.
- Click anywhere in the TAXSTAT field (data or header).
- Click on the toolbar.
The record counts here refer to the number of species records for each TAXSTAT value.

Try the following:

- Use $\sum$ in the FAMILY field to calculate the total number of taxa per family.
- Use $\sum$ in the GENUS field to calculate the total number of taxa per genus.
- Use $\sum$ in the YEAR field to calculate the total number of taxa per publication year.

- Apply a simple filter on the FAMILY field to filter on the family Podocarpaceae.
- With this filter set, click once in the AUTHOR1 field and then use $\sum$ to display the total number of taxa in this family published per different author.
- To clear all filters, right-click on the toolbar.

- Apply a simple filter on the TAXSTAT field to show only acc names (as described earlier). Locate the field IUCN in the main species file. Click in this column and then use $\sum$ to display the total number of taxa per IUCN category. Also open the analysis result in Excel using the option provided on the toolbar.

- Open the main genus file (option on the Taxa menu). Using the $\sum$ toolbar option, produce a summary table of the total numbers of genera per family. Which family has the most genera?

Results generated by the $\sum$ toolbar can be open in Excel and used to prepare charts and graphs.
The Zoom window

The toolbar displays all non-empty fields in a mouse-sensitive window to the right of the main window. Clicking on the Zoom button a second time closes the Zoom window.

- Select Taxa > View/edit species in database to open the main species file.
- Click on the toolbar to open the zoom pane.
- Double click on a field name in the Zoom pane to go to and highlight that column.

![Zoom window example](image)

When you move to a new record in the main file, the Zoom window is updated

- Click on the toolbar to close the zoom window.
- Using the simple filter method learnt above, apply a filter to show only those names with TAXSTAT = acc.
- Now Click now on the toolbar to open the linked data file (bottom of screen). Linked data are explained more in a subsequent section.
- With the link file open, click on the toolbar to open the zoom pane. Data from link file fields will be included in the zoom pane.

If you right-click in the Zoom window, you can adjust window properties. One of the options is to include blank fields (these are excluded by default).

Using the toolbar to get field level help

- Select BotanicalRecords > View/edit botanical records in database. Click in the PREFIX field and then on the toolbar to read about this field.
- Open one of the taxon files (family, genus or species) and, using toolbar, read about the SYNOF field.
Physical and translated field names

The field headings you see on the screen are sometimes different to the real field names in the data file. This makes them more readable. However, with some functions (e.g. creating reports and using Foxpro commands), you must know and use the real field names.

- Select BotanicalRecords > View/edit botanical records in database and locate the field name with the name MAJOR COUNTRY AREA.
- Hover your mouse over the column header and note that the physical field name here is GAZ.MAJOR. This means that the field is in a related file with short name GAZ and in that file, the true field name is MAJOR.

Memo fields

Memo fields hold text of any length. They are used for notes and descriptions. You can copy and paste text into memo fields or drag selected text from your word processor files.

- Select BotanicalRecords > View/edit botanical records in database.
- Locate the field PLANT DESCRIPTION.
- Double-click on a memo to open it or use Ctrl+M.
- Enter Ctrl+W to close and save - or Esc to close a memo and abandon edits.

Memo fields with ‘Memo’ rather than ‘memo’ have data. You can open and edit several memo fields at the same time in a file.

Field Views

Field views are used to restrict the fields you see when viewing data grids. You can create and save multiple views for each type of data (species, collections, extract files, RDE files, etc.). They are useful for different editing tasks or simply viewing your data.

- Select BotanicalRecords > View/edit botanical records in the database.
- Select the toolbar to define/select field views.
- Initially, select Exclude all to remove all fields then choose fields by numbering in the POS column.
- Create a field view to show the fields TAG, DEL, COLLECTOR(S), NUMBER, YEAR, FAMILY and FULLNAME.

The field selection form with the option Show selected fields ticked.

- Select Save as new to save and select this view, choosing an appropriate name for this field selection as prompted.
You can add and save many field views per file. The required view is selected using the dropdown field view list on the main toolbar. All field views are registered centrally under Admin > Field views and settings. You can remove views here.

**Edit data in form mode**

Experienced BRAHMS users usually find working in data grids faster and more flexible than working with forms. However, with some files, especially those with many fields, data can also be edited using tabbed dialogue screen forms.

- In the main species file, locate the name *Taiwania cryptomerioides* using the toolbar.
- Select the toolbar to open the data form.
- Click on the Nomenclature tab to view/edit synonyms of this species.

**Calculated fields**

Calculated fields are summaries of data, often handy for reporting and data checking. These fields are not auto-updated – they must be updated periodically using the Calculate menu options provided. Calculated field options are available in most of the main files.

- Open the main country list by selecting Geo > View/edit countries in database.
- Select Calculate > Update calculated fields....
- Select Select all then Process.

Calculated totals are added to fields such as COLLECTION TOTAL, SEED TOTAL, SPECIES TOTAL, etc.

- Locate the column COLLECTION TOTAL, right-click the column header name and choose Sort Ascending. Go to the bottom of the file to see the highest values.
- Close the country file.

The country file with a field view set to show calculated fields.

- Now open the main people file by selecting People > View/edit people in database.
- Select Calculate > Update calculated fields and select the option ‘Collection totals’ and then Process. Locate and then and sort on that column.
ADDING AND DELETING RECORDS

Adding records

- Open the main species file using Taxa > View/edit SPECIES in database, click the toolbar several times to add some blank records. You don’t need to add any data at this stage. Close this file.

- Open the main country file using Geo > View/edit countries in database, click the toolbar several times to add several blank records. Close this file.

- Now add blank records to the botanical records, family and genus files.

Deleting records

- Delete all the new records added to the various files edited above. To delete a record, go to that record and then either click on the toolbar or press the F7 key. This adds * to the DEL field for each record that you want to delete.

- To finally remove these marked records, select Edit > Delete options > Remove records marked for deletion.

Record deletion is always a two-stage process as described here.

Pressing F7 of using the toolbar adds * to the DEL field but at this stage, records are only marked for deletion. In the above example, the records are also tagged.
USING LINK FILES TO EXTEND DATABASE STRUCTURE

Link files introduced

BRAHMS database files are provided with default standard fields. If BRAHMS lacks fields that you require, you can add your own fields using linked data files. Link files extend the structure of your database and are available in most of the main database files including species and botanical records.

For example, if you want to indicate whether a species has spines or not, you could add a new field to the species link file called ‘SPINES’ and add ‘*’ to all species that have spines. In this case, the field would only need be 1 character in width.

Viewing link file fields from a main file

- Select Taxa > View/edit species in database to open the main species file.
- Click on the toolbar. This opens the link data file at the bottom of your data grid.
- Set a simple filter in the main species file to restrict the view to TAXSTAT = ‘acc’. Accepted names will tend to have linked data such as descriptions stored.
- Open the zoom window using the toolbar.
- Link file data are included in the Zoom window and all the data in the Zoom window are updated as you move to a different record.
- Close the main species file.

The link file opened using the toolbar at the bottom of the main species file. Link file fields are displayed in the Zoom window.

Link files are available for species, gazetteer, botanical records, seed collections, living collections, images and references.

Opening and editing link files directly

You can also open link files directly from the main menu.

- Select Taxa > Default linked data file (SPLINK). This opens the species link file. If you are doing a lot of editing of link file fields, it may be quicker to open it like this rather than at the bottom of the main species file.
Modify link file structure

- Select Taxa > Default linked data file (SPLINK) to re-open the link file.
- Select File > Modify file structure...
- In the open square at the bottom of the field list, type in mynotes and change the field type to Memo.
- Click on Insert to add another new field
- In the open square at the bottom of the field list, type in spines and change the field type to Character width 1

<table>
<thead>
<tr>
<th>Field</th>
<th>Type</th>
<th>Width</th>
</tr>
</thead>
<tbody>
<tr>
<td>vernacular</td>
<td>Memo</td>
<td>4</td>
</tr>
<tr>
<td>etymology</td>
<td>Memo</td>
<td>4</td>
</tr>
<tr>
<td>mynotes</td>
<td>Memo</td>
<td>4</td>
</tr>
<tr>
<td>spines</td>
<td>Character</td>
<td>1</td>
</tr>
</tbody>
</table>

- Click OK to save this edit and respond Yes to the prompt ‘Make structure change permanent?’.
- Close the link file.
- Select Taxa > View/edit species in database to open the main species file.
- Click on the toolbar again to open the link file and note that these new fields are now available and can be edited.
EXTRACTING (QUERYING) DATA

About extract – query files
Most categories of data have a menu option at the bottom of the respective menu: Extract/query data. The extract options open a form offering query commands. These commands vary depending on the category of data you are working with.

Extract menu options for botanical records and taxa

Extracting botanical records (collections) by genus. As the option ‘Auto-open extract file after a search’ is selected, the search result will be displayed after clicking ‘Search now’.

Extract collections by genus – use calculate options

- In the Conifer database, select BotanicalRecords > Extract/query data...
- Check the extract file is empty by clicking the Empty button.
- Select Taxa/det > Genus > Select/Add to search list.
To choose the genus *Podocarpus*, enter ‘pod’ in the search string box. In the Conifer database, this would be enough to locate the correct name. Click on Select to confirm the selected name.

Finally, click on Search now to extract the data. Data are extracted to an ‘extract’ file.

If the Auto-open extract option was selected, the extract will auto-open. Otherwise, close the form and select Extracts > BotanicalRecords.

You can now process these results in different ways, for example to make a report or a map, undertake an analysis or export the data for processing elsewhere.

- Click on the toolbar to auto-resize column widths.
- Click on the toolbar to open the zoom pane.
- In the Zoom pane, locate and dbl-click on the COUNTRY column name to quickly locate and select that column.
- Then use the toolbar to calculate the number of collections stored in this database per country in for this genus in this database. Remember to click in the COUNTRY field first if it is not already selected.

**Mapping extracted collections to Google Earth**

- If you are online and you have Google Earth installed, select the toolbar, check the Google Earth option
- Make sure that the option Restrict to tagged is not selected (unless you only want to map tagged records). Click on Map all.

![A snapshot of the Podocarpus collections in S E Asia region.](image)

**Extract collections by country**

- In the Conifer database, select BotanicalRecords > Extract/query data...
- Check the extract file is empty by clicking the Empty button.
- Select Geographic > Country then Select/Add to search list.
- Choose a country that has conifers, for example China or Vietnam.
- Click on Search now to extract the data for the selected country.

You can now process your extracted records in different ways. For example:

- Locate the SPECIES column and use the toolbar to calculate the number of collections per species for that country.
- Use a FastSort menu option to sort the records.
- If online, use the toolbar to map these data using Google Earth.
Extracting data using a tag profile

A further use of tagging in BRAHMS is to create and save groups or records, for example a group of countries that you may use frequently. You can use your groups to query your database, for example, to extract all specimens from Africa.

- Select Geo > View/edit countries in database. Clear all the tags using the Tag menu option.
- Locate and tag a series of countries in your region (you could do this manually or deploying some filter and tag menu options).
- Select Tag > Tag profiles an groups then Create new to save these tags to a named group e.g. ‘Africa’ or ‘Indochina’.

To test your country group, select BotanicalRecords > Extract/query data... . Then select Geographic > Country Group and extract all specimens from that group of countries.

The same process could be used to save any logical group of records (e.g. endangered species, a selection of seed records, a group of gazetteer records).

Create a species list from extracted botanical records

Using your extracted botanical records, you can create a separate list of taxa. This is a useful tool when producing check lists based on collections.

- In the opened extract file (created above), select Tools > Convert extract file to another ... > Botanical Record extract -> Taxon extract.
- Select Tools > Convert extract file to another ... > Botanical Record extract -> Taxon extract.
- Close the current extract and select Extracts > Taxa to open this new taxon extract derived from your collections.

Extract accepted names of Juniperus

Although, as described above, you can create a taxon extract from a botanical records extract, you can also make taxon extracts more directly - as described below. This is a common first step when making monographic and other species reports.

- In the Conifer database, select Taxa > Extract/query data...
- Check the extract file is empty by clicking the Empty button.
- On the form, select Taxa > Genus > Select/Add to search list and the locate and select Juniperus.
- Now select the Name status option and choose the ‘acc’ to restrict to accepted names only.
Two search options selected on the taxon extract form

- Finally, click on **Search now** to extract the data.
- Assuming the **Auto-open extract** option on the form was selected, the resulting table will be auto-opened. Otherwise, close the form and select **Extracts > Taxa**
MORE EXTRACTS AND A START WITH REPORTS

Although reports can be created from any BRAHMS file, they are usually prepared from extract or RDE files. The following examples introduce the two main categories of reporting used in BRAHMS. These are known as Text and Visual reports.

Preparing a sample text report for Juniperus

Taxon extracts are used to create many different categories of report including checklists. Using Text Reports, reports can be formatted directly into your word processor.

- In the open taxon extract prepared above, sort the names using Fastsort > Family+species.
- Select Tools > Formatting for reports > Format species name to FULLNAME

Using this form, choose how you want the names to appear.

- Click the toolbar to open the main reports form and ensure Text/HTML reports is selected.
- Choose the report ‘Species list sorted AZ by family with linked description’ from the listed text reports.
- If this report does not appear, use the option Import report template sample(s) and Add the report as prompted.

- Click on the toolbar to generate this text report. You can copy and paste this result into a Word document – or use the toolbar.
- Close the report viewing screen.

CUPRESSACEAE

*Juniperus angustifolia* R. P. Adams
Description: Small trees or shrubs to 3–8(-10) m tall, evergreen, dioecious; trunk monopodial. Bark smooth on branches, soon exfoliating with small flakes, greyish-brown to grey, on trunks plates, inner bark light brown or cinnamon, outer bark weathering grey. Branches thick, last forming an irregular, spreading or more or less dome-shaped crown. Foliage branches ined straight or curved, 1–1.3 mm wide, quadrangular to terete (depending on physiology), retain (more on ultimate branches) or in alternating whorls of 3, lanceolate, appressed, or with a obovate-obovate ultimate branches, 1.5 x 0.7 mm, obsolete or acute, on thicker branchlet oblong-ovate, acute-pungent, upper margins minutely hyaline-serrulate (esp. of smaller leaves
- The report format used to create this report is a very simple one. If you click on Edit report template, you will see there are 3 command lines. You will learn how to edit these templates later in this guide.

Text reports are written to text files. They include HTML tags. You can include any HTML tags in text reports.

Tagging species to prepare a checklist of conifers for Madagascar

The following exercise introduces the Taxonomic Database Working Group (TDWG) geographic coding system. TDWG provides a standard, global geo-coding system. All accepted taxa in the conifer database are coded in this way thus defining their known geographic distribution. Botanical records provide more distribution details but only when stored in this database.

- Select Taxa > View/edit species in database to open the main species file.
- Select Tag > Clear all tags.
- Locate the memo field TDWG in this file. Set a filter so that the memo field TDWG includes ‘MDG’ which is the TDWG code for Madagascar. To do this, you could right-click on the TDWG column header and select Filter on selected text and edit as below:

![Filter on selected text](image)

Enter MDG in the Value prompt. It’s not case sensitive.

- Once the filter is set, tag all these records using Tag > Tag all with *.
- Close the species file.
- Select Taxa > Extract/query data.
- Check the extract file is empty by clicking the Empty button.
- On the query form, select Tagged > Tagged species > Select/add to search list then click on the Search now button.

This creates a query file of all conifer taxa known to be from Madagascar.

Preparing a sample text report for Madagascar conifers

- To produce this report, follow the same instructions provided above for the Juniperus text report.

PODOCARPACEAE


_Description_: Trees to 25 m tall, but often much smaller and shrubby; trunk to 60 cm d.b.h thin, exfoliating in strips on larger trunks, in small flakes on small trees, light brown weath grey. Branches numerous, spreading; foliage branchlets spreading or ascending, stout, teret ridged and grooved, terminating in robust, subglobose buds 4-6 mm wide, with imbricate, t ovate scales; lower scales carinate and weakly acuminate, with scarious upper margin. It highly variable in size, on the type specimen 3-6 cm long, 5-7 mm wide, but ranging from long and 3-16 mm wide on other specimens, elliptic-oblong to linear; mostly thick coriaceous but in one variety more lax and dropping, tapering towards a petiolar base and to an acute, acuminate (or long attenuate) or obtuse apex; margins slightly revolute; leaf colour lustrous above, dull green below. Midrib inconspicuous or obtuse on adaxial (upper) side, continuous pecting out distally, more distinct and continuous, with abruptly raised edges, on abaxial (side. Stomata in numerous intermittent lines on either side of midrib on abaxial side. Pollen: axillary, solitary or with 2-3 together on short peduncles, subtended by imbricate, rounded scales, cylindrical, elongating to 1.5-2.5(-3) cm long, 4-5 mm wide; microsporophylls in 3 with triangular, minutely denticulate apex, each bearing two basal, oblong pollen sacs. See _Juniperus_; foliage 0.5-3 mm long, slender peduncles, subtending of an axis with 3-4 fixed.

Section of the report, in this case opened as a word document
Extract botanical records by collector name

- In the Conifer database, select **BotanicalRecords > Extract/query data...**
- Check the extract file is empty by clicking the **Empty** button.
- Select **Collector/Number > Collector name > Select/add to search list.** As prompted enter 'Farj' and choose the collector 'Farjon, A.'.
- On the next prompt form, click **OK** to choose the defaults although note that you could restrict to a selected number range for this collector. Click **Search now** to extract these data.

View extracted collections using a Visual Report list template

- In the opened extract file, select **FastSort > Collector+Number.**
- Click on the ** toolbar again to open the reports form. Ensure **Visual reports** is selected.

  Choose the report 'Collection list with collector name/number + species + geodata' from the listed visual reports. If this report is **not available**, choose the option **import report template sample(s)**. Make sure you select the correct report on the dropdown.

- Click the ** button to view/print the report. Note that for Visual reports, you do not use the **toolbar.
- Close the preview by pressing **Esc**.

View extracted collections using a Visual Report label template

- In the same extract file, select **Tag > clear all tags** then locate and tag the Farjon records with collection numbers 440 – 445.
- Click on the ** toolbar. Ensure **Visual reports** is selected.
- Select **Tagged** in the Record selection area to restrict the report to tagged records only.

  If it not already selected, choose the report 'Label starter - A4, 6 per page surrounded by square box' from the listed visual reports. If this report is not available, choose the option **import report template sample(s)**. Make sure you select the correct report on the dropdown.

- Click the ** button to view/print the report (labels). Close this preview and the report form.

Adding a title to the Visual Report

- Select **Extracts > BotanicalRecords** to open the last extract file.
- Click again on the ** toolbar again to open the reports form ensuring that **Visual reports** is selected. Choose the report 'Collection list with collector name/number + species + geodata' from the listed visual reports (as used above).

The next challenge is to add some text and images to the report **Title** section. The Title section is printed once at the beginning of the report.

- On the report form, select the **Edit Report Template** button.
- With the report edit screen open, select **View > Reports controls toolbar** on the main BRAHMS menu. This opens the toolbar to assist with visual report editing.
The visual report template opened for editing with the Report control toolbar

- The first task is to create some space to add a title. To do this, drag the ‘Title band’ of the report down.

- On the reports toolbar, click on the A button. Then click in the report title (top) band and write some text such as ‘Collection list’.
- If you now click on the toolbar Arrow then again on this text, the text is ‘selected’.
- Dbl-click the selected text, select Style and choose a font as required.
- Now select the menu option Format > Align > Centre horizontally.

- To save these changes so far, enter Ctrl+W or you can use File > Close and save the changes as prompted.
- Click the button to view/print the report (labels). Press Esc to close this preview.

**Livening up a Visual Report template with images**

- To continue editing, again select the Edit Report Template button and open the editing toolbar as above.
- On the Reports Controls toolbar, click the button. Then click and drag open a small square shape in the report title area, top left. The size of this square can be changed later. The dialogue that opens allows you to locate an image file.
- The Control source type will by default be set to ‘Image file name’. Click on the find button opposite the Control source text box and locate any image available on your computer. If you have none, locate the image ‘\brahms\setupdata\report_samples\plant_sciences.jpg’.
- Set the Frame size mode to ‘Scale contents, retain shape’.
- Click OK to save these edits.
- Add more sample images to the report title band as you wish.
- To close and save the report template edits, enter Ctrl+W.
- Click the button to view/print the report.
Visual reports are mostly used for labels and lists. They are printed directly, not sent to text files. You can 'print' a visual report to a PDF.

Creating an index of collections

Lists of exsiccate, tedious to produce manually, are easily made in BRAHMS from either the taxon or botanical record extract files.

- In the Conifer database, select BotanicalRecords > Extract/query data...
- Check the extract file is empty by clicking the Empty button.
- Select Geographic > Country then Select/Add to search list. Choose a country that has conifers, for example China or Vietnam. Click on Search now to extract the data for the selected country.
- In the extract file, select Tools > Data summaries > List of exsiccate.

Lobbichler, F. 203, 241, 292, 428 (Juniperus semiglobosa); Miehe, G. 17, 18, 48, 226 (Juniperus squamata); 369, 449, 613 (Juniperus excelsa ssp. polycarpos); 780 (Juniperus pseudosabina); 1797 (Juniperus excelsa ssp. polycarpos); 1843 (Juniperus semiglobosa); 2064 (Juniperus pseudosabina); 2550 (Juniperus semiglobosa); 2663 (Juniperus excelsa ssp. polycarpos); 3536, 3678, 3679 (Juniperus semiglobosa); 4713 (Juniperus pseudosabina); 4718 (Juniperus semiglobosa); 4798, 4843 (Juniperus pseudosabina); 4922 (Juniperus semiglobosa); 4927, 4930 (Juniperus excelsa ssp. polycarpos); 4932, 4947, 4961 (Juniperus semiglobosa); 4968, 4970, 4971 (Juniperus excelsa ssp. polycarpos); 5025, 5051, 5058 (Juniperus pseudosabina); 6031, 6372 (Juniperus semiglobosa); 6373, 6396, 6415 (Juniperus excelsa ssp. polycarpos); 6417, 6418 (Juniperus semiglobosa); 6505 (Juniperus pseudosabina); 6670 (Juniperus excelsa ssp. polycarpos); 6686 (Juniperus pseudosabina); 6718, 6770 (Juniperus excelsa ssp. polycarpos); 6798 (Juniperus semiglobosa); 6826, 6883, 7045 (Juniperus pseudosabina); 7057 (Juniperus semiglobosa); 7058 (Juniperus excelsa ssp. polycarpos); 7114, 7115 (Juniperus squamata); 7116 (Juniperus excelsa ssp. polycarpos); Nüsser, M. 1796 (Juniperus squamata); 2701
USING RAPID DATA ENTRY (RDE)

Relationship between RDE and BRAHMS

Although data may be entered directly into BRAHMS, RDE is recommended for entering larger numbers of records. RDE can be used to enter botanical records (specimens), seed records, taxa, gazetteer names, references and images. RDE is a fast, flexible and safe - and you can make reports and maps directly from RDE.

RDE files, once ready, are transferred into a BRAHMS database. They can then be kept safely as backup files.

RDE FILES

BRAHMS DATABASE

When typing data into RDE, you can consult your BRAHMS database to lookup and auto-copy available data. RDE files have settings and functions to optimize field and record lookups, verification and copying.

RDE is also used as a data transfer mechanism when importing data from Excel, Access and elsewhere.

Create a new RDE file for botanical records

- Log into the Conifer database.
- Select BotanicalRecords > Add/edit botanical records using Rapid Data Entry files to open the RDE file manager.
- Select File > Create a new RDE file.... Select The system template option to create the file and choose a path and RDE file name as prompted.
- Your new file will be auto-registered in the RDE file manager. The RDE file manager tracks all your RDE files.

Your instructor will explain more about how to organize RDE file storage and also where NOT to store files. Also, how you can create new RDE files by cloning one with a ‘project-perfect’ structure.

Adding botanical records to RDE

- Select BotanicalRecords > Add/edit botanical records using Rapid Data Entry files to open the RDE file manager for collections. Then dbl-click on the file name to open your new file.
- Click on the toolbar to add a new record (or use ALT+A).
- Enter, as best you can, the data for your specimen(s).

Most fields have an obvious meaning (e.g. COUNTRY and COLLECTOR) but others are less clear. For information on any field, click on the field name and then on the toolbar.

A few basic rules:

1. Any field can be left blank.
2. Enter personal names using the format Smith, A.B.
4. Longer text entries are added to memo fields. An example in locality notes if these are given.
5. The DUPS field is used to cite herbaria where the specimen is held. Use codes as in ‘K’ or ‘K, MO, FHO’.
Field and record copying using F4 and Ctrl+F4

- Use the toolbar to add a new record. Press F4 to copy fields from the previous record.
- Position the cursor on any record with data. Enter Ctrl+F4 to duplicate that record.

Selective field copying using the toolbar

This toolbar is used to edit data copy settings to selectively copy fields when you add records. The fields selected depend on the data entry task. For example, it may be useful to copy the collector name, country name, day, month and year and other fields that mostly remain constant after a field trip.

- Click on the toolbar, and edit some of the copy settings.
- In RDE, position the cursor on the last record with data and then add one or more new records to test field copying.

Using F9 lookup options

- Click on the toolbar to add a new record (or use ALT+A).
- In the COLLECTOR field, press F9 to look for data in BRAHMS. Using the Name starts with prompt, locate and select the name ‘Farjon, A.’.
- In the SP1 field, press F9 to look for the species Juniperus sabina var. sabina – typing ‘ju sab’ in the Search for prompt will get you very close. Choose the correct name from the list and then press Enter. Note that the family and genus fields are also filled.
- In the GAZETTEER field, press F9 to look for a place. Note that all related geographic fields are also filled.

AutoComplete

The AutoComplete function attempts to fill in data fields as you type.

- In an open RDE file, click on the AutoC toolbar and ensure AutoComplete is enabled.
- Add a blank record to your file. In the FAMILY field, typing ‘Cup’ adds Cupressaceae. Typing ‘J’ in the GENUS field adds Juniperus. The names offered are restricted to the current family.
- Start typing into SP1. The names offered are restricted to the current genus.
- Try this in geographic fields.

Editing file structure

Standard BRAHMS RDE templates are likely to include fields that you will not need and they may exclude one or more special fields that you want to add.

- To open the RDE file, dbl-click on the file name or use the toolbar.

To remove, edit or add fields:

- Select File > Modify file structure....
- Click on the field SUFFIX and the Delete button to remove that field.
- Click on the field COLLECTOR and then reduce the field Width to 40.
- To move a field, drag the small rectangle to the immediate left of the field name.
- Click on OK to save the file structure changes permanently.
- Close the RDE file and the RDE file manager.
When you modify the structure of an RDE file, the system auto-creates a .BAK version of the file. If the file includes memo fields, a .TBK file is also created. These files can be safely deleted using your windows file manager.

**Opening the specimen level form**

RDE is a simple 'flat file'. In some cases, the level of detail you may want to store for a record is more complex. For example, you may want to store accession numbers for other herbaria, old determinations and type status details. This level of individual specimen detail can be stored using the SPEC form.

- Click on the Spec toolbar (or use the toolbar and select the Specimens tab). Note that the specimen level data already added to your RDE file will be registered in this form.
- On this form, click on the top button adjacent to Edit Specimens.
- Use F9 in the HERBARIUM field to choose a herbarium code from the available list. If the CATEGORY is blank, use F9 to select 'Herbarium sheet'. This action registers a further duplicate for this collection.
- Close the specimen form.

Using the Specimen form in RDE, you can add determination histories, type status and further details about one or more individual specimens of a botanical record.

**Custom lookups, AutoComplete and Verify data**

BRAHMS has a separate file where you can store lists of values for fields used in RDE and BRAHMS. The field value can be used to help enter and standardize data by using lookups (select from a list using F9) or AutoComplete (data auto filled in as you type).

Example fields are HABIT, IUCN, TAXSTAT and RANK1 – all of which have a relatively small number of potential values. Note that any field can be registered in this file with the field values by selecting Admin > Custom lookups.

Large dictionaries that are built into BRAHMS (e.g. the main people, taxonomic and geographic lists) have their own special lookup options. Values for these dictionaries do not go into the custom lookup lists.

To test how this works:

- Select Admin > Custom lookups to open the list. Your list will by default include some entries for the field IUCN. You can edit these values if necessary.
- Close this file after checking the various IUCN values.
- Select Admin > Project configuration > System wide settings > AutoComplete and ensure that the setting is not disabled.
- Select Admin > Project configuration > System wide settings > Forced data checks and tick the option Enable forced data checks.
- Now Select Taxa > View/edit species in database to open the main species file.
- Add a blank record and goto the field IUCN.
- Note that as you type into the IUCN field, the data are auto added. Also, if you type a bad entry, you cannot exit the field.

By editing custom lookup dictionary values and setting forced data checks, you can help standardize data entry.

**AutoMatching**

AutoMatching auto-prompts you with collections already stored in the active database and/or designated external file when you exit a specified RDE field. This function minimizes double entry of specimens.

- In your RDE file, click on the Onoff toolbar until is reads 'On'.
- Click also on the AutoM toolbar and enable the option Further checks on exiting the field and set the field value to NUMBER.
- In the Select field(s) to use for Matching list, select the NUMBER field and ensure all the other field names are not selected. You can experiment with different settings later.
- Ensure that the Data source(s) to check includes the current (logged into) database.
Close this form and test adding data to NUMBER and pressing ENTER. In the Conifer database, try adding any number e.g. 649 or 116.

**Using the RDEIMAGES memo**

Some sample specimen images are provided in your brahmsdata-conifers\Other sample files\Images folder.

If you have images of specimens or the labels, you can **right-click** on the memo field RDEIMAGES and locate these images. Image file names are added to the memo and can be viewed using the images using the toolbar. Alternatively, open the image viewer using the toolbar and drag images from Explorer onto the viewer.

![Image files are not stored in RDE or BRAHMS – only the reference to the file location.](image)

**Transfer the RDE file to BRAHMS**

Once you have added 5 or more practice records, transfer these data into the conifer database.

- Close the RDE file but stay in the RDE file manager and select the toolbar.
- If the RDE file includes images, the **image transfer** option will be enabled. Note that you can link the images to the botanical record as a whole or directly to the relevant specimen. If your images are of the plant habit, choose **Link to botanical record** but if your images are of specimens/labels, choose the **Link to specimen** at option and ensure the correct herbarium code is selected.
- Ignore **Link to transaction** unless you want to auto-link the imported specimens to a loan or exchange.
- Select **Check RDE file**. This produces a summary of what is new in the RDE file and flags up errors.
- Assuming there are no serious errors (**these will be reported in red**), proceed to **Transfer all**.

**Check your database files**

As a final step in this exercise, you can check the data added to your main database. When an RDE file is transferred into BRAHMS, each category of data is checked and appended to the appropriate file if new. In all cases, new records will be found at the bottom of unsorted database files.

- Select **BotanicalRecords > View/edit BotanicalRecords in database** and confirm that the expected records have been appended.
- Select **Taxa > View/edit species in database** to check for any new taxa. Repeat for families and genera if you added new names.
- Select **People > View/edit people in database** to check for new personal names.
- Select **Geo > View/edit gazetteer in database** to check for place names.

**RDE import problems**

If you see a red message as shown below, this means that BRAHMS has rejected your RDE file.

- Open the RDE file and read the contents of the RDE_ERRTXT memo field (this will be added to the end of the record structure).
REPORTING INTRODUCED

Text vs Visual reports

BRAHMS has two main ways to produce reports: Text and Visual reporting.

Text reports format your data into text files with HTML tags. These files can be transferred to text or word processor documents. Text reports are used to produce checklists, monograph accounts and similar. Text reports may include graphics generated using HTML tags e.g. lines (<hr/>) images references (<img src=>) and so on. Most BRAHMS users don’t know much about HTML tags — which is fine. You do not get any special knowledge. However bear in mind that, in addition to the tags added by BRAHMS for all the basics, any valid html tags can be included in your text reports. And so, if you do have a knowledge of tags, you could use these to set more elaborate fonts, styles, indents, etc.

Visual reports are generated using the Visual Report Designer. These reports are normally used to prepare lists, labels, det. slips, loan forms and other reports that are printed directly or sent to a PDF — rather than being passed to a word processor. Visual reports often include graphics (lines, boxes, images).

Learning curve

The BRAHMS report design options are flexible. You can achieve more or less any report you want using a visual or text report although clearly some experimentation will be needed. However, there is quite a lot to learn about both report categories — so it may take some time to conquer both. Most people enjoy designing reports.

Templates?

When you design a report, you are designing a template that can be used for any data of the same type — not just one report. If you spend a long time perfecting a label, don’t worry — the template you are designing may be used for the next 10 years to print many labels!

Managing your report template files

When you add a new report design, the template is auto added to your central reports library. You can open this using Utilities > View/edit all report templates. Note that templates are associated with a particular type of data. Thus — if you create a new design in a botanical record RDE file, that template can only be used with that file type. But of course, it can be used in any botanical record RDE file, not just the one you had open when you created the report. In the central reports library, you can delete and rename report templates.

Inheriting reports from another project

If you want to register a report from another database/project, use the Register an inherited report option on the reports form.

Importing report template samples

Some report sample templates are provided with BRAHMS and if available, you can import these to your database using the Import report template sample(s) option on the reports form.
TEXT REPORTS: A SAMPLE CHECKLIST

The objective of this exercise

The following exercise illustrates how easy it is to produce a checklist or text for revisions from BRAHMS using text reporting. You will create a text report template that generates examples similar to that shown below. Data in the longer descriptive fields are truncated and have ‘…’ printed after shortening.

PODOCARPACEAE


Description: Shrubs or more commonly small, stunted trees 3–10 m tall, rarely to 20 m; dbh to 50 cm. Back thick, smooth, becoming fissured and scaly, exfoliating with sloughy strips, brown weathering grey. Branches much spreading and contorted in older trees. Foliate branchlets stout, terete, with longitudinal grooves and ridges on vigorous shoots, less marked on slow growing shoots, terminating in large, broadly ovate blades with ovate-spiculate 5–6 mm long scales which are free towards apex, a few of the outer scales sometimes elongated to scale-like leaves 10 … Name origin: The species epithet (Latin coriaceus – skin) describes the thick, leathery leaves. Ecology Podocarpus coriaceus occurs in lowland forest or woodland on poor sandy soils in Trinidad and Tobago and on the Leeward and Windward Islands of the Lesser Antilles and in Puerto Rico in all forest on windward mountain ridges and summits from 500 m to 1100 m a.s.l. This vegetation type does not exceed 10 m in height and is usually much lower and scrubby.


Extracting and sorting the data

Although text reports can be created from any BRAHMS files, the most common use is from the taxon extract file. A first step is to extract all the taxa you want to use to produce the report. In this example, you will extract all accepted names in the genus Podocarpus.

- In the Conifer database, select Taxa > Extract/query data… Empty the extract file if necessary.
- Choose Taxa > Genus and select Podocarpus. Also select Name status and choose ‘acc’. Proceed to extract all the accepted names in the genus, just over 100 names.
- In your taxon extract file, select FastSort > Species to sort the list.

If you want to speed things up, you could extract data for just Podocarpus coriaceus or any other species.

A quick checklist at this stage

At this stage, you can already produce a checklist based on the data you have extracted. First, you need to create a text report template that includes minimally a reference to the FULLNAME field and then generate the report.

- Click on the toolbar option to open the reporting form. Ensure Text/HTML reports is selected.
- Select Create New template. The report file folder location will default to your Myreport folder unless set otherwise in your Folder settings setup options. Add a report template descriptive name as appropriate – the actual file name for the template will be auto-generated from this.
Dialogue for creating a new text report

BRAHMS will automatically add expressions (items to be included in the report) for the FAMILY and FULLNAME fields as shown below:

<table>
<thead>
<tr>
<th>Pos</th>
<th>Expression</th>
<th>ExprHtml</th>
<th>Decimal</th>
<th>Lines1</th>
<th>Punc1</th>
<th>Punc1print</th>
<th>Space1</th>
<th>Caps</th>
<th>Func2</th>
<th>Punc2print</th>
<th>Space2</th>
<th>Lines2</th>
<th>Norepeat</th>
<th>Noempty</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>tout.family</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

In the text report template designer, fields are always added with the short file name as a prefix as in tout.fullname. The short file names are known as file aliases (in this case ‘tout’ = taxon output). They are provided in the main browser caption bar (not seen here). The POS field control field order and can be edited. If POS is zero, the item is excluded.

- Click on Exit, leaving the default text report as above.
- Ensure that your report descriptive name is selected in the Select report template drop down at the top of the form.
- Click on the toolbar to generate the report to an HTML file. The result will auto-open. You can press Esc at any time to stop report production and then use the toolbar to view progress.

Example from basic list as generated above with names sorted and with some basic formatting.

- Close the preview screen before proceeding.

Formatting names and types

In the taxon extract file, tools are provided to format and/or add data summaries for each extracted name. These options format data in special extract file fields using HTML tags, preparing for inclusion in your text report.

- In your extract file, select Tools > Formatting for text reports > Names, synonyms and types to FULLNAME and SYNSUM. This provides formatting options for the accepted names including the assembly of synonyms and types.
Experiment with the settings on this form. In the above example, the species names will be printed in bold+italic with their authors, protologue citations and any notes stored in the species file NOMNOTE and TYPENOTE fields. Synonyms, in italic, are also added to the SYNSUM memo in your extract file. Note that types are included and the formatting requested here is for types to be printed in homotypic groups.

Adding and formatting specimens for each species

Assuming you want to include a list of specimens in this report, you can proceed now to use another Tools option to do this. The specimen data will be assembled for each name in your list and formatted into the taxon extract field SPECLIST.

- In your taxon extract file, select Tools > Formatting for text reports > Collection citation lists to SPECLIST.
- Choose Fully formatted citation lists. Later, you can learn how to format lists exactly as required using the Citation list formatting options but for now, you can use the default format provided with the conifer database.

Designing the final text report

The last step is to add a few more expressions to the report template. In the screen below, you can see the new entries refer to field in the file ‘tout’ (taxon output) and ‘linked’ (species link file).
You need to carefully type the report structure shown below into your template file.

The above text report template was used to produce a report sample similar to the example at the start of this section.

All the expression entries refer to fields in either the main or the linked file. The POS field controls the order of printing. The gaps in numbering are deliberate and facilitate insertions. Anything set to POS = 0 is not printed.

For an explanation of the various columns in the designer, click on the Editing help on option on the lower part of the design form.

A few design points are explained here:

The entry 'T' in fields such as CAPS signifies True; The entry '<hr/>' in the PUNC2 column (punctuation after printing the expression) in the HTML tag to draw a line; The '....' in some of the PUNC2 columns have been added as the text data are truncated in the conifer database; Note that as the LINES2 value for the expressions linked.descrip and linked.etymology are set to 0, these items will be printed (also with linked ecology) in a single paragraph. The LINES2 value 2 will print 1 blank line; The field NOEMPTY, if set to T, suppresses printing of expression (and the related punctuation) if there is no data; The field NOREPEAT suppresses printing an item in a sorted file until it changes.

- Edit the your checklist text report template (created above) and add in the expressions and related punctuation as shown above. If you want to keep that basic list, you can create a new template for this more detailed one.
- Click on the toolbar to generate the report to an HTML file. This should produce the sample shown at the start of this section in an HTML browser screen.
- Close the browser and then click on the toolbar to open this in Word. In the example, the word document is formatted in 2 columns (Format > Columns).
VISUAL REPORTS: DESIGNING A SPECIMEN LABEL

Designing labels
To design a report template for labels, you need to learn about some of the Visual Reports design tools. The following exercise takes you through step by step. The result you want to achieve (or something similar to this) is shown below. There are countless different ways to design labels. Once the basics are mastered, you can choose your own designs.

The above label sample is printed in 2 columns, with a shaded background, each displaying an image of the plant. Otherwise, the labels include standard fields expected on the typical specimen label. Each label is boxed. Any of these features can be removed from the design as you proceed. The special features are included here partly to illustrate what can be achieved.

Labels are usually created from RDE and/or botanical record extract files. Although very similar, you will need a separate label template for each file. This is explained further at the end of this section.

While this section deals with labels, the procedures discussed can be applied to develop many further types of visual report template.

Getting ready with your RDE file
You need to have an RDE file which includes the common standard fields and has at least some data ready to print. If one or more fields (represented in the report template) are missing, you will get a warning message when you try or preview or print.

- To refresh any calculated RDE fields, open your RDE file and select Tools > Refresh label fields. This will update fields such as GEODATA, COLLECTED and LATLONG.

The content of the calculated GEODATA memo can be configured from Admin > Project configuration > System wide settings > Geo. On the Dates tab on that form, you can also choose the date format for COLLECTED.

Creating a new visual report template
- Click on the reports toolbar and ensure the Visual reports option is selected.
- Select Create new template.
- The report file folder should default to your ‘myreports’ folder. As prompted, add a report file name (e.g. relabel01) and a report description (e.g. My sample label 1). Select OK to create the report template.
- At this stage, it is recommended that you enter Ctrl+W which is shortcut to save the work and close the template designer.
- To re-open and continue designing, ensure your label name (report description) is selected in the Select report template drop down at the top and then click on Edit report template.
**Report bands and columns**

The default visual report designer has 3 ‘bands’ Page Header, Detail and Page Footer. Of these, we only require the **Detail band**. To effectively remove the others:

- Drag the Header band up to the very top and the Footer band up to touch the Detail band.
- Also, to set this report to 2 columns, select **File > Page setup** and set the **Column number** to 2.
- You can also drag the Detail band down to the 9 cm mark as shown on the left side. (Note that a **right-click** on the Detail band provides access to a properties menu where, using the **General** tab, you can set the height precisely).

Note that if you were preparing a visual report template to generate a list with columns, you would add text labels (e.g. ‘COLLECTOR’) to the header band. The header band is printed at the top of each page. You can also add a title band which is printed once at the start of the report.

**The Report Controls Toolbar and editing grid**

A special report design toolbar is needed for this task. The toolbar has options to add boxes and lines, text labels, and data and images from your file.

- Select **View > Report Controls Toolbar** to open the design toolbar.
- At this stage, also useful to select **View > Grid Lines** to enable an editing grid.

For help on the Report Controls Toolbar, search for the text ‘Report Controls Toolbar’ in the help file. Each on the toolbar options is explained.

**Setting a default font**

Before proceeding further, it will be useful to set a default font for your label. This will save time as you add labels and field expressions.

- Right-click on the blank label surface and choose Properties > Page layout and set the default font to Arial, Regular 9 point size – or another font/size as you prefer.

**Adding a box surround for the labels**

Adding a surround box can be useful when designing labels as it gives you a more defined area to work in and it helps when previewing your labels. The box can be easily removed later on.

- Click on the rectangle icon on the toolbar and then drag a box onto the label design surface, roughly from top left to bottom right. The exact position and size can be adjusted later.

Your screen up to this point should be similar to the above.

- Before going further, enter **File > Save**.

The next task is to set the background colour of the added rectangle. To do this:

- **Dbl-click** on any of the box edges and select the **Style** tab on the properties form.
- Remove the tick from the **Use default background (fill) colour** option.
- Select a colour using the lookup provided. You can define a custom colour.
As you proceed to design your label, select **File > Save** frequently to avoid loss of your hard work ...

**Adding a text label**

If at any stage the designing toolbar vanishes, select **View > Report Controls Toolbar** to re-open it.

- Now click on the Report Controls Toolbar and then click once on the label surface inside your box area and type in the name of your herbarium or any text to appear at the top of the label.
- After typing the text, click on the Report Controls Toolbar (Select objects) and then click once on the text label you have just added. This will **select** this object and you will see handles (small selection marks) at the label corners.
- If you **dbl-click** on the label and select **Style**, you can increase the font point size for this as you wish, perhaps also setting it to bold.
- After doing this (the text label will still be selected), on the menu, select **Format > Align > Center Horizontally**.
- Also note that you use your up and down keyboard arrows to fine adjust the item position up/down/left/right.

**Label previewing**

At any stage during the design, you can save and close your report template (using **Ctrl+W** is a fast way) and click on the toolbar to view progress. If your RDE file has many records, tag a few and use the Restrict to tagged option on the reports form.

**Adding the family name**

Bear in mind that you can add report items in any order. As a next step here, you can add the family name. The family differs from the text label added above as it may change, record by record, in your data file. Thus, rather than adding a basic text label, you must add a field expression.

- Click on the Report Controls Toolbar, click on the label surface. In the Expression box, enter RDE.FAMILY (this can be in upper or lower case). ‘RDE’ is the short file name for RDE files and FAMILY is the name of the field in the RDE file. Note the ‘.’ between the two words.
- Should you want to print the family name slightly larger than other label features and perhaps in bold, select **Style** (dbl-click on the expression box if the form was closed) and set accordingly.
- If you want to add the fixed text label ‘Family’ to the left of this, click on the Toolbar and then click once on the label surface let of the family expression and add the text ‘Family’.

At any stage, you can drag these label objects to refine their positions.

The label so far - in design mode

The label so far - in preview mode
Adding the species name

Species names are a bit tricky as names are composed of more than one field and they often require the mixing of italic and regular fonts. You cannot mix fonts within a single expression.

- If you don’t need italic font or are happy to print the species name and authors all in italic – you can add an expression to your label – following the same procedure used for the family name but using the expression: `alltrim(rde.genus) + ' ' + alltrim(rde.sp1) + ' ' + alltrim(rde.author1)`.
- If you want to print the names with mixed format, the simplest option will be to select the option Species names sample on the report form and to copy the code there onto your label surface.

The `alltrim()` function removes leading and trailing spaces from the fields. If you do not use it, you would end up with something like ‘Dioscorea sagittifolia Pax’.

Adding locality data

The easiest way to add locality data is to use the calculated memo field GEODATA. You can adjust your Admin > Project configuration > Geo options to control the content of the GEODATA memo. Remember to update this field using Tools > Refresh label fields after editing your RDE file.

- Click on the Report Controls Toolbar, click on the label surface. Drag the box to form a ‘paragraph sized’ area on the label surface – it can be resized later. In the Expression box, enter `rde.geodata`.
- If you want to print the contents of the calculated field LATLONG together with GEODATA, you can edit the expression to `rde.geodata + rde.latlong`.
- If you want to force the latlong data onto the next line, use `rde.geodata + chr(13) + rde.latlong`.
- To leave a blank line, use `rde.geodata + chr(13) + chr(13) + rde.latlong`.
- Use the toolbar to add the text label ‘Locality’ or similar - as for the family.

Some experimentation will be needed to get the optimal size of this locality text box. You can drag the box lower edge up/down to resize. If it is not deep enough, longer text entries would be truncated.

Building a field expression, combing the geodata and latlong fields, forcing a blank line between them.

Adding other field notes

Using a similar procedure to the above, you can add a further paragraph sized expression to display the PLANTDESC memo, perhaps combined with HABITATTXT. Bear in mind that you have the choice about which fields to include, where they are located and how they are combined with other fields For example, you could equally combine HABITATTXT with GEODATA and LATLONG.

Adding the collector name and date

The collector name is added in very much the same way as the other fields discussed above, for example, the family name. In this label example the name and number are combined in a single field expression.

- Add a field expression to the label and set the expression text to `alltrim(rde.collector) + ' ' + alltrim(rde.number)`.
- Add a further, separate expression set to `alltrim(rde.collected)`. If you want the date to be printed on the right side of the label, drag the date expression box to the right side and also select on the menu Format > text alignment > Right.
In this example, additional collectors are added below the main collector in a separate expression.

**Adding images to your label**

Skip this stage if you don’t want to add any images to your labels. There are two categories of image addition considered here. You can add:

- a **fixed image** to all your labels (perhaps an institutional logo or a small country map).
- images that **vary record by record** – e.g. of the plant habit.

- Click on the toolbar and then drag a small square top right of your design surface. The final size you can adjust later.
- To add a **fixed image**, set the **Control source type** to ‘Image file name’ and locate an image file using the lookup provided.
- Most likely, the image will not be the same size as your label image area – and thus, you will benefit by setting the Source/Frame size to **Scale contents, retain shape**. If you do not, the image will be clipped.
- To add a variable image, set the **Control source type** to ‘Expression or variable name’ and add the RDE field name to the **Control source** text box.

You may have several images per record stored in RDEIMAGES memo. As only one image is permitted for Visual Report image display, you would then need to create a new field called *e.g. LABELIMAGE* and copy the selected image filename here, editing the report expression to RDEIMGELABEL. You may want to print several images, in which case you could add to your RDE file the fields LABELIMG1, LABELIMG2, or equivalent.

Each record in the file must have a valid image - otherwise the reporter will generate an error. As one or more records may not have an image, the safe procedure is to add a **Print when** clause, using the tab provided, as follows:

The expression `file(alltrim(rde.rdeimages)) = .t.` restricts processing to records where the image file is located.
Aligning fields

To tidy up your label design, use the options on the Format menu. In the example below, the left side text labels have been collectively selected (use shift+click to do multiple selections). You can then use Format > Align > Align left sides. Repeat this to align other fields as necessary.

![Image of label design options](image)

Labels for RDE or extract files

If you want to print labels from RDE or extract files, you will normally need separate reporting templates for each – even if they are very similar. This is because when adding field expressions to templates, it is recommended you use the format filealias.fieldname where the filealias is the short name of the file you are reporting on and the fieldname is the name of the field in that file. Thus, ‘rde.collector’ and ‘cout.collector’ refer to the field collector in the RDE and COUT files respectively (COUT = Collection Out). File alias names are displayed at the top of each opened file in BRAHMS.

If you design a good label for an RDE file with a filename e.g. ‘MYRDELABEL’, when editing this, you use File > Save as to save a copy to e.g. ‘MYEXTRACTLABEL’ and then register this new label in your central reports library and edit the template as required.

To register a report template, select Utilities > View/Edit all report templates, add a blank record, F9 in the Report template file field to locate the saved report template file. You must also a) set the report type to ‘V’ to indicate it is a visual report and b) Use F9 in the Report used in field to choose Collection extract file.

![Image of report template registration](image)

The central report library stores details on all your report templates

Printing to a PDF file

If you have software installed to print to a PDF file. Rather than printing your labels directly, you can create a PDF file. Example free software is available on [http://www.primopdf.com/](http://www.primopdf.com/).
Developing the Species List

Families, genera and species

All BRAHMS databases include lists of families, genera and species. A database may consist only of taxonomic names and information about these names.

In addition to a basic list of names, you can include detailed nomenclature at the family, genus and species level (synonymy, types, protologues, etc.) together with facts about species such as habit, IUCN status, local and global distribution, descriptions, ecology, uses, conservation notes and so on.

If BRAHMS does not include a species field that you need, you can add this using the species link file.

Manually adding family, genus and species records

Taxon names are usually added to BRAHMS when taxon, specimen or other RDE files that include the names are imported. However, from time to time, you may want to add names individually.

- Select Taxa > View/edit Families in database. Click on the toolbar to add a blank record and type a name into the FAMILY field. Choose any name e.g. 'Anacardiaceae'. It is not necessary at this stage to add any further details – but if you wish to, you can add in the author name (using a lookup), citation, publication year. Let's assume your new name is an accepted name – use a lookup in the TAXSTAT field to set to 'acc'.

- Select Taxa > View/edit Genera in database to add a new genus name – e.g. 'Spondias' and using a lookup in the FAMILY field, link this name to your new family.

- Select Taxa > View/edit Species in database to add a new species name. Use a lookup in the GENUS field to link this name to your new genus (and thus family) and enter in a species epithet to the SP1 field – e.g. 'testii'.

- Set the TAXSTAT of this new species to accepted ('acc').

- Now add a further new species in the same genus but with a different name.

Editing author names

To add the authors of taxa, use a lookup in the relevant AUTHOR field, click on Add name and locate an author name using the default abbreviation search – followed by Save. When adding multiple author names as in the complex example (Fisch. & C.A. Mey.) Lindl. & Gordon, you add each of the author names and edit their properties - Basionym or Publishing author + the punctuation 'ex', '& or 'comma'.

Use a lookup (F9 or right-click) in the author field to open the above form. In this example, the species author is '(Farjon & Hiep) D. P. Little'. The names Farjon and Hiep are basionym authors while D.P.Little is the publishing author. Hiep is also indicated * in the '& authorname' select box.
Editing synonym links in the species file

Synonym links are most commonly made in the species file – but note that families and genera may also be linked as synonyms.

- Select Taxa > View/edit SPECIES in database to open your species file.
- Locate the last species you added above.
- Click on the =>syn toolbar and as prompted, locate the first of your 2 new species and make the a second name you added a synonym of this first name.

When a synonym is added, the ID (spnumber) of the correct name is added to the SYNOF field. By default, the SYNCAT is set to ‘SYN’ although you can later edit this using the lookup option provided.

- To review the nomenclature of your new names, click on either of the names and then on the nomc toolbar.
- To remove a synonym link, click on the synonym record in the nomc screen and then click the –syn button.

Adding link file fields

- Select Taxa > Default linked data file (SPLINK) to open the species link file.
- Select File > Modify file structure … and add 2 new memo fields called LOCALDIST and LOCALECOL to store details on local distribution and ecology respectively.
- Save these changes
- Select Taxa > View/edit SPECIES in database to open your species file. Use the toolbar to open the link file.
- Add some sample text to these memo fields for your two new species.
- Open the Zoom window using the toolbar and check that your text is visible.

Import names from IPNI

For monographers, a useful first step may be to import a draft list of species names from the IPNI website. In this exercise, you will import a list of names from IPNI into BRAHMS via an RDE file.

- Select Taxa > Add/edit taxa using Rapid Data Entry files. Here, select File > Create a new RDE file … and select the System template option and proceed to create a new RDE file for taxa.
- Open the BRAHMS help file and locate the option Rapid Data Entry > RDE data import and convert tools > Taxon names from IPNI to BRAHMS.
- Run through the steps in the help file to import the IPNI data to RDE.

To check any species name in BRAHMS, go to that name in the species file, RDE or elsewhere and click on the toolbar.
BOTANICAL RECORDS

Botanical records and specimens
A botanical record represents the occurrence of a species in a locality. For some projects, this may be restricted to physical specimens stored in herbaria. On the other hand, some projects store information about field observations where there is no actual voucher (specimen) — perhaps just notes and one or more fotos. In other cases, a botanical record could be based on a literature reference.

The CATEGORY field in the main botanical records file indicates the type of record. “V” is for a vouchered collection while “O” represents a field observation with no voucher. The default is ‘V’.

A botanical record may have one or more specimens — physical objects. Examples are herbarium sheets (the most common), spirit collections, silica dried leaf samples for DNA extracts, wood collections and bruchid beetles. A botanical record often has duplicate specimens that are distributed to different herbaria.

Several physical specimens may be collected from this tree.

The tree represents a botanical record: species x locality.

Specimens have data attributes that differ from that of the botanical record. These include herbarium location, specimen category, barcode, accession number, type status and determination histories.

Botanical record categories can be edited using BotanicalRecords > Resource files > Botanical Record categories. The 3 default entries are ‘V’, ‘O’ and ‘L’.

Specimen categories can be edited using BotanicalRecords > Resource files > Specimen categories. The category ‘Herbarium sheet’ coded ‘HS’ is always added.

Manually adding a botanical record with 3 specimens

- Select BotanicalRecords > View/edit botanical records in database.
- Add a blank record using the toolbar. A ‘V’ will be added by default to the CATEGORY field unless your setup instructs otherwise.

Many fields in this file must be edited using a lookup option as the fields cross-reference to data in other files.

- Use F9 in the COLLECTOR field to open the relevant lookup function. Use the Add name button to add one or more collector names.
Enter some data for fields such as prefix, number, suffix, day, month and year. These can be freely edited. Leave fields blank as you wish.

Using an F9 lookup in any of the species related field fields will open the specimen level form. You can also click on the spec toolbar.

The upper part of the specimen form lists the specimens, their category (here 3 Herbarium sheets) accession numbers/barcodes, type status if applicable as here and a few other facts. The lower part of the screen lists determinations for the individual specimens.

Add one or more specimens to your new botanical record. Use F9 or right-click to lookup values in the CATEGORY and HERBARIUM field.

In the lower part of this form, use a lookup in the DETERMINATION field to locate and select a species name. You may also add the DETBY name and date. If the name is new or a name change, you will be asked if you want to change the name.

Use a lookup in any of the geographic place name fields to locate and select a country, area or place name. Locality free text notes are added into the LOCNOTES memo.

Enter a map reference suitable for your country. Make sure you also fill in the NS and EW fields. Test your map reference using the or toolbar options.

Notes describing the plant habit are normally added to the PLANT DESCRIPTION NOTES memo. Habitat notes can be added to HABITAT AND SITE DESCRIPTION.
THE MAPPING REVOLUTION

Recent advances

These days, very high quality map data is available on the web either to download to use with your own GIS or indeed to plot directly on Google Earth or Google Maps. Pinpoint accuracy is possible and BRAHMS provides you with up to 10 decimal places in case you want to draw lines right in the middle of forest trails or plot plant positions in botanic gardens.

A vast amount of useful map data is available on the internet and, as one example, you can get excellent SHP file base maps from http://www.diva-gis.org/ following the free spatial data link.

Map style and Google Earth

The following example is for users hooked up on the web with Google Earth installed. As well showing how easy it is to make a map, it introduces map style setting.

You can change the data used in the example if you want.

A few colourful points plotted using Google Earth down the centre of Kew Bridge in London just next to the herbarium.

- Select BotanicalRecords > Add/edit botanical records using Rapid Data Entry files to open the RDE file manager for collections.
- Use the toolbar to add a new record and then use F9 in the FILE NAME columns to locate and register the sample RDE file Brahms6\Setupdata\Mapping\RDEsample\Kewbridge.dbf this file in your RDE manager.
- Open the RDE file.

This RDE file has been edited with lat/long references already in decimal degrees (LLUNIT tells us this) and uses map the style fields MAPCOL, POINTSCALE and MAPSYM to control the colour, size and symbol of each point.

- Finally, select the toolbar and choose Google Earth. Ensure the All option is selected and click Map all.
PRODUCING MAPS

Some notes on mapping
Maps are easily prepared from any RDE or BRAHMS file that has numeric LAT and LONG fields. If online, you can plot individual points using the or toolbar options (for Multimap and Google Maps respectively).

The toolbar opens the main mapping form used to plot the points in the current file to your selected GIS.

Map precision check for online users
- Select BotanicalRecords > View/edit botanical records in database.
- Add a blank record using the toolbar then press Enter until you reach the LAT field.
- Enter the coordinates of the kick-off mid-point in the Stade de Mahamasina, Antananarivo, Madagascar. LAT = 18.919372 S and LONG = 47.525690 E.
- As these units are in decimal degrees, enter ‘DD’ in the LLUNIT field. This will override any general map unit configuration settings. Do not enter negative values.
- To check all records are untagged, select the menu option Tag > Clear all tags.
- Now tag your newly added record. Just that one record.
- Click on the toolbar. Ensure Google Earth is selected.
- Select the option Restrict map to tagged records.
- Click on Map tagged.
- When you close Google Earth, do not save map items to temporary ‘My Places’ as prompted.

You could also add this record to an RDE file and produce the map from there.

Preparing a map for 2 species using DIVA GIS
When publishing maps, you will normally need to map your data in black and white on a clear and sharp base map (not overly complicated). You can use ArcView or Diva to do this. The following exercises introduce DIVA.

ArcView users can stick to ArcView.

- Open the BRAHMS help file and go to Training exercises > Mapping > Creating a map using DIVA GIS.
- Follow the step by step instructions in this exercise. You should complete the exercise with a completed map in a Word document similar to that shown below.

Introduction to style setting for Google Earth
The task now is to plot the same map in Google Earth, style set to show each species in a different colour and symbol.

- Return to the 2 species botanical record extract file created in the above exercise. If the file is closed, select Extracts > BotanicalRecords to re-open.
- Open the BRAHMS help file and go to **Training exercises > Mapping > Google Earth map and basic style setting**.
- Follow the step by step instructions in this exercise. You should complete the exercise with a completed map similar to that shown below.

*If you do not see the two colours, close Google Earth, return to BRAHMS and make sure the filter set in the exercise is removed and try again.*
IMAGING SPECIMENS AND THEIR LABELS

To image or not?
Herbaria undertaking large scale digitization of their specimens benefit enormously by integrating data entry with the imaging of specimens and their labels.

Using a modestly priced digital camera with flash, auto-focus and macro functions, images of entire specimens and images of the labels on specimens can be taken efficiently. Experience tells us that a trained specimen imager can take well over 1000 images per day, equivalent to more than 500 specimens.

Herbarium databases benefit from having images linked to the record in multiple ways. The ability to see an image of a specimen and especially its label provides by far the best way to verify and correct herbarium data, avoiding the need to hunt down specimens in the cabinets. Numerous errors are corrected in this way. Having images linked to specimens enlivens and enriches any herbarium database and facilitates going online.

With imaged labels linked up in the database, the entry of lengthy field note text becomes optional. Projects that have access to images of duplicates from other herbaria make yet further gains as images of duplicates can be compared often leading to a further wave of data correction.

Beyond strongly supporting specimen imaging, we go further to recommend data entry directly from the label images. Data entry from label images has certain advantages with respect to sorting data and thus being able to copy data from previous records. Specimens can be more quickly processed and returned to the cabinets. Data entry can take place anywhere, not necessarily physically next to bulky specimens.

Taxonomic vs database imaging
The rapid imaging methods discussed here should not be confused with the very high resolution images taken mostly for taxonomic purposes. Such images are often taken with special scanners or camera equipment. We encourage high resolution imaging for taxonomic purposes. However, imaging of this nature, often reserved for a subset of herbarium specimens including type specimens, is more time consuming and does not necessarily result in separate images of labels as advocated here.

Certainly, higher resolution images can subsequently be batch processed to make smaller resolution copies and if a herbarium has the resources to take large number of high resolution images of specimens and their labels (e.g. > 10Mbytes), this is fine.

We suggest using a camera setting of 2 Mbyte resolution. This size is more than adequate to see most details on any specimen. Label images can subsequently be batch reduced to < 500K per image.

Taking images of specimens and their labels

To optimize efficiency and speed, images can be taken with a hand held camera rather than using a fixed position tripod. This makes it far easier to reframe the images between specimen and label. Flash is recommended. If specimens are in plastic bags, flash is not practical unless specimens are removed. Use side lighting instead. Place a fixed size measure (ruler) on a blank part of the specimen.
Assembly of image file names to RDE

The process described here captures images into a Botanical Record RDE file.

- Transfer the images from your camera to a folder on your hard drive. The images will have their default camera file names.
- Select BotanicalRecords > Add/edit Botanical Records using Rapid Data Entry files. Select File > Create a new RDE file copying the ‘System Template’ as prompted. Name this file IMAGETEST or equivalent.
- When making your new file, ensure that the option Include RDEIMAGES memo is selected.
- Now select Tools > Images in RDE > Append images to RDE file. This will append all images from your selected folder, adding the complete image file name to the RDEIMAGES memo. Each record will contain one image.
- To check this has worked, go to top of the file and click the toolbar and move through the file to view the images.

If the sheet has an accession number and/or barcode, include these with the label – or take a separate image if necessary. If you are adding barcodes at the same time as imaging, add the barcode first – then take the image.

In the next phase, these numbers will be typed in to rename the image files.

Initial entry of accession or barcode numbers

The next step is to enter sufficient data from your images to the RDE file to be able to rename the image files appropriately. The objective is to rename your image files to include:

1. your herbarium code
2. the herbarium accession number or barcode
3. and a suffix that indicates what type of image it is – specimen or label.

There are other ways to rename images but in this exercise, you will use accession number. To simplify and speed up this step, you should create a field view for the RDE file that includes the following fields: TAG, DEL, FOTOPREFIX, ACCESION, FOTOSUFFIX, RDEIMAGES, IMAGETEMP and NEWNAME. No other fields are required at this stage. Select BARCODE instead of ACCESION as appropriate.

- Close and re-open your RDE file. This will ensure that the new FOTO fields are available for field selection.
- Click the toolbar to define a field view to include the fields listed above and save this with a suitable name e.g. ‘Image editing’. The reason for setting up this field view is to speed up subsequent data entry.
Field view set to show selected fields only and thus speed up data entry

- With this field view selected and the current image visible (using the toolbar), what you now need to do is enter the accession numbers by reading these off the images. Enter the barcode if using barcodes.

Note that specimen with accession number 12351 has 2 records – there are 2 labels.

- Enter your herbarium code into the FOTOPREFIX field. As this will be standard, you will use F4 to copy next records. Alternatively, you could use a FoxPro command Replace FOTOPREFIX with “ABC’ all at any stage (replace ABC with your herbarium code).

- Use the FOTOSUFFIX field as follows:
  1. if the image is a whole specimen, leave this field blank.
  2. If the image is of a label, enter “_L” (upper or lower case - but be consistent)
  3. If the image is of a second or further label for the same specimen, enter “_L1”, “_L2”, etc.

For example, a specimen may have 2 labels images. In this case, the first RDE record with the image of the whole specimen will have a blank FOTOSUFFIX, the next 2 records will have “_L” and “_L1”. All 3 records will have the same ACCESSION number entry as they all refer to the same specimen. The actual character used in not important (e.g. in Brazil, they use “_e” for ‘etiqueta’).
Image file re-naming – step 1

The next task is to re-name the camera derived image files. Our objective here – and bear in mind you may want to re-name your images differently – is to convert the images files to be something like "ABC_123.JPG" and "ABC_123.JPG_L" where ABC is your herbarium acronym.

Once you have completed filling the ACCESSION and FOTOSUFFIX fields:

- Select Tools > Images in RDE > Image file renaming > Generate IMAGETEMP from ... choosing the accession or barcode option as appropriate. This will compile the new ‘proposed’ image file name to replace the camera name.

The next task is to convert the IMAGETEMP to NEWNAME. The NEWNAME field adds the image file extension and the full path – this constructing the full image name. At this stage, if more than one image has the same name, warnings are given. Clearly, you cannot use the same name more than once.

- Select Tools > Images in RDE > Image file renaming > Generate NEWNAMEs using the IMAGETEMP field for tagged records.

If the same name is used more than once (i.e. generated from IMAGETEMP in turn from your prefix, accession/barcode and suffix fields), a warning is generated: "!*! Duplicated new file name" and added to the NEWNAME memo. For these records, an ‘X’ is added to the TAG field.

Image file re-naming – step 2

Once the NEWNAME field is filled, you are ready to proceed to the final re-naming stage which is to physically re-name the images on your disk.

- Tag the records you want to rename. The following option only processed tagged records.
- Select Tools > Images in RDE > Image file renaming > Physically rename TAGGED image files on disk to NEWNAMEs.
- Using your file manager, check that the images on the disk have in fact been correctly renamed.

Gathering same-specimen records

Most specimens will have 2 records in the RDE file (specimen + label). In some cases, more than 2. In the next step, you will merge same specimen images into one record, paving the way for data entry. We can match specimens using the accession number or barcode.

- Select Tools > Images in RDE > Image file renaming > Gather images of same specimen ...
- Choose the field ACCESSION or BARCODE as used in the exercise.
- Tick the option ‘Delete records that have been merged’.
- Optionally restrict to tagged.

Data entry

Your course instructor will now explain how to proceed with data entry using the label images.
DIVERSITY ANALYSIS INTRODUCED

Notes on diversity analysis and DistDiv options

Distribution summary table (DST) options are all located on the main DistDiv menu option which is enabled using Utilities > My Setup/Profile > Active modules.

The purpose of these options is to calculate and display summary data about the distribution of taxa and to calculate diversity indicators. Summaries are executed for TAXON x AREA combinations. Example summaries are ‘family x country’, ‘genus x major area’ and ‘species x gridcell’. In the last example, if grid cells were set to 1 degree square, the DistDiv options would generate tables with:

1. Distribution table: separate records for each degree square x species combination
2. Diversity indicators table: separate records for each grid cell summarizing its content

Taxon quick codes

Some of the options associated with the DistDiv options (e.g. export to PC-ORD) require short codes for family, genus and/or species records. You can easily generate/refresh these.

- Select Taxa > View/edit SPECIES in database followed by Tools > Generate species quick codes to SPQUICK. Although you can adjust the settings, it’s recommended you choose all the default and click on Generate. The results you will see in the field SPQUICK.
- Repeat this for the family and genus files.

If any taxon records lack quick codes, you will be auto-prompted to re-generate these codes when you run the DistDiv options.

Generating DistDiv summary tables

- Select DistSum > Create/View DistDiv for current database.
- If the DistDiv form does not auto-open, click on the Re-calc toolbar.

On this form, adjust the settings as seen above. Thus based on the data source “Vouched collections”, you will generate a table with one record for each family x country combination.
- Also tick the option Also create diversity sum table in the lower part of this form.
- Ensure none of the Data restriction options are selected and then click on the Calculate option.
A sample result screen with a filter set on Podocarpaceae

- Sort the table on FAMILY column and/or set a filter on a selected family. Note that each record includes a summary of results, for example, the total number of vouchers and the map grid range.
- You can repeat the recalculation for any combination of TAXA x GEOGRAPHIC RESOLUTION settings.

Checking grid cell definitions

- Select DistDiv > Add/edit grid cell definitions. If the file is empty, select Tools > Add sample grid cell records. You can add further definitions here if necessary.
- Meanwhile, note that the field CELLSIZE includes the cell dimensions. The value ‘1’ represents 1 degree square cells. The value ‘1/10’ represents 1/10th degree cells.

Recalculating the DistDiv for 1/10 degree cells and mapping on Google Earth

To speed up this next stage, you can restrict the calculation to a subset of your database.

- Select BotanicalRecords > Extract/Query data, choose Geographic > Country and proceed to extract all records from ‘New Caledonia’. Close the extract file.
- Select DistDiv > Create/view DistDiv for current database. If the DistDiv form does not auto-open, click on the Re-calc toolbar.

- On this form, adjust the settings as seen above. Note that the Data restriction option Extracted botanical records is selected. Thus based on the data source “Vouched collections”, you will generate a table with one record for each species+ssp/var x 1/10 degree grid cell – and the calculation will be restricted to the New Caledonia data subset.
- Examine then close the main DistDiv results table.
- Select DistDiv > View calculated diversity indicators per area. This file includes a summary of taxa and diversity indexes for each 1/10 degree cell area.
Sample diversity indicators file sorted by species. This file includes one record per gridcell, tallies various parameters (e.g. species and total taxa) and calculates various diversity indices. For further details refer to the help file.

- Now select **Tools > Map tools > Add/re-set map style fields**. This will add some extra columns useful for Google Earth mapping.
- Sort the file on the Column TAXA then go to the bottom of the file. Note that some cells have a value greater than or equal to 10 different taxa per cell.
- For each record where TAXA >= 10, add "R" to the field MAPCOL. This is a short code for the colour red.
- Click now on the toolbar and ensure Google Earth is selected.
- On the map form, click on **Draw polygons for cell boundaries**. Then click on Map all.

Sample output showing the most diverse 1/10th degree cells in red. To open the text box, use **Ctrl+click** on a selected cell.
THE POWER OF FOXPRO COMMANDS

Why use FoxPro commands?
The ability to use FoxPro commands in RDE (and elsewhere) opens up a further dimension of editing flexibility. It is never essential to use these commands. However, if you do, it makes certain tasks much easier.

Imagine an RDE file with many records where you want to replace the mixed and incorrect text values ‘SN’ and ‘sn.’ in the NUMBER field to a uniform ‘s.n.’. This could be done manually, record by record but it would take a long time. Using FoxPro commands, the task can be done in seconds.

Numerous data processing functions can be undertaken with one-line commands using a small number of programming keywords. The commands can be made to apply to one record, tagged or filtered records or all records in a file.

An example FoxPro command is: Replace COUNTRY with ‘Malaysia’ all. The replace command is the most commonly used. The all keyword tells BRAHMS to do this for all records in the open file.

You can execute FoxPro commands whenever the button is activated on the toolbar. As FoxPro commands could be damaging, this button is only enabled in RDE, extract files and other temporary work files, but not in main database files.

Command operators

<table>
<thead>
<tr>
<th>Command</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>Equal to</td>
</tr>
<tr>
<td>&gt;</td>
<td>Greater than</td>
</tr>
<tr>
<td>&lt;</td>
<td>Less than</td>
</tr>
<tr>
<td>$</td>
<td>Is included in</td>
</tr>
<tr>
<td>&lt;&gt; or #</td>
<td>Not equal to</td>
</tr>
</tbody>
</table>

Some commonly used text string and numeric functions

<table>
<thead>
<tr>
<th>Command</th>
<th>Does what</th>
</tr>
</thead>
<tbody>
<tr>
<td>ALLTRIM()</td>
<td>Remove leading and trailing blanks</td>
</tr>
<tr>
<td>Upper(), Lower()</td>
<td>Convert to upper / lower case</td>
</tr>
<tr>
<td>Str()</td>
<td>Convert a numeric field to character format</td>
</tr>
<tr>
<td>Substr()</td>
<td>Extract a portion of a character field</td>
</tr>
<tr>
<td>Strtran()</td>
<td>search and replace characters within a text string</td>
</tr>
<tr>
<td>Val()</td>
<td>Convert a character field to numeric format</td>
</tr>
</tbody>
</table>

Some sample commands to try now

- Select BotanicalRecords > Add/edit botanical records using Rapid Data Entry files.
- Create a new file and add at least 20 blank records.

Using the ‘replace’, ‘upper’ and ‘lower’ commands

- Select the toolbar and add a new command line Replace GENUS with “JUNIPERUS"
- Execute this command. This will add this genus name in upper case to the current record.

- Modify the above command to Replace GENUS with “JUNIPERUS” all
- Execute this command. This will add this genus name in upper case to the all records.
Now add and execute the commands (change the exact content of the commands if appropriate)

- Replace GENUS with lower(GENUS) all
- Replace GENUS with upper(GENUS) all
- Replace NUMBER with "12345" all
- Replace NUMBER with "A"+ alltrim(NUMBER)+"Z" all
- Replace COLLYY with 1899 all
- Replace COLLYY with COLLYY + 100 all
- Replace TAG with "" for LAT = 0 and LONG = 0
- Replace FAMILY with "Compositae" for FAMILY = "Asteraceae"

**Using the ‘substr’ command**

- Add and execute the command ‘Replace genus with upper(substr(GENUS,1,1)) + lower(substr(GENUS,2)) all

**Experimenting with the strtran() function**

- In the same RDE file, add and execute the command Replace COLLECTOR with “Smith, A.B.” all
- Now Replace COLLECTOR with strtran(COLLECTOR,"A.B.","C.D.") all

**Using ‘for’ to select records**

- Tag some records in your RDE file then use Replace COLLMM with 12 for tag = "***"
CREATING A NEW DATABASE PROJECT

The template database

When you first install BRAHMS, you can log into the so called ‘Template database’. This is an empty database provided as part of the standard BRAHMS system installation. The template database is used to create new database projects. **Do not enter data into the template database.** These data would be lost when you next upgrade BRAHMS.

- Log into BRAHMS ensuring the **Project** is set to ‘Template’. Note that **Data in** is set to ‘template\database’. This is a folder within your BRAHMS installation folder.

A database project is a group of related database files held in a single folder (e.g. c:\brahmsdata-conifers\database). All projects are registered and named in the BRAHMS database manager.

Create a new database

Creating a new database is a first step for all new BRAHMS users. Existing users may also want to setup a new project from time to time. You can create and register as many separate databases as you need. To create your own database:

- Using your normal file manager (e.g. Windows explorer), create a folder on any drive (local or shared/networked). This folder will be where all files associated with the project will be stored. Choose a name such as ‘c:\brahmsdata-mydatabase’.
- When logged into the **template** database, select **File > Create new database/project…**
- Select your new folder name as prompted on this form.
- Give the project a name and a short code.
- Click **OK** to proceed to create and login to the new database.

When you create a new project, a series of subfolders is created under the main folder name. Of these, the most important is DATABASE. This is where your actual database is stored. The other subfolders are default locations for different BRAHMS files – these can be changed later.

The database manager

The database manager is a file in BRAHMS that stores details about the names, locations and some further properties concerning your database(s).

- Select **File > Database manager** to open this file.
The NETMODE setting can be ‘S’ or ‘M’ to indicate single or multi-user login for the project in question. Unless your BRAHMS configuration options and/or permissions prevent it, you can edit the netmode when logging in. For example, on networked, multiuser systems, the database administrator will occasionally need to login in single user mode to re-index the database.
SOME ADMINISTRATION TOPICS

Re-indexing your database

Database index files (.CDX files) allow rapid access to your data. These files are automatically kept up to date as you add or edit data. Nevertheless, periodic re-indexing can speed up system performance.

- Select Admin > Project/database management > Re-index and pack data files... and proceed to re-index your database.

![Image of re-indexing and packing database dialog box]

Backing up your data

- Have you located and read the help file text on backing up? If not, open the help file now and search for 'Backing up'.

Backing up is the process of copying valuable files to a safe place. Copying your files to the same disk as the one your files are on is not recommended - all your eggs are in one basket. **There is only one way to absolutely ensure the safety of your data – rigorous adherence to a regular program of backing up of your data. It is a nuisance to backup but this is a much better alternative than the loss of your data.**

- If backing up an RDE file, make sure you copy the DBF and the FPT files.

User access permissions

Each listed user can be assigned database access permissions. This is only important on networked systems with multiple users. If you are using your own research database, you would always have full admin level access.

- Select the new record with your user name and click the **Access** extra toolbar.
- Remove the tick from the **Administration level access** box.
- On the displayed form, you can select the various user permissions.
- Now tick the **Administration level access** box AGAIN to ensure you have maximum access. The ACCESS GROUPS field will display ‘ALL’.

- Access groups, discussed in the BRAHMS help file, enable database administrators to select which options each user can access. The entry ‘ALL’ provides unrestricted access to all database options.
Access permissions screen. In this example, user access is restricted to RDE and the user is unable to switch to Advanced mode. All users have Vital functions.