Getting started with BRAHMS v8
Updated November 2021

If you have not installed BRAHMS or connected to a database, refer to the installation guide.
This introductory guide provides a rapid walk-through some of the key functions and features
available in BRAHMS v8. No previous experience with the system is expected.
The separate BRAHMS manual covers all aspects of system operation including
administration, configuration, connections to data stores, import and export, Rapid Data
Entry, editing, report design, image management and mapping.
The examples in this document mostly refer to the demo conifer database but you can
use another v8 database if you have one available. You can also request a quick
migration of your own data, free of charge.

For licensing enquiries, contact brahms@innovation.ox.ac.uk
To obtain an evaluation version, visit https://herbaria.plants.ox.ac.uk/bol/brahms/software/evaluations
Technical enquiries, contact brahms@plants.ox.ac.uk
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BRAHMS Version 8
Managing Natural History
BRAHMS is a scalable management system for preserved, fossil and living natural history collections as well
as those undertaking floristic or taxonomic research. Its development is based on almost 30 years of
database implementation.
For collection managers in museums, botanic gardens, herbaria and seed banks, BRAHMS helps integrate
your data for management and research, increasing outputs and productivity.

Data integration for research and collection management is a key objective with BRAHMS. Taxonomic data lie at
the core of the system.

Some database project examples:
•
•
•
•
•
•
•

manage a herbarium, grasshopper or beetle collection;
develop a comprehensive botanic garden or seed bank management system;
create a catalogue of fungi or cultivated plants;
produce an annotated checklist for a mountain in Cameroon;
create an online portal to search and display your data, images and maps;
help prepare a monograph for a family or a genus;
or all of these together within a larger natural history museum or herbarium.
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BRAHMS has been developed to store all categories of natural history collection.

BRAHMS development priorities
Intuitive - similar to MS Office applications
Scalable - from individual researcher to multi-site enterprise systems
Taxonomic Core - comprehensive across disciplines
Integrating Digital Assets - including preserved and living collections
Modular - allow others to develop, including web-based add-ons
International - with respect to data store and user interface
Sustainable - long term development plan with Oxford University Innovation

Online videos
Online training videos can be found on: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos

Building a natural history database
Introduction
The development of a well organised database is an important activity for managers and researchers.
The strategy you adopt will vary depending on your resources, the amount of data to manage and your
short and longer term objectives. However, in all these cases, the paths to successful database
development are broadly similar.

Hardware
For individual researchers running their own show, the software and the database will be installed on a
personal computer running Windows or on a Mac with Windows emulation. Aside from having
sufficient disk space and as much RAM as possible (8GB or ideally more), there are no special
requirements other than that the .NET version is sufficiently up to date. However, bear in mind that
performance is broadly related to how well resourced your infrastructure is. An under-resourced server
and/or client workstations leads to poorer performance.
For institutions with large collections, perhaps many millions, and many simultaneous users, the
database will be stored on a server and it is very important that this is well resourced. The server will
need sufficient disk space, adequate RAM and a good processor. If you try to run any large database
on an inadequately resourced server, performance will be poor.
The BRAHMS software itself will either be installed on a shared drive that all users can access – or on
individual client workstations. You can also have a set up with remote server log in by users located
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on different sites. On larger networks, the set up you adopt will be fine-tuned to achieve the
maximum performance, a specialised IT task that is not further discussed here.
In addition to the server where the database and usually the BRAHMS software are stored, the role of client
workstations should not be underestimated. When you log into the BRAHMS software, the system uses the
resources of the local workstation/PC. Thus, even if your server is extremely well resourced, underresourced workstations will not perform well.
In summary, cutting corners on hardware set up is something of a false economy when it comes to
established a healthy database environment, all the more so when there are large databases and
many users. Institutions need to invest appropriately in managing their digital assets.

Data migration
You may have data in an earlier version of BRAHMS, in Excel or Access tables or in other database
packages. These data are important and can be migrated into BRAHMS. V7 databases are automatically
upgraded (refer to the BRAHMS manual) and data in Excel can be imported to BRAHMS via RDE. Data
held in other packages will require some form of migration input.

Optimising data capture
Data entry efficiency (speed + accuracy) can be sensibly optimised for all projects, be they small or large.
While smaller number of records can be added directly into BRAHMS, the recommended procedure for larger scale data
capture is to use Rapid Data Entry (RDE). Data are added to external RDE spreadsheets (themselves portable minidatabases) and after checking, these data are transferred into the main database. RDE files can themselves be optimised
for specific projects by setting up the desired fields and field order.
To take full advantage of RDE, your database can be kick-started by importing useful dictionaries of
data, for example collector, taxa and geographic names. Lookup lists can be added for any field where
you have a fixed set of values. Although lookup lists can be generated on the fly, it’s usually best to
have these defined in advance. You are then in a position to force selection for a defined list or allow
the data entry person to add new entries. A more complete range of optimising procedures is
discussed in the RDE section of the main guide.

Exploring your data
BRAHMS allows you to explore your data in smart spreadsheets or data grids. While BRAHMS forms
are great for data editing, the data grids, together with the many toolbar options, are used for viewing,
sorting, filtering, calculating and analysis. Data grids are virtualized, ensuring they are fast even if you
are working in table with millions of records.

Reports
Aside from using the data export options provided in BRAHMS, you may want to create report
templates for lists, labels, loan forms and others. You can gradually build up a library of handy report
templates – and many of the tricks to learn for that are reviewed in detail in the report design section
of the main guide. Learning to design cool reports is one aspect of mastering BRAHMS where users
with interest to do so can go the extra mile, delving into complete range of report design options as
laid out, for example in https://www.stimulsoft.com/en/documentation and
https://www.youtube.com/user/StimulsoftVideos

Mapping
Most projects want to produce maps and again, all the procedures for creating maps using different
GIS options such as QGIS are reviewed in the manual map section. Bear in mind that if you are online,
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you have access not only to the in-built ArcGIS API but also the map point location editor. One of the
handiest features in BRAHMS v8 is the ability to view data records and map points together,
dynamically linking these to highlight the current data record, and respect filters.

Exporting data
Aside from reporting, all data can be exported to Excel or CSV – and all such exports respect your
currently selected column views, applied filters and sort order. You can also export data as Darwin Core
Archive (DwC-A) format. Forthcoming is a new XML designer that will allow you to export to XML using a
user-defined XML schema.

Special management areas
In addition to the powerful system-wide features and functions listed above, BRAHMS includes
specialist modules for managing museums, herbaria, botanic gardens and seed banks. These modules
have been developed collaboratively with numerous institutions ensuring that provide the day to day
curation and research support that projects need.
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Taxa, Museums, Botanic Gardens, Seed Banks
BRAHMS includes various specialist modules notably those that manage taxa, museums/herbaria,
botanic gardens and seed banks. These modules provide the day to day curation and research support
that projects need. The following notes provide an introduction to some of these features.

Taxonomic data
BRAHMS has separate tables for Higher Classification, Families, Genera and Species, the latter
including infraspecific names and cultivars. All the key ICN and ICNCP ranks are covered. There are also
separate tables to store authors, common names, plant uses and text descriptions. While some
projects require only a simple list of names, others assemble comprehensive details as required for
different types of research publication. In this respect, BRAHMS manages all details of nomenclature
for taxonomic research.

Field selection in the higher classification table.

A sample species table with the data grid showing selected columns. The taxa form and column management tool
are opened and docked right.
BRAHMS v8 – Getting started

8|Page

Collections and preserved specimens
If a collection event leads to vouchers being taken, the physical specimens will likely be deposited in a
museum/herbarium collection. They may be formally mounted and incorporated to a museum
collection. Examples are birds, insects, fungi, ferns, higher plants – or indeed any form of preserved
natural history material.
Each specimen is linked to a collection event which stores the collector name and number, date,
location, initial identification and usually some other details about the collection. A single collection
event may lead to multiple specimens (or duplicates). These may be deposited at different institutions
and be different types of material (an insect or bird, a herbarium sheet, a DNA sample, seeds, wood
section, fruit, etc.).
Specimens may have barcodes and/or accession numbers. They may be ‘types’ of a certain category
(holotype, isotype, etc.). Each specimen may have multiple determinations.

Selecting a specific collection category alters the toolbar menu options.

–

Material may be held in boxes and folders as shown here. Boxes can be barcoded as can the folders and specimens.

•
•
•
•
•
•
•
•
•
•
•
•
•

Scalable, to manage any size of collection.
Allows multiple users to add and edit data simultaneously, with access permission controls.
Store data for any category of specimen.
Store one to many physical specimens per collection event.
Store one to many determinations per specimen.
Add project specific fields to your database structure if these are not included by default.
Link images to specimens as physical files or media library URLs.
Design report templates for lists, loan forms, labels and determination slips.
Optimize specimen data capture using the Rapid Data Entry module.
Import specimen data donated from other databases and websites.
Use specimen data to develop checklists and analyse diversity for differently scaled areas.
Map geo-referenced collections to show distribution by species or any other queried dataset.
Publish specimen details with images online.
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Botanic Gardens
For more details, refer to the BRAHMS manual section BRAHMS for Botanic Gardens.
https://herbaria.plants.ox.ac.uk/bol/content/software/v8/BRAHMS_Manual.pdf

The BRAHMS living collections module manages data and images for botanic gardens, arboreta and
other horticultural projects. The module, which already takes advantage of all standard features to
edit, query, report, map, export and publish online, adds comprehensive additional features for
managing garden accessions and plants. As these data are fully integrated within BRAHMS, it becomes
possible to develop a comprehensive system for both management and research.

Taxa

Develop an infrastructure of taxa from higher classification down to infra-specific levels, cultivars
and hybrids. Add synonymy, common names, trade names, groups, series, grexes, patent IDs,
descriptions, native distribution, hardiness, shade tolerance, water requirements, conservation
status and more.

Garden Layout

Garden locations can be recorded from a defined garden area or theme zone down to pinpoint map
location with options to record bed, grid numbering and map shape files.

Institutions

Manage comprehensive lists of institutions and addresses as suppliers or those receiving material
through purchase or transaction exchanges.

Accessions

Store accession records including details of the type and quantity of material received, who and
where from, the original or derived source, and the initial identification.

Propagation

Add propagation details for all plants including cuttings, grafts and seed - linking this to production
propagation to supply garden plants.

Plant records

Add plant records, linked to accessions, storing all details of plants in the garden from planting out
to their disposal, loss or death.

Plant events

Events for plants can be recorded. Examples are plant maintenance and stock-checks; name
changes; observations on leaf flush, flowering, fruiting, disease and cause of death.

Plant requests

Requests can be logged in the plant management requests file with their ongoing status.

Transactions

Manage incoming material, garden exchanges and other transaction categories as defined.

Vouchering

Vouchers may be added from original wild collections and/or established garden plants.

Images and
Documents

Link images and documents to accessions and plants (physical files or media library URLs).

Legal

Add details of all permits and related documentation for the acquisition and exchange of material.

Query/Report

Query on any table or field using simple or compound saved query commands.

Map

Map the location of garden plants using the in-built ArcGIS API or using your preferred GIS.

Online

Publish a virtual botanic garden or online plant catalogue.
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Changing the Category of collection to Living Collection reveals the relevant menu options for these data.

The key tables and relationships associated with the Living Collections module.
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Seed Banks
The seed module, developed collaboratively with the Millennium Seed Bank at RBG Kew, has broad
curation and research applications for projects who collect, store, test and distribute seed. Seed
accession and test data, related vouchers and images are all integrated and can be published online.

•
•
•
•
•
•
•
•
•
•
•
•

Seed accession records including passport and wild origin data can be managed with links to voucher details,
project and agreement details.
Data on seed cleaning, cleaning time and results and store bank locations are stored.
Duplication to other seed banks.
Seed counting processes including absolute and estimates via seed sample weights, incorporation of x-ray
and/or cut-testing analysis to provide adjusted quantities per collection.
Germination test design including addition of multiple conditions and treatments.
Germination test results provided for both germination and viability percentages, including germination rate.
Automated scoring of collections/batches against Millennium Seed Bank Partnership Seed Conservation
Standards.
Documents can be linked to accession, individual plant, species and other records. Examples are material
transfer documents.
Images of seed or plants in their original habitat can be added, together with voucher images as available.
Projects can extend the standard BRAHMS seed data file structures by editing BRAHMS extension files which
become a part of your database.
The Rapid Data Entry (RDE) module is used to capture new seed accessions and test data or to transfer data
from other formats such as Excel worksheets.
You can design your own website and publish a virtual seedbank garden or online plant catalogue directly
from BRAHMS using BRAHMS WebConnect. For example see the RBG Kew MSBP data Warehouse at
http://brahmsonline.co.uk/msbp .
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Logging in to the demo database
If you haven’t installed BRAHMS and/or do not have a link to the conifer database or any another
database, refer to the installation guide:
https://herbaria.plants.ox.ac.uk/bol/content/software/v8/BRAHMS_installation.pdf
Otherwise, the login steps for the conifer database are as follows:
•

Locate and run the brahms.exe file. You can create a desktop shortcut to this file. If the application does not start,
refer to the troubleshooting section in:
https://herbaria.plants.ox.ac.uk/bol/content/software/v8/BRAHMS_installation.pdf

•

On the log in form, choose the settings as shown below:

A splash screen window is displayed as the system gathers the necessary resources. With BRAHMS Authentication,
the default user name is ‘Demo’ and the password is lower case ‘demo’. The above settings assume that the conifer
database has been located in your personal Documents\BRAHMS folder and is named brahms.db (=default).

Note: if the conifer database is located on a shared drive and your data connection is to the shared drive,
multiple users can be logged into the database at the same time.

The opening screen will vary, depending on your background image selections
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Task 1: Set system background and taxon author display
To set the BRAHMS application background, select System > Options > Background Image. For
example, you can also display background images from your own image gallery choosing Use my
images.
Background

Author display
You can control how author names appear in calculated species names. For example, you may want
to exclude authors or only include the lowest ranked epithet author name.

Note: If author names are excluded by default, you can override this on a name by name basis using the Force Author
options found on the main species form:

No force: Alnus incana subsp. rugosa var. occidentalis
Force all: Alnus incana L. subsp. rugosa R.T.Clausen var. occidentalis (Dippel) C.L.Hitchc.
Force last: Alnus incana subsp. rugosa var. occidentalis (Dippel) C.L.Hitchc.
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Task 2: Opening tables and using data grids
Working on a small screen?
If you are working on a small screen and/or have the screen resolution set to lower values, the toolbars
may collapse as shown in the screen below.

Clicking on the collapsed toolbar opens the otherwise hidden options.

Opening and closing tables in data grids
By default, BRAHMS uses data grids with context sensitive toolbars to browse, locate, sort, edit, query and analyse
your data. Data tables are opened using a single click on the selected menu entry. The use of forms is discussed in the
Using data forms task.
•

On the Taxa menu, click once on Families.

When a table opens, the toolbar will usually change to Data Tools which is where you will likely find what
you need to do next. For Taxa specific tools or if you want to open another taxa table, return to the Taxa
menu.
•

To close the table, select the X next to the opened table name.

Closing a table using the X mark next to the table name.

•

Alternatively, to close tables, use Alt+X. Function keys such as Alt+X are listed using Shift+F1 when in any data
grid. A grid must be active to do this. Refer to the section on navigation and function keys.
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Opening multiple tables
See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#multiple

You can open and utilise different tables at the same time. The task here is to open the main family,
genus, species and collection events tables.
•
•
•

On the Taxa menu, click once on Families.
Return to the Taxa menu and click on Genera. Repeat this now for Species. Note that each time you open a
table, the Data Tools toolbar is activated – so you have to return to the Taxa menu.
Finally, on the main menu, select Collections and choose Collection events.

Each table has a tab which can be selected to view the data in that table.
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Task 3: Docking tables
See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#multiple
Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#opendocklink

To view two or more of the tables opened in the last exercise at the same time, use the docking
features. Tables can be detached from a centrally docked position and docked to the side, above or
below another table – or dragged to a different monitor. Forms, images, external web sites, maps,
query tools and others are all dock-able.
Positioning tables and other items takes a little practice - there are many potential docking
arrangements. The tasks here assume one monitor – but if you have two or more, take advantage of
these to display tables and other screens fully undocked.
•
•
•

Drag table tabs to undock them. Initially, it can be a little tricky to grab the tab correctly. When you drag any table
to undock it, a series of yellow ‘docking boxes’ appear.
Drop the table on one of these docking options – the central box redocks the table as it was.
As a first try, drag the genus table and re-dock this by placing and releasing your mouse pointer over one of the
yellow docking points. Repeat for the species table.

Here the genus table has been undocked and is floating above the other tables. And the species table is about to be
docked to the right.

•

Repeat this with the collection events table, docking elsewhere or moving it to a different monitor.

The various tables rearranged with collections events dragged off the main application

The yellow docking points appear when you drag a table from a docked position.. Docking options vary depending on
the windows opened. Some experimentation is required.
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Map screen undocked and dragged to separate monitor. In this example, data records have been tagged using different colour
symbols, these reflected on the map. A column summary on the Tag column is also active and docked to the right of the main grid.

Left monitor with genus and species tables docked next to the TROPICOS Weblink. The collection events table is shown in the lower
small screen and an ArcGIS map with Google Images on the left monitor. The events table is set to update to the selected species
record – together with the map and the images.
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Task 4: Data grid navigation, Function keys, Zoom
There are a few tricks to learn to move efficiently between columns and rows in BRAHMS data grids.

Navigation
BRAHMS draws data from your data store into the grids and presents these data with low-lag data
virtualization, storing as much data as possible in memory. As you scroll up or down, the system
retrieves the relevant data to memory and refreshes the opened grid.
•
•

Close all the tables used in the previous task.
Select Collections > Collection Events to open the events table. Activate the grid by clicking in any data cell. The
default mode for data grids is read-only mode, nothing can be edited.
Action in non-edit mode

Keys

Move to the next / previous column

Right / Left Arrow

First/Last column

Home / End keys

First/Last row

CTRL Home / CTRL End

Next /Previous row

Down / Up arrow

Scroll up and down

PgUp / PgDn

Select or activate a column or cell

Click in the cell

Action in edit mode

Keys

Move to the next / previous column

TAB / Shift TAB

Next /Previous row

Down / Up arrow or use Alt+Arrows in memo or numeric fields

Function keys

List Function Key assignments using Shift+F1. Before selecting Shift+F1, click anywhere in a data grid. Examples are
using F6 to tag or un-tag records; using the DEL key to mark a record for deletion; CTRL+E to swap to Edit mode and
Alt+X to close a table.

•
•

Press Ctrl+F6 to ensure all records in this table are untagged.
Now press F6 several times to tag a few records.
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•

Try Alt+F6 to set a filter on the tagged records. Ctrl+F11 removes all filters.

Record Zoom
The record Zoom function is a great way to summarise and view the current record – but you can also use it for
navigating to a column. This can be used in any table.

Double-click on the Zoom field header name e.g. ‘Description’ to go to that column. If it is not visible, it will be made so. The Zoom
window can be undocked. You can show all fields or just the non-empty fields.

Using a Right Click on data grids
Right-clicking on data grids opens up a short-cut menu to widely used options.

The functions offered here are all available on the main toolbar. Most have shortcut F keys.
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Task 5: Adjust and save column views
Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#columnviewvideo

When you open a table, the default data grid columns will be visible. You can adjust and save new
column views using the Column Management options. This applies to all tables. Selecting a particular
set of visible columns is a handy way to view selected data and speed up specific editing tasks.
•

Select Collections > Collection events then Grid Tools > Manage Columns…

The Column Management Tool allows you to select visible columns.

You can save a view using Save layout on the Grid Tools toolbar. This will create a small data grid view file with
extension .dgv saving this file to your BRAHMS\Columns folder. You can create as many views as you want,
choosing the view using the Layout dropdown.
Deleting a .dgv file from the Columns folder will remove it from your list. You can also share saved views by copying
the saved dgv file to the application shared\columns folder.

An example view with a selection of re-ordered fields, the records sorted in this case by country + year.

Another way to adjust visible columns and field order is to right-click on any of the column headers. This opens a
dialogue form with options to show hidden columns and alter the column order. You can also drag column headers to
change order and size. And here’s another handy way to hide columns:
•

Click anywhere on the Family table to make it the active table. Now click in a field you want to
hide. Select the Grid Tools tab and then Hide Current – this hides the selected field.

In summary, there are various ways to select and view columns in your data grids. Different views are
useful for specific editing tasks. Views can be deleted and shared.
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Task 6: Sorting Records
See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#sorting

Sort on single or multiple columns
If column sorting is enabled, tables can be sorted on single columns by clicking on the column header, Shift
Clicking on multiple column headers … or using the Sorting Tool. To use header-click sorts, make sure this
option is enabled by setting Enable Header Sort on the Sort toolbar dropdown. You can also set this on by
default for all tables in System > Options > Grid options.

•
•
•

Select Taxa > Genera to open the main genus table.
Click once on the Family column header to sort A-Z. Click the same column header again to sort Z-A.
Click a third time to remove the sort.
You can combine as many columns as needed using Shift Click on columns headers.

Saving complex sort commands
Using the Sorting tool, you can add fields of any type to create complex sorts. You can save these sorts using
the Save option provided.

Using the sort form, any combination of character, numeric, date and logical field can be selected to sort your records.
Complex commands can be named and saved for future use.
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Sorting collection events by collector and number
Collection event field numbers are alphanumeric and thus, by default, sorting the field number column AZ
gives an incorrect sort order.

As can be seen here on the left, sorting these Wilson, EH collections on Field Number gives a bad result. This is resolved
using the calculated field # Field Number (sortable) shown on the right which pads the number field with zeros.

•
•

To display this field, select Grid Tools > # Calc Fields
You could now sort the collection events table on the Collectors + Field Number (sortable) fields but in
reports, still refer to the column Field Number. NB If you do not see data in the sortable field number
field, use Data Tools > Calculate > Recalculate.

Date sorting
Records can be sorted on date fields. For example, you can sort on the audit fields Created By, Created On,
Last Modified By and Last Modified On and such sorts are useful for a variety of purposes.
When you add a new record, the data grid is auto-sorted on the Created On field. But you may find it useful to
sort on this field (click on field header) at other times, perhaps in combination with other fields.
For example, to view records most recently added, you can sort on Created On, clicking the column header
twice to bring the most recently added record to the top of your data grid.
If you want to sort collection events by date, sort on year, month and day in that field order, shift clicking on
fields for multiple selections.

You can also easily sort on the Last modified date, or using the dropdown on that toolbar option, Date Created.
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Task 7: Tagging functions
See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#tagging
Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#tagsandmaps

Tagging refers to the addition of a single character to the TAG field. This field is available in all tables in the
first column. Tagging has multiple uses throughout BRAHMS with record selection and grouping. While the
default tag symbol is *, you can tag records with different symbols or numbers. Each of these can be assigned
a colour. Tags are user-specific, thus one users’ tags do not interfere with those of another working in the
same table.

Select System > Options > Grid Options to edit the default colour options. Clicking on the Tag option on the Data Tools
toolbar adds the selected symbol to the TAG field. The Tag toolbar dropdown provides a list of handy tagging options.

Transfer tags

Copy tags to child records, for example, species tags can be copied to all collection events,
specimens and det history records

Count tags

A count of all tagged records.

Filter on tagged

Show only tagged records *

Tag all

Tag all records in table – respecting any filters

Clear all grid tags

Remove your tags from all tables – does not respect filters

Clear current grid tags

Remove your tags from the current table – respecting current filters

Invert tags

Tagged records are set to no tag; records that had no tag are tagged *

Tag with

Choose tag symbol from list

Records tagged with a variety of symbols.
Tag groups
By using Tag > Tag Groups, you can create and save ‘groups’ based on your tagged records. Tag groups can be shared with
other users.
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Some sample tag groups in the species table. One of these groups (Doubtful entries) is shared and thus can be seen by
other database users.

Tag transfers
Tag > Transfer tags provides options to copy tags to related tables, either up or down a data hierarchy. This tool
has multiple applications throughout BRAHMS.

For example, in the species table, tagging down would copy tags to child records including collection events and living
accessions. By select the ‘Tag all child records’, the tags will also be copied to the specimen and determination history tables.
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Task 8: Column summaries
See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#colsum

The column summary option lists the different values in the selected column, providing the total number of
records per value.
•
•

Select Collections > Collection events.
Locate and click in the column # Full Name and then select the Summary option on Data Tools. If you do
not see the summary option, refer to the section on small screens.

Here, the summary shows the number of collection events per family. Moving to a different column will update the
summary, assuming Auto-update on column change is selected. Click on the summary columns to sort by field name or
count.

The summary option can also be used to apply filters on one or more selected values.

•

Open any table you want and test the Column Summary function in any column. Moving to different
columns auto-updates the list unless the form option Auto-update on column change is disabled.

•

Try saving a summary list to Excel using the Export option provided on the summary form.

The Summary tool also has a Merge Value option, handy for cleaning up spelling errors and the like.
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Task 9: Find, Filter, Query
Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#datagridfilters

Queries using the grid filter row
See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#explore

•
•

Open the main file collection events table using Collections > Collection Events.
Enter values into the yellow, top grid filter row as shown below. You can use operators *, =, <, >,<=, >=
and combine values using capitalized AND/OR statements. You can also use keywords NOT and NULL. <>
means not. Thus, adding <> NULL shows non-empty records. The grid filter bar is an efficient way to apply
filters and locate records. Note that you must use capitalized key words such as AND and OR.

Using the grid filter row, you can add values to as many columns as needed. For text strings, the default filter mode is
‘includes’. Use = to make a precise match.

An example in the Month field using the operators < and >.

•

You can use * to select ‘starts with’ and ‘ends with’, thus:

Setting a filter where collector name starts with ‘ter (left) or includes ‘ter’ (centre) and right, where the genus ends ‘illa’.

Queries using Selection and +Selection
You can set filters on current cell values using the Selection and +Selection options.
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•

Open the main file collection events table using Collections > Collection Events. Set a filter on a cell
value by clicking on the value and then the Selection toolbar. This option overrides any previous filters.

•

You can add multiple cell-based queries using the +Selection option. As soon as you select Selection
rather than +Selection, the filter will be again restricted to a single value.

Using the Selection toolbar options.

Use the Filter Info toolbar option to list current filters.
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Task 10: Building and saving more complex queries
Using the main Query tool form, you can design and save your own queries. Queries can mix and match
fields of any type. Each command you add is saved unless you remove it from the list. You can then
selectively enable and combine the one-line commands and optionally name and save combinations of
commands.
•

Select the
toolbar option to open the main Query Tool. Use the various drop downs to add the
query commands you want, using Add to add the command to the command list. The AND/OR settings
can be adjusted if necessary.

•

Use Apply filters to run the query.

An example Query Tool form with previously used commands, three commands enabled. You can name and save a
combination of query commands. The Query Tool form can be undocked and dragged off the application.

A further example Query Tool form with previously used commands, four commands enabled. Note that the SQL
command used by BRAHMS is displayed in the lower part of the screen.

Active filters can be displayed using the Filter Info option next to the Filter option.
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Task 11: Saving data to Excel
See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#exporting

Data are easily exported to Excel spreadsheets using the Tag -> Excel or CSV options on Data Tools.
Exporting works only with tagged records. Exports respect applied filters and your currently selected column
view.
In this task, export specimen data from BRAHMS, sorted by family and species name, restricting the export
to some columns and the filter selection to holotypes. Adjust filters as necessary, depending on your data.
•
•
•
•
•
•

Select Collections from the main menu and choose ‘Preserved Specimen’ using the Category drop down.
Select Specimens to open that table.
Now select Grid Tools > Manage Columns and here you can remove any columns you don’t want to
export and sort the table as wanted.
Locate the Type Category column and enter ‘Holo’ or ‘holo’ in the filter bar to apply a filter on Holotypes.
Select Tag > Tag all
You can now use the Export Tagged option to save the tagged records. If you do not see the Export
option, refer to the section on small screens.

Exporting tagged records to Excel.

You can list all saved files using the View option on the Export Data toolbar section.
In data grids, you can click on a record to select the record. You can use Shift Click to select groups of
contiguous records or CTRL Click to select individual records – the same as in other packages. Selected
records are displayed in a shaded colour. Copy the selection using CTRL+C. You can then paste CTRL+V these
records elsewhere, for example to Excel. Be sure to select the correct paste option to format the data
appropriately.
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Task 12: Dynamic weblinks
You can dynamically link your database to external websites as provided on the WebLinks toolbar. WebLink
options will soon be configurable in BRAHMS, allowing you to add the websites that you find most useful.
WebLinks are available from many of the BRAHMS tables, especially when there is a species name in the
table. You can test these options in different tables but for this initial task:
•
•

Select Taxa > Species to open the main species table.
Select WebLinks > POWO (Plants of the World Online).

In this example, the POWO website has been opened on Podocarpus taxifolius, a synonym of Prumnopitys montana.
Moving data grid records auto-updates the open weblink page. The species form is opened on the synonyms tab and the
various windows are docked.

Examples with the ant genus Acromyrmex, top Google Images, lower using AntWeb.
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Task 13: Mapping from the main database
See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#mapping
Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#mappingvideo

NB. You can also map your data to ArcMAP, QGIS, DIVA, Google Earth and GeoCAT. These topics are explained in the
manual.

The in-built ArcGIS API provides a wealth of handy mapping features which you can take advantage of without
installing any further GIS software. You do need to be online.
Some advantages of the in-built ArcGIS tool: * No installation required; * data points are highlighted on the
map as you browse through your data grid; * clicking on a map point locates the grid record, an excellent
way to locate errors; * maps are auto-updated as you apply grid filters; * calculation of Extent of Occurrence
(EOO); * selectable base map including world imagery; * map tagged only or map all, exclude cultivated
records; * search maps; * save map as a png file and import to a document.
•
•

Select Collections > Collection events then select the Mapping toolbar followed by ArcGIS in BRAHMS.
If no filter is applied, by default, this will plot all tagged records. To plot records, tagged or not, adjust the
Tagged only option. The map window can be dragged to another monitor and made full screen size.
A map displaying all conifer collections (no
filters applied).
The setting here does not restrict to tagged
records and a dark gray base map is selected.
The current data grid record in Kenya is hightlighted
on the map.

Here, a filter set on New Zealand with the base
map set to World imagery.
The point colour has been changed and the current
grid record is highlighted.

With the ArcGIS Auto Zoom disabled, you can plot different taxa without changing the current base map area.
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Task 14: Images and Documents
See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#images

Images
Images can be linked to any record in BRAHMS and you can link multiple images to the same record. All
images are listed in the central images table with their full pathname or web URL.
Images may be located in any location including in media libraries and cloud servers. Read more about
managing images in BRAHMS. You can store links to images using a URL – you do not need to have a copy of
the image file.
Images can be viewed from the main file and/or wherever they are linked. As an example, you can link some
images to a species:
•
•

Select Taxa > Species. On Data Tools, select Images… to open the Image Viewer.
Here, you can either use the Link … button or drag images to the Image Viewer.

The Image Viewer has several handy toolbar options (Rotate, Zoom, etc.). You can also use F keys and your mouse to
control the viewer, for example Shift + mouse wheel = zoom in/out around central point.

As discussed in the RDE sections, images can be transferred from Excel files to RDE and also from RDE to
BRAHMS.

Documents
Multiple documents of any type can be linked to any record in BRAHMS. This could be a PDF material transfer
agreement or collection permit linked to a specimen, accession or transaction; a protologue description linked
to a species; a sound file linked to an animal entry; or perhaps a video or slideshow linked to a botanic garden
greenhouse record.

Linking pdf, docx, wav, pptx and xlsx documents to a species record. Media and documents can be opened using the Open
option or double-clicking on the linked entry.
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Task 15: Literature links
You can store references of any category (books, journal articles, websites, etc.) and then link these to any
record in your database. For example, you may want to link a book, a book chapter, a report or journal article
to a species or to a selected text entry for a species.

Adding and editing literature entries
•

Select Biblio > Literature List to open the main table for literature. On the same Biblio menu, you will find
table of literature categories and journal listings.

Viewing reference entries in the main literature table. The demo conifer database includes sample reference entries.

Reference entries can be stored as complete reference text strings in the Full Reference field with no attempt
to separate the text into the component fields – or you can store the reference using the separate fields for
author, title, journal, pages, year, etc. The Full Reference field is auto-updated from the other fields if an entry
is made in the TITLE field.

If the Full Reference field is empty or requires updating, select Recalculate on Data Tools toolbar.

•

You can add some new reference entries using the standard Add option.

Linking references to data
Literature links are created using the Literature option on the Data Tools toolbar.
This option allows you to select any item from your main literature list and link this to the current record. You
can link multiple literature links to any record, optionally adding the relevant page/plate numbers, the link
status (for example ‘Synonymy’) and comments.
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Task 16: Optimising data entry, lookups and shortcuts
When editing data, the challenge is to maximise efficiency. This comes through mastering the use of function
keys, lookups and a few handy tools such as value merging. Function keys make most editing tasks more
efficient, lookups minimise typing and help standardise your data. Other tools help find and clean errors. Users
often assume it’s easier to add/edit data using forms. However, as a rule, it’s faster working in the grids. You can
create and save custom column views and use function keys to look-up and copy data.
•

To enable edit mode (grids and forms), select the Edit option on the Data Tools toolbar or use CTRL+E. By
default, tables are opened in read-only mode.

The behaviour of the data grids changes slightly in edit mode. For example, you will find that TAB and Shift
TAB are needed to move through the fields rather than the left and right arrows.
•
•
•

Select Taxa > Species to open the main species table.
To list available function keys, enter Shift+F1 in an active grid. An example: use Alt+X to close a table.
New records are added using Add on the Data Tools toolbar. You can add a single record or in batches as
offered on the Add drop-down. Adding records enables edit mode. A faster way: use CTRL+N.

•

To mark the records for deletion, use the toolbar option or your DEL key (toggle). To remove these records,
choose Remove records marked for deletion on the toolbar Delete dropdown.

Some fields in the main tables cannot be edited directly - usually fields from a related table or calculated fields. Examples are Genus
and Species Author. To edit these, you must use a lookup. These fields have a lookup icon in the header and have a darker shade.

There are two categories of lookup, both activated using F9, CTRL+L or using Lookup on the toolbar. a)
selecting values from the larger database dictionaries such as people, taxa and place names and b) selecting
values from your central lookup dictionary.
•

In the main species table, Add a blank record and then click in the newly added genus cell. Use F9 or CTRL+L to
open the genus lookup. The specific epithets Species, Subspecies, etc. are typed in as these are free text fields
to be edited.

The field Taxon Status uses values stored in your custom lookup list. The list is edited using Management >
Lookup Lists. In edit mode, the Taxon Status field displays as a drop down because it is registered in the custom
lookups list.

The Edit Lookup Values form allows you to define and edit lookup values as well as the properties of the
lookup field.
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Task 17: Merging data values and records
Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#mergevalues

The tasks here demonstrate Value Merging and Record Merging.

Value merging
The Column Summary tool, as well as listing and giving a count for each different value in the selected
column, can be used to quickly clean up data errors in non-relational, non-read-only fields. Value merging
standardises different spellings of the same value in a column – and is a fast way to find and clean these
errors. You can use value merging in any table – as long as the field is not read-only.
•

In the conifer demo database, select Geo > Gazetteer and select the Major Admin Name and/or Minor
Admin Name columns.

•

Select the Summary tool on the Data Tools toolbar. Sort the summary record by values by click on the value
header.

•

Tag the value(s) to be merged - then select the correct value by click on that record (no need to tag). Use
Merge to Selected to complete the task.

In the example on the left, either spelling of Alpes-Maritimes may be acceptable but clearly, it is better to be consistent.
The right-side example is in the Minor Admin Name column where you will find plenty of other entries to correct. Note that
a grid filter has been used with the Minor Admin example to narrow down the summary entries.

Record merging
Record merging leads to 2 or more similar or identical records being merged into one record with a resulting
deletion of the merged records. When record merging takes place, the system must ensure all child records
are moved to the selected record. Record merging is used to clear up double (or more) entries of entire
records – for example if you had two or more entries in the genus table for the same genus, both with linked
species, you could not simply delete one, you would need to merge the records.

The Merge records tool is found on the Edit dropdown.

In this example, you can merge some gazetteer records.
•

In the conifer demo database, select Geo > Gazetteer and enter ‘jiang’ in the grid filter bar for the field
Locality Name. Click on the column header to sort by name. Locate the entries ‘Nu Jiang - Qi Qu divide’
which is entered twice, slightly differently.

•

Tag the one you want to remove and then select the record to merge into. Then select the Merge option on
the Edit dropdown on Data Tools.
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In this example, the calculated field shows
each of these Nu Jiang records has 1 linked
collection event. These will be joined under
the selected entry.
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Task 18: Using data forms
Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#speciesformvideo

Forms are provided for most of the main data grids. As well as being used for editing, they often provide
options to list related records and calculated fields. The data on forms update as you navigate to different
data grid records. Forms can be docked (default), dragged elsewhere and re-sized. In order to edit data on
forms, you need to be in Edit mode. If you are not, data will not be saved and lookup options are not enabled.

The form icon indicates if you are in Edit mode or not.

Most forms have the option to edit data and then Save or Cancel the edits made. Once any edits have been
made, the form is given a red surround.
•

As an example, select Taxa > Species and then select the Form option on Data Tools. The species form is, by
default, docked right.

•

Review the various tabs on the species form, moving through grid records to update the form.

Data can be viewed and edited using grids or forms. Forms can be resized, docked or dragged to separate monitors.
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Summary of collections displayed from the main species form. Move to a new species in the grid to update the form. Note
that in the conifer database, only accepted names (Taxon Status=’Accepted’) have linked collection events/specimens.

An example form in the main collection events table showing the specimen tab. The table has the calculated field #
Specimens included in the view and this has been used to sort the records.
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Task 19: Adding custom fields to BRAHMS
BRAHMS databases and the tables they contain are provided with a defined structure. However, as well as
defining the data columns that you choose to see in your data grids, you can add new data storage fields that
are specific to your project.
You can choose the field name, type and size. These custom fields become a permanent part of your database
unless you subsequently opt to delete them. This also applies to RDE files.
•
•
•

Select Collections > Collection events - or another table if you prefer.
Select Grid Tools > Manage Columns.
Add one or more new columns using the Custom Columns tab. Field names can include spaces.

The Column Manager form - options to add and edit custom columns are enlarged on the right side.

On this form, you have the option to add new fields. If the field is of type Text and you set Max. Chars to NULL
or 0, this creates a text field equivalent to a v7 memo field. Using the Editor tab options, you can list and
remove your custom fields. Field position can be modified using the buttons provided above the field list. You
can also load existing field layouts, edit and save as a new layout.

Custom fields appear in your main data grids, assuming they are selected for inclusion in your data grid view. They have a
different font to standard fields.
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Task 20: Register and open a Rapid Data Entry file
Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#labelstoppt

While data can be entered directly into BRAHMS, RDE is recommended for entering larger numbers of records
and also as a first step when importing or transferring data from other software packages such as Excel.

RDE files are entirely separate mini SQLite databases linked to your main BRAHMS database. They provide
portability and flexibility – optimising data entry and cleaning.
You can store data in one or more RDE files and use these data to create summaries, maps, reports, manage
images, and in general, use most of the BRAHMS tools and functions.
This example opens an RDE file of specimen data prepared by John Wood (Oxford based botanist) from his
field work in Bolivia.
•

•
•
•

First download the file RDE_Bolivia_JRIWood.zip and open the zip to the folder Documents/BRAHMS/RDE.
This is the default location for RDE files. The zip file includes an RDE file of specimens and a report template
sample for labels.
Log into BRAHMS – choosing any project and select Rapid Data Entry > RDE File Manager. This will list any
RDE files located in your registered RDE folders.
To open the RDE file downloaded above, double-click on the RDE manager entry ‘JRI Wood Bolivia’.
Explore this RDE file using the Summary option on Data Tools.

An RDE opened with a column summary in the Family field. The summary shows the number of records per different family.
Clicking in a different column will update the summary.
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RDE folders
All users, regardless of their database role, have access to their default Documents\BRAHMS\RDE folder.
Beyond this, non-admin and non-manager users need to be given access to folder(s) by the system
administrator or database manager.

RDE files can be stored in any registered folder. New folders are added using the Add option of the left panel.
Administrators can register new RDE folders and assign access permissions to one or more non-admin level users.
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Task 21: Import from Excel to RDE
Data and images can be imported from .xlsx tables into RDE using the Excel Data Import Wizard. This allows
you to match the columns in the Excel file to your RDE file. The matching between Excel and RDE columns can
be adjusted as necessary to pull in as many fields as possible. This process also allows you to import data from
custom fields – assuming the custom fields have been added to your RDE file. Fields in foreign languages can
be mapped to the standard names. For example, your Excel table may store country names in a column with
heading PAÍS or 国家 or PAYS. The task is to align this with the standard RDE field COUNTRY.
This example uses collection data (species x locality) taken from museum specimens. But you could work with
other data, for example, just a list of taxon names. If you do not have your own data to experiment with,
download the sample Excel:
https://herbaria.plants.ox.ac.uk/bol/Content/Software/v8/SampleExcel_RDE_Import.xlsx.
•
•
•
•
•

Select Rapid Data Entry > RDE File Manager then use the Add option on the Data Tools toolbar to create a
new RDE file. Choose the Category ‘Specimens’ – and provide a file title. Enter Next.
If you want to add some custom columns to the RDE, use the options provided in the right-side panel.
Knowing whether to add custom data fields requires some knowledge of what the default fields are.
When you Finish, the new RDE will be created and registered in your RDE manager.
Open the file by double-clicking on the record. Then choose Rapid Data Entry > Import from Excel…
Follow the Excel Data Importer steps as prompted.

These screens show the matching process (left) and the data processed and ready to import to RDE. This may not be fully
possible if the data are in the wrong format – but you will probably be able to get close. Data in different formats can be
adjusted in Excel or processed after transfer to a custom field in RDE.

If your Excel file includes image references as physical file names (path + file name) or URLs, these can be imported to and
viewed in the RDE file. If there is more than one image cited in the same field, the entries should be comma or semi-colon
separated or on different lines.

Once the data have been processed by the Excel Wizard, you can then choose to transfer selected records or all the data
into your new RDE file.
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Task 22: Mapping from RDE
If you do not have an RDE file with specimen data, download the file RDE_Bolivia_JRIWood.zip and open the zip to the
folder Documents/BRAHMS/RDE.
You need to be online for this task which uses the in-built ArcGIS API (no installation required). You can also map to
QGIS, Diva GIS, ArcGIS, Google Earth and GeoCAT. Further mapping tasks are provided in the section Mapping from the
main database.
•
•

To map the RDE file opened above, select Maps > ArcGIS in BRAHMS.
Initially, if no records are tagged, no points will be plotted. To map the entire file, remove the mark from Tagged
only on the map toolbar.

The RDE file mapped with the Tagged only option de-selected.

•
•
•
•

If you now tag some records, you can use the Tagged Only option to restrict the map to tagged.
The yellow point represents the current grid record. This updates as you move to a different grid record.
With the map remaining open, set a filter on a geographic area. In the example below, the text ‘vela’ has been
added to the grid filter bar in the field Minor Area Name, here selecting the area Velasco.
You can change the base map using the option provided on the ArcGIS screen.

On the map, Use Tag Colours is selected, in this example plotting the Convolvulaceae in a different colour.
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Task 23: Adding and editing map points in RDE
You need to be online to use this feature. The map location editor can be used in RDE and in the main tables
for collection events and botanic garden plant points. You can use the map location editor to add a new map
point or edit an existing one. The editor opens a map form which updates as you move through the data grid.
A right-click on the map resets the point position and either auto-saves this to the grid or awaits confirmation
via the Save option.
•

In the opened RDE file, select the Map point editor option on the map toolbar. In Edit mode, you can also use the
standard F9 lookup from the latitude or longitude fields.

Once opened, the location editor can be used to edit points and altitude in your data grid.

The map location editor displaying the current point, set to Auto-save. In this mode, a right-click on the map will update the Latitude
and Longitude values in the data grid without using the Save option. This example screen has no zoom and is displaying the entire
globe.

The same point displayed at a very different zoom level. Right-click the map to edit point location.
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Location editor settings
Setting

Notes

Base map

Choose base map that best suits the editing task in hand.

Auto-zoom on/off

If selected, as you move to different records, the map zooms to the current point using your
zoom scale setting.

Zoom to marker

Zoom to current point based on your Zoom Scale setting.

Zoom Scale

Choose the optimal zoom setting. Maximum shows a world map.

Reset Zoom

Reset the zoom, if adjusted, to your current setting.

Map units

Select the entry mode for manually editing data.

Lat Long checked

Mark a record as ‘map checked’.

Auto-save

If selected, a right-click on the map will adjust the point and save the map point change.

Location searching
The internal Map Point Editor, dynamically connected to your data grids, has a location search tool. Localities can be
searched for by name or part of a name, adding a region or country to help improve the results listed. Clicking on the
suggested locations list adds a blue suggestion marker to the map. A right-click on the map adds the map reference to
the data grid.

Using the location search option with the Map Editor.
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Task 24: Reporting from RDE
You can print reports directly from RDE or send the outputs to documents, Excel or elsewhere. Report design is
covered in detail in the BRAHMS manual:
https://herbaria.plants.ox.ac.uk/bol/content/software/v8/BRAHMS_Manual.pdf. The reporting example here uses the
sample report included in the RDE file download: RDE_Bolivia_JRIWood.zip
To produce some labels from your opened RDE file, tag some records as the reporter only works with tagged
records. If you wanted to print labels for the entire file, use the Tag all option on the Tag dropdown.
•

To open the sample report template provided, select Reports then File > Browse and locate the report file ‘RDE
specimen label sample.mrt’. It will be located in the same folder as your RDE file – Documents/BRAHMS/RDE.

The reporter opened here on the Home tab which is where report design can be edited. Report design is not further discussed
here.

•

To view the labels, select the Preview tab at the top of the reporting application.

On the Preview tab, you can choose various Save options including MS Word. If exported to MS Word etc., your labels can be
edited prior to printing.
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Task 25: Creating your own database
You can create a new database project in just a few steps. For practice purposes, it will be fastest to create
this using SQLite but you could also use MSSQL Server or PostgreSQL. Another decision is whether to use an
existing data store or whether to create a new one. For example, you could create a new database/project
using the existing conifer data store conifers.db, bearing in mind that a single data store can hold more than
one database project. This example starts by creating a new project in the default personal brahms.db store.

Creating a new database or data store - SQLite

To create a new project in the existing brahms.db data store:
•
•

Log into the default personal store. If this has no database projects (as initially installed), as soon as you log in, the
Database Projects Manager Form will open.
If you already have created a project here, select System > Manage Database Projects… > New and enter the
project name and a few other details as requested.

You can also create an entirely separate personal SQLite data store in any folder location:

To create a new data store:
•
•
•
•

Log into the default personal store (or any other data connection).
Select System > Manage Data Connections > New choosing the Local Filesystem option.
Choose Create a new file…
Once created and saved, you can log in to this new

BRAHMS v8 – Getting started

48 | P a g e

Creating a new database – MSSQL Server
To create a new data store in MSSQL Server (local or server based) or to connect to an existing one:
Prerequisite: You must be able to connect to an MSSQL Server with sufficient permission to create new
databases and to manage user login accounts. This will usually be someone with a Database Administrator
(DBA) role.
•
•
•
•

Log into the default personal store (or any other data connection).
Select System > Manage Data Connections > New choosing the ‘MSSQL Data Provider’ option.
Choose Create (a new MSSQL hosted data location).
Follow the Wizard Tool instructions – which will lead to a script being run in the connected MSSQL Server to
create a completely new BRAHMS data store.
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Task 26: Adding data to a newly created database
You can add data directly to BRAHMS or import data from RDE files. The tasks here will do both. These examples use data
grids rather than forms.

Adding data directly to your new database
In practice, you would not use this method to add many new records but it is reviewed here in multiple steps
to explain the process.
•

Select Taxa > Higher Classification. Here, you can add a new record, adding as much detail as you wish from
Kingdom to Order. You may want to add custom fields to define additional taxa levels.

•

Select Taxa > Family. Add a family name, here e.g. Acrididae (grasshoppers). Use a lookup in the Order field
to connect the Higher Classification record just added.

•

To link an author, use a lookup in the Family Author field. On the name selection form, use New if the name
is not included in the compiled author name(s) list. You may also have to add new person
names/abbreviations.
• A similar process can now be used to add genus and species records, using lookups and adding new
authors where needed.

In this example, some higher classification data have been added (top grid) from Order name upwards. The field Superorder has been
added as custom field. The family table (lower grid) also has some custom fields added.

Having added the family and genus names, the species level data can be added, in this case, 4 subspecies of Melanoplus sanguinipes, with
their authors. A lookup is used in the Genus and Author fields.

Using RDE to add the above data
In practice, if adding multiple taxa names as above (or adding new specimens etc.), it will be far faster to add
these using RDE. The key point is that new family, genus, species and author names can be more easily added
to a single RDE table. The same applies to specimen and other data categories. If the names are new to
BRAHMS, they are added to the relevant database tables when the RDE file is transferred into BRAHMS.
BRAHMS v8 – Getting started

50 | P a g e

A sample RDE file with 4 entries added. The first 4 columns have been copied down using the F4 copy function.

Transferring from RDE into BRAHMS
•

•
•

On the main menu, select Rapid Data Entry and open the RDE table you wish to transfer to BRAHMS. You can optionally
restrict the transfer to tagged records and if you wish to do that, tag the records to transfer. Otherwise, this is not
necessary.
Back on the Rapid Data Entry menu, select Transfer RDE to BRAHMS…. and on the ‘Step 1: Run data analysis’ page, you
can restrict to tagged if necessary.
Select Run Analysis – this will list the data that are new to BRAHMS and those that already exist. The report enables
you to review the quality of the data.

A part of an analysis report.

•

Now select Next to go to Step 2: Import the Data and select Import Data

The data transfer from RDE to BRAHMS adds new records to your database as needed.
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Task 27: Adding a user account and setting permissions
Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#useraccount
Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#userpermissions

Adding users and setting permissions is described in detail in the BRAHMS guide. You can add users with
BRAHMS, Local Windows account or Domain account authentication. Users can be assigned access and
permissions to one or more databases.
In this example, add a new BRAHMS authentication user and assign this user some permissions. Feel free to add
other user accounts including your own local Windows account, this allowing you to log in with no additional
password entry. NB. You cannot save changes to the ‘Default’ permission set as used by Administration.
•
•
•

Log into the demo database and select System > Manage Users and Permissions.
Choose the User List option above the grid (or use Add on Data Tools).
Select New User > Add BRAHMS User adding the User Name, Password and ‘Known As’ name. Do not set the user as an
Administrator.

Select Create this User and follow the prompts through.

Close the user form and select the new user on the User Management data grid. Then select the Access and
Permissions option.
•

After editing the settings, assign new permission role name (here ‘Transaction Manager’) and use the Apply
As option to save the settings and assign this Permission Set to the current user.

Choose the options you feel appropriate for this user.

Save the permissions as a permission set using Apply As. This set can then be used for other users.
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Task 28: Two challenges
Create screens similar to those shown below:

This conifer database example with docked windows shows collection event data filtered to Pinus hwangshanensis, a map, a column
summary and POWO and Google Images weblink options.

In the main species table, generate the above screen for a species, (here Araucaria nemorosa). The sorted species list has
selected columns including the IUCN category which is filtered to vulnerable taxa. It includes website links to Tropicos and
Google Images. The species form is opened listing collections.
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